aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-06-13 21:52:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-06-13 21:52:15 +0800
commit9b696c695da6116342f09738395e498b47fab2d8 (patch)
tree2d6a53ba31b130900962616ffbba7e7dcd427974 /editors
parenta10729a421cedd30846625b02735d9d6844bcda7 (diff)
downloadfreebsd-ports-gnome-9b696c695da6116342f09738395e498b47fab2d8.tar.gz
freebsd-ports-gnome-9b696c695da6116342f09738395e498b47fab2d8.tar.zst
freebsd-ports-gnome-9b696c695da6116342f09738395e498b47fab2d8.zip
- Use DISTVERSIONSUFFIX instead of DISTFILES
- Add my LOCAL to MASTER_SITES - Simplify WRKSRC - Use USES=tar:tgz - Regenerate patch file with makepatch: - Reformat pkg-descr - Take maintainership
Diffstat (limited to 'editors')
-rw-r--r--editors/hexedit/Makefile15
-rw-r--r--editors/hexedit/files/patch-search.c (renamed from editors/hexedit/files/patch--search.c)6
-rw-r--r--editors/hexedit/pkg-descr10
3 files changed, 15 insertions, 16 deletions
diff --git a/editors/hexedit/Makefile b/editors/hexedit/Makefile
index fa27e999e0b9..55479bb957e9 100644
--- a/editors/hexedit/Makefile
+++ b/editors/hexedit/Makefile
@@ -3,23 +3,24 @@
PORTNAME= hexedit
PORTVERSION= 1.2.13
+DISTVERSIONSUFFIX= .src
CATEGORIES= editors
-MASTER_SITES= http://rigaux.org/
-DISTFILES= ${DISTNAME}.src.tgz
+MASTER_SITES= http://rigaux.org/ \
+ LOCAL/sunpoet
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= View and edit files in hexadecimal or ASCII
LICENSE= GPLv2
-WRKSRC= ${WRKDIR}/${DISTNAME:S/-${PORTVERSION}//}
-
GNU_CONFIGURE= yes
+USES= tar:tgz
+WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/hexedit man/man1/hexedit.1.gz
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hexedit ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/hexedit.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/hexedit ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/hexedit.1 ${STAGEDIR}${PREFIX}/man/man1/
.include <bsd.port.mk>
diff --git a/editors/hexedit/files/patch--search.c b/editors/hexedit/files/patch-search.c
index a9dbb6ca1ae1..177daa1ac004 100644
--- a/editors/hexedit/files/patch--search.c
+++ b/editors/hexedit/files/patch-search.c
@@ -1,6 +1,6 @@
---- search.c.orig Tue Nov 8 17:16:47 2005
-+++ search.c Sat Jul 29 15:21:47 2006
-@@ -30,6 +30,18 @@
+--- search.c.orig 2008-11-07 15:50:57 UTC
++++ search.c
+@@ -30,6 +30,18 @@ static int searchA(char **string, int *s
if (!ask_about_save_and_redisplay()) return FALSE;
if (!displayMessageAndGetString(msg, last, tmp, tmp_size)) return FALSE;
diff --git a/editors/hexedit/pkg-descr b/editors/hexedit/pkg-descr
index 3c34a0975423..fdf1bb48d3ff 100644
--- a/editors/hexedit/pkg-descr
+++ b/editors/hexedit/pkg-descr
@@ -1,8 +1,6 @@
-Hexedit view and edit files in hexadecimal or in ASCII.
-hexedit shows a file both in ASCII and in hexadecimal.
-The file can be a device as the file is not whole read.
-You can modify the file and search through it.
-You have also copy&paste, and save to file functions.
-Modifications are shown in bold.
+Hexedit view and edit files in hexadecimal or in ASCII. hexedit shows a file
+both in ASCII and in hexadecimal. The file can be a device as the file is not
+whole read. You can modify the file and search through it. You have also
+copy&paste, and save to file functions. Modifications are shown in bold.
WWW: http://rigaux.org/hexedit.html