aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>2001-12-02 02:22:09 +0800
committershige <shige@FreeBSD.org>2001-12-02 02:22:09 +0800
commitdf6194d65a5fefe5f27a96eec3be917026fed1f3 (patch)
treef9a43c785147eccf4f795dfe3d036aa6bd43bd04 /editors
parent92b0d94cfa684ee7c86ec146e68ac75bd24f92e1 (diff)
downloadfreebsd-ports-gnome-df6194d65a5fefe5f27a96eec3be917026fed1f3.tar.gz
freebsd-ports-gnome-df6194d65a5fefe5f27a96eec3be917026fed1f3.tar.zst
freebsd-ports-gnome-df6194d65a5fefe5f27a96eec3be917026fed1f3.zip
Inactivate and Remove editors/apel-emacs.
Activate editors/apel.
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile2
-rw-r--r--editors/apel-emacs/Makefile126
-rw-r--r--editors/apel-emacs/distinfo1
-rw-r--r--editors/apel-emacs/files/_pkg.el4
-rw-r--r--editors/apel-emacs/files/apel-setupel.el.in9
-rw-r--r--editors/apel-emacs/files/patch-aa10
-rw-r--r--editors/apel-emacs/files/patch-ac11
-rw-r--r--editors/apel-emacs/pkg-comment1
-rw-r--r--editors/apel-emacs/pkg-descr39
-rw-r--r--editors/apel-emacs/pkg-plist57
-rw-r--r--editors/apel-emacs/scripts/configure13
11 files changed, 1 insertions, 272 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 87d9c5c7495a..c878af471a2e 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -3,7 +3,7 @@
SUBDIR += AbiWord
SUBDIR += aee
- SUBDIR += apel-emacs
+ SUBDIR += apel
SUBDIR += apel-emacs20
SUBDIR += apel-mule
SUBDIR += apel-xemacs21-mule
diff --git a/editors/apel-emacs/Makefile b/editors/apel-emacs/Makefile
deleted file mode 100644
index 2c1bad2e134c..000000000000
--- a/editors/apel-emacs/Makefile
+++ /dev/null
@@ -1,126 +0,0 @@
-# New ports collection makefile for: apel for emacs
-# Date created: 23 September 1998
-# Whom: Shigeyuki FUKUSHIMA <shige@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= apel
-PORTVERSION= ${APEL_VER}
-CATEGORIES= editors elisp
-MASTER_SITES= ftp://ftp.m17n.org/pub/mule/apel/ \
- ftp://ftp.etl.go.jp/pub/mule/apel/ \
- ftp://ftp.media.kyoto-u.ac.jp/pub/mule/apel/ \
- ftp://ftp.win.or.jp/pub/word/mule/apel/ \
- ftp://ftp.eos.hokudai.ac.jp/pub/GNU/emacs/mule/apel/
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
-
-MAINTAINER?= shige@FreeBSD.org
-
-# distfile version
-APEL_VER= 10.3
-# setupel filename
-APEL_SETUPEL= apel-setupel.el
-# document install directory by install-doc target
-APELDOCDIR?= share/doc/apel
-# apel lispdir
-APEL_LISPDIR?= ${LOCALBASE}/${EMACS_SITE_LISPDIR}
-APEL_VERSION_SPECIFIC_LISPDIR?= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
-
-# This is a master port.
-PORTCLASS?= master
-
-# emacs port setup
-.if (${PORTCLASS} == "master")
-EMACS_PORT_NAME= emacs
-# emacs requires *-setupel.el
-REQUIRE_SETUPEL= YES
-.endif
-
-# target name for make build
-ALL_TARGET?= elc
-# environments
-SCRIPTS_ENV+= TARGETS="${APEL_SETUPEL}"
-PLIST_SUB+= APELDOCDIR=${APELDOCDIR} APEL_SETUPEL=${APEL_SETUPEL}
-MAKE_ARGS+= PREFIX="${LOCALBASE}" \
- LISPDIR="${APEL_LISPDIR}" \
- VERSION_SPECIFIC_LISPDIR="${APEL_VERSION_SPECIFIC_LISPDIR}"
-
-.include <bsd.port.pre.mk>
-
-.if defined(EMACS_PORT_NAME)
-# depends on custom: emacs-19.34 or mule-19.34
-.if (${EMACS_VER} == "19.34")
-BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT_NAME}
-RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT_NAME}
-.endif
-.if defined(EMACS_PACKAGESDIR)
-BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/xemacs-packages/lisp/xemacs-base/advice.el:${PORTSDIR}/editors/xemacs-packages
-RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/xemacs-packages/lisp/xemacs-base/advice.el:${PORTSDIR}/editors/xemacs-packages
-.endif
-.else
-.BEGIN:
- @${ECHO} "Error: Bad port."
- @${ECHO} "You must define EMACS_PORT_NAME."
- @${FALSE}
-.endif
-
-pre-configure:
-.if defined(REQUIRE_SETUPEL) && (${REQUIRE_SETUPEL} == "YES")
- @${CP} ${FILESDIR}/${APEL_SETUPEL}.in ${WRKDIR}
-.endif
-
-pre-install:
-.if defined(EMACS_PACKAGESDIR) && defined(EMACS_PACKAGES_SUBDIRS)
- @${MAKE} mkdir-site-packages
-.endif
-.if defined(EMACS_PACKAGESDIR) && defined(XEMACS_PKGNAME)
- @${MAKE} pkg-el-install
-.endif
-
-post-install:
-.if defined(REQUIRE_SETUPEL) && (${REQUIRE_SETUPEL} == "YES")
- @${MAKE} setupel-install
-.endif
-.if defined(EMACS_PACKAGESDIR) && defined(MANIFEST)
- @${MAKE} manifest-install
-.endif
-.if !defined(NOPORTDOCS)
- @${MAKE} doc-install
-.endif
-
-###############################################################################
-#
-# local functions
-#
-mkdir-site-packages:
- @(for i in ${EMACS_PACKAGES_SUBDIRS} ; do \
- ${MKDIR} ${LOCALBASE}/${EMACS_PACKAGESDIR}/$${i} ; \
- done)
-
-pkg-el-install:
- @(if [ -f ${FILESDIR}/_pkg.el ] ; then \
- ${MKDIR} ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME} ;\
- ${INSTALL_DATA} ${FILESDIR}/_pkg.el \
- ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}/_pkg.el ;\
- fi)
-
-doc-install:
- @${MKDIR} ${LOCALBASE}/${APELDOCDIR}
- @(cd ${WRKSRC} ; \
- for i in ChangeLog README.* ; do \
- ${INSTALL_DATA} $${i} ${LOCALBASE}/${APELDOCDIR}/ ; \
- done)
-
-setupel-install:
- @${INSTALL_DATA} ${WRKDIR}/${APEL_SETUPEL} \
- ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp
-
-manifest-install:
- @${RM} -f ${WRKDIR}/${MANIFEST}
- @${CAT} ${PLIST} | ${GREP} -e "^%%EMACS_PACKAGESDIR%%" | \
- ${SED} -e "s;^%%EMACS_PACKAGESDIR%%/;;" > ${WRKDIR}/${MANIFEST}
- @${INSTALL_DATA} ${WRKDIR}/${MANIFEST} \
- ${LOCALBASE}/${EMACS_PACKAGESDIR}/pkginfo/
-
-.include <bsd.port.post.mk>
diff --git a/editors/apel-emacs/distinfo b/editors/apel-emacs/distinfo
deleted file mode 100644
index ecc5b1469e4d..000000000000
--- a/editors/apel-emacs/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (apel-10.3.tar.gz) = a7357019aeeae69f95fb3cdc5a39bb1f
diff --git a/editors/apel-emacs/files/_pkg.el b/editors/apel-emacs/files/_pkg.el
deleted file mode 100644
index d3d55387912f..000000000000
--- a/editors/apel-emacs/files/_pkg.el
+++ /dev/null
@@ -1,4 +0,0 @@
-;;;###autoload
-(package-provide 'apel
- :version 1.16
- :type 'regular)
diff --git a/editors/apel-emacs/files/apel-setupel.el.in b/editors/apel-emacs/files/apel-setupel.el.in
deleted file mode 100644
index 1047e259b991..000000000000
--- a/editors/apel-emacs/files/apel-setupel.el.in
+++ /dev/null
@@ -1,9 +0,0 @@
-;;
-;; @(#)apel-setupel.el -- apel emacs load-path setup elisp file.
-;; -- by shige@FreeBSD.ORG
-
-(setq load-path (append '(
- "@@LOCALBASE@@/@@EMACS_LIBDIR@@/site-lisp/apel"
- "@@LOCALBASE@@/@@EMACS_LIBDIR_WITH_VER@@/site-lisp/emu"
- ) load-path))
-(provide 'apel-setupel)
diff --git a/editors/apel-emacs/files/patch-aa b/editors/apel-emacs/files/patch-aa
deleted file mode 100644
index d8595b1a9a38..000000000000
--- a/editors/apel-emacs/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.orig Tue Oct 27 23:58:27 1998
-+++ Makefile Sun Nov 1 20:44:21 1998
-@@ -17,6 +17,7 @@
- PACKAGEDIR = NONE
- VERSION_SPECIFIC_LISPDIR = NONE
-
-+all: elc
-
- elc:
- $(EMACS) $(FLAGS) -f compile-apel
diff --git a/editors/apel-emacs/files/patch-ac b/editors/apel-emacs/files/patch-ac
deleted file mode 100644
index a602fff48d9f..000000000000
--- a/editors/apel-emacs/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- APEL-MK.orig Wed Dec 22 13:14:21 1999
-+++ APEL-MK Wed May 10 23:45:36 2000
-@@ -41,7 +41,7 @@
- ;; Make "emu" subdirectory.
- "emu"
- ;; Don't make "emu" subdirectory.
-- ""))
-+ "emu"))
-
- ;; The directories where APEL and EMU modules will be installed.
- ;; These two variables will be generated from other variables above.
diff --git a/editors/apel-emacs/pkg-comment b/editors/apel-emacs/pkg-comment
deleted file mode 100644
index 195399718c18..000000000000
--- a/editors/apel-emacs/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A Portable Emacs Library for emacs
diff --git a/editors/apel-emacs/pkg-descr b/editors/apel-emacs/pkg-descr
deleted file mode 100644
index 5f029e89a2ad..000000000000
--- a/editors/apel-emacs/pkg-descr
+++ /dev/null
@@ -1,39 +0,0 @@
-A Portable Emacs Library.
-
---- Emacs Library Porting
-
-APEL is programed by MORIOKA Tomohiko <tomo@m17n.org>.
-
- APEL stands for "A Portable Emacs Library". It consists of
- following modules:
- apel
- - alist: utility for Association-list
- - calist: utility for condition tree and condition/situation-alist
- - filename: utility to make file-name
- - install: utility to install emacs-lisp package
- - mule-caeser: ROT 13-47-48 Caesar rotation utility
- - path-util: utility for path management or file detection
- emu
- - broken: provide information of broken facilities of Emacs.
- - emu: bundled in tm-7.106 compat module
- - invisible: provide features about invisible region
- - mcharset: provide MIME charset related features
- - pccl: utility to write portable CCL program
- - pces: provide portable character encoding scheme features
- - pcustom: provide portable custom environment
- - poe: emulation module mainly for basic functions and special forms/macros
- - poem: provide basic functions to write portable MULE programs
- - static: utility for static evaluation
-
- APEL is installed the following directory tree:
- ${LOCALBASE}/share/emacs/site-lisp/apel/ --- apel
- ${LOCALBASE}/share/emacs/19.34/site-lisp/emu/ --- emu
-
-
-To use apel, put the following setup into your ~/.emacs:
-
- (require 'apel-setupel)
-
-WWW: http://cvs.m17n.org/elisp/APEL/index.en.html
-
---- Porting by shige <shige@FreeBSD.ORG>.
diff --git a/editors/apel-emacs/pkg-plist b/editors/apel-emacs/pkg-plist
deleted file mode 100644
index 6e36cd992f32..000000000000
--- a/editors/apel-emacs/pkg-plist
+++ /dev/null
@@ -1,57 +0,0 @@
-%%EMACS_LIBDIR%%/site-lisp/apel/alist.el
-%%EMACS_LIBDIR%%/site-lisp/apel/alist.elc
-%%EMACS_LIBDIR%%/site-lisp/apel/calist.el
-%%EMACS_LIBDIR%%/site-lisp/apel/calist.elc
-%%EMACS_LIBDIR%%/site-lisp/apel/filename.el
-%%EMACS_LIBDIR%%/site-lisp/apel/filename.elc
-%%EMACS_LIBDIR%%/site-lisp/apel/install.el
-%%EMACS_LIBDIR%%/site-lisp/apel/install.elc
-%%EMACS_LIBDIR%%/site-lisp/apel/path-util.el
-%%EMACS_LIBDIR%%/site-lisp/apel/path-util.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/apel-ver.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/apel-ver.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/broken.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/broken.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/emu.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/emu.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/inv-19.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/inv-19.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/invisible.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/invisible.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/mcharset.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/mcharset.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/mcs-ltn1.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/mcs-ltn1.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/mule-caesar.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/mule-caesar.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pccl.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pccl.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pces.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pces.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pces-raw.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pces-raw.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pcustom.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pcustom.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/poe.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/poe.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/poem.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/poem.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/poem-ltn1.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/poem-ltn1.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/product.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/product.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pym.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/pym.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/richtext.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/richtext.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/static.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/static.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/timezone.el
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu/timezone.elc
-%%EMACS_LIBDIR_WITH_VER%%/site-lisp/%%APEL_SETUPEL%%
-@dirrm %%EMACS_LIBDIR%%/site-lisp/apel
-@dirrm %%EMACS_LIBDIR_WITH_VER%%/site-lisp/emu
-%%APELDOCDIR%%/ChangeLog
-%%APELDOCDIR%%/README.en
-%%APELDOCDIR%%/README.ja
-@dirrm %%APELDOCDIR%%
diff --git a/editors/apel-emacs/scripts/configure b/editors/apel-emacs/scripts/configure
deleted file mode 100644
index 083bc7164d33..000000000000
--- a/editors/apel-emacs/scripts/configure
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-for i in ${TARGETS}
-do
- if [ -f ${WRKDIR}/${i}.in ]; then
- cat ${WRKDIR}/${i}.in | /usr/bin/sed \
- -e "s;@@LOCALBASE@@;${LOCALBASE};g" \
- -e "s;@@EMACS_LIBDIR@@;${EMACS_LIBDIR};g" \
- -e "s;@@EMACS_VER@@;${EMACS_VER};g" \
- -e "s;@@EMACS_LIBDIR_WITH_VER@@;${EMACS_LIBDIR_WITH_VER};g" \
- > ${WRKDIR}/${i}
- fi
-done