aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-24 22:56:28 +0800
committervs <vs@FreeBSD.org>2005-10-24 22:56:28 +0800
commitead7000459df6733f7f3d294482f2264c32676f9 (patch)
tree13a321f4edeaa23aad6814be9f6c90238becdd82 /editors
parent6aa8d8f6560709205f9362e61ef4f1559d4bcc41 (diff)
downloadfreebsd-ports-gnome-ead7000459df6733f7f3d294482f2264c32676f9.tar.gz
freebsd-ports-gnome-ead7000459df6733f7f3d294482f2264c32676f9.tar.zst
freebsd-ports-gnome-ead7000459df6733f7f3d294482f2264c32676f9.zip
Fix build by falling back to makeinfo
Diffstat (limited to 'editors')
-rw-r--r--editors/psgml-emacs19/Makefile7
-rw-r--r--editors/psgml-mule/Makefile7
2 files changed, 14 insertions, 0 deletions
diff --git a/editors/psgml-emacs19/Makefile b/editors/psgml-emacs19/Makefile
index 940ce051c12b..e9a65e0f47c4 100644
--- a/editors/psgml-emacs19/Makefile
+++ b/editors/psgml-emacs19/Makefile
@@ -14,4 +14,11 @@ MASTERDIR= ${.CURDIR}/../psgml
# emacs port setup
EMACS_PORT_NAME= emacs19
+BUILD_DEPENDS+= makeinfo:${PORTSDIR}/print/texinfo
+
+ALL_TARGET= compile
+
+post-build:
+ cd ${WRKSRC} && makeinfo *.texi
+
.include "${MASTERDIR}/Makefile"
diff --git a/editors/psgml-mule/Makefile b/editors/psgml-mule/Makefile
index 9ad2199dcf9d..a212a8c2b3bb 100644
--- a/editors/psgml-mule/Makefile
+++ b/editors/psgml-mule/Makefile
@@ -14,4 +14,11 @@ MASTERDIR= ${.CURDIR}/../psgml
# emacs port setup
EMACS_PORT_NAME= mule
+BUILD_DEPENDS+= makeinfo:${PORTSDIR}/print/texinfo
+
+ALL_TARGET= compile
+
+post-build:
+ cd ${WRKSRC} && makeinfo *.texi
+
.include "${MASTERDIR}/Makefile"