aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-08-23 01:48:35 +0800
committerhrs <hrs@FreeBSD.org>2015-08-23 01:48:35 +0800
commit52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2 (patch)
tree445c3e315f03aa972de87391f921c655e4634f60 /editors
parent069a5644197c0b8b71f45d29221cd5192af4c720 (diff)
downloadfreebsd-ports-gnome-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.tar.gz
freebsd-ports-gnome-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.tar.zst
freebsd-ports-gnome-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.zip
- Split ghostscript into X11-independent and -dependent parts:
* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
Diffstat (limited to 'editors')
-rw-r--r--editors/ted/Makefile4
-rw-r--r--editors/texmacs/Makefile4
-rw-r--r--editors/texmaker/Makefile4
-rw-r--r--editors/texstudio/Makefile2
4 files changed, 7 insertions, 7 deletions
diff --git a/editors/ted/Makefile b/editors/ted/Makefile
index 67c2ae1a7a54..204e2e9d0a67 100644
--- a/editors/ted/Makefile
+++ b/editors/ted/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ted
PORTVERSION= 2.23
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors
MASTER_SITES= ftp://ftp.nluug.nl/pub/editors/ted/ \
http://fossies.org/linux/misc/
@@ -26,7 +26,7 @@ GTK2_DESC= Use GTK2 instead of MOTIF
WRKSRC= ${WRKDIR}/Ted-${PORTVERSION}
USE_XORG= xext xft
-USES= ghostscript:run iconv
+USES= ghostscript:x11,run iconv
GNU_CONFIGURE= yes
MAKE_ENV= DEF_AFMDIR="-DAFMDIR=\"\\\"${AFMDIR}/\\\"\"" \
DEF_INDDIR="-DINDDIR=\"\\\"${INDDIR}/\\\"\"" \
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index 9868057c1d0c..085888501577 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= texmacs
PORTVERSION= 1.0.7.21
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= editors print
MASTER_SITES= ftp://ftp.texmacs.org/TeXmacs/tmftp/source/ \
http://www.predatorlabs.net/dl/
@@ -40,7 +40,7 @@ PDF_DESC= Experimental PDF renderer
FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
FREETYPE_CONFIGURE_WITH=freetype=linked
-GHOSTSCRIPT_USES= ghostscript
+GHOSTSCRIPT_USES= ghostscript:x11
GHOSTSCRIPT_CONFIGURE_WITH= gs=yes
ICONV_USES= iconv
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 05ba554a71b0..51458a19c53b 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -3,7 +3,7 @@
PORTNAME= texmaker
PORTVERSION= 4.4.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 3
CATEGORIES= editors
MASTER_SITES= http://www.xm1math.net/texmaker/
@@ -13,7 +13,7 @@ COMMENT= LaTeX Development Environment
LIB_DEPENDS= libpoppler.so:${PORTSDIR}/graphics/poppler
-USES= desktop-file-utils ghostscript:run pkgconfig qmake tar:bzip2
+USES= desktop-file-utils ghostscript:x11,run pkgconfig qmake tar:bzip2
_USE_QT4= gui network xml webkit \
moc_build rcc_build uic_build
_USE_QT5= concurrent network printsupport script webkit widgets \
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index 770e9fdff587..2fba2864a192 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -2,7 +2,7 @@
PORTNAME= texstudio
PORTVERSION= 2.9.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/TeXstudio%20${PORTVERSION}