aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-11-01 00:49:14 +0800
committerbapt <bapt@FreeBSD.org>2011-11-01 00:49:14 +0800
commit20446c8becb4f37a312ff572950d9ebef66a7a4c (patch)
tree2aa96bc1eb273546f8e6e8d3c553e9bb9ffbfb19 /editors
parente1b9c074271ffbe9612be0b45684e58b17048fbc (diff)
downloadfreebsd-ports-gnome-20446c8becb4f37a312ff572950d9ebef66a7a4c.tar.gz
freebsd-ports-gnome-20446c8becb4f37a312ff572950d9ebef66a7a4c.tar.zst
freebsd-ports-gnome-20446c8becb4f37a312ff572950d9ebef66a7a4c.zip
- fix build after new poppler import
- while here fix plist (should have been fixed long time ago :() [2] Reported by: pointyhat (pav)
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx9
2 files changed, 10 insertions, 1 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 5588e76ac2c5..ff0a9eb5f524 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -395,7 +395,7 @@ post-install:
@cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s lib \( -type f -o -type l \) -print >> ${PLISTF}
@cd ${LODESTDIR}/${PREFIX} && ${FIND} -d lib/libreoffice -type d -exec ${ECHO_CMD} "@dirrm {}" \; >> ${PLISTD}
-.for subdir in applications icons mime mime-info mimelnk
+.for subdir in applications icons mime mimelnk
@cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s share/${subdir} \( -type f -o -type l \) -print >> ${PLISTF}
@cd ${LODESTDIR}/${PREFIX}/ && ${FIND} -d share/${subdir} -type d \
-exec ${ECHO_CMD} "@unexec ${RMDIR} %D/{} 2>/dev/null || ${TRUE}" \; >> ${PLISTD}
diff --git a/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx b/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx
index 59a896b3d577..55e570ad8f50 100644
--- a/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx
+++ b/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx
@@ -1,5 +1,14 @@
--- clone/extensions/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.orig 2011-10-26 13:23:40.000000000 +0000
+++ clone/extensions/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2011-10-26 13:23:57.000000000 +0000
+@@ -150,7 +150,7 @@
+ void writeJpeg_( OutputBuffer& o_rOutputBuf, Stream* str, bool bWithLinefeed )
+ {
+ // dump JPEG file as-is
+- str = ((DCTStream *)str)->getRawStream();
++ str = str->getBaseStream();
+ str->reset();
+
+ int c;
@@ -489,7 +489,7 @@ void PDFOutDev::endPage()
printf("endPage\n");
}