aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-08-16 01:44:36 +0800
committerarved <arved@FreeBSD.org>2004-08-16 01:44:36 +0800
commit213ac661aa994fcdb9e2400e4f39183bcf3cfd9e (patch)
tree9d4234eb0dffd9d62039e415817c1e940a816053 /editors
parent887aea8ecc6b4bb7933ba83f17cdc98de1a6d5ae (diff)
downloadfreebsd-ports-gnome-213ac661aa994fcdb9e2400e4f39183bcf3cfd9e.tar.gz
freebsd-ports-gnome-213ac661aa994fcdb9e2400e4f39183bcf3cfd9e.tar.zst
freebsd-ports-gnome-213ac661aa994fcdb9e2400e4f39183bcf3cfd9e.zip
Fix build with gcc 3.4
Diffstat (limited to 'editors')
-rw-r--r--editors/wily/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/editors/wily/Makefile b/editors/wily/Makefile
index e224c0808c44..c8a61c6f0c01 100644
--- a/editors/wily/Makefile
+++ b/editors/wily/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/rc:${PORTSDIR}/shells/rc
USE_XLIB= YES
GNU_CONFIGURE= YES
USE_GMAKE= YES
+USE_REINPLACE= YES
MAN1= wgoto.1 win.1 wreplace.1 Tag.1 mktags.1 Man.1
PORTDOCS= index.html intro.html download.html credits.html FAQ.html \
@@ -33,6 +34,10 @@ PORTDOCS= index.html intro.html download.html credits.html FAQ.html \
TUTEDOCS= hello.c start typescript
TUTESHS= findword script send_to_gary
+post-patch:
+ cd ${WRKSRC}/tools/win; ${REINPLACE_CMD} -e 's," in " __FUNCTION__ "()",,' \
+ win.c wgoto.c wreplace.c
+
# Run the configure script in the tools directory.
post-configure:
@${RM} ${WRKSRC}/tools/win/config.cache