aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-12-28 12:28:50 +0800
committermarino <marino@FreeBSD.org>2013-12-28 12:28:50 +0800
commit290a03858b6e415b1f98838071b6cf42a02c1ba9 (patch)
tree61049ab757aa87b00f9b085c559eb19f34bc364b /editors
parente80fa10b92850d17656b10399747da9825f9de56 (diff)
downloadfreebsd-ports-gnome-290a03858b6e415b1f98838071b6cf42a02c1ba9.tar.gz
freebsd-ports-gnome-290a03858b6e415b1f98838071b6cf42a02c1ba9.tar.zst
freebsd-ports-gnome-290a03858b6e415b1f98838071b6cf42a02c1ba9.zip
editors/beav: Unbreak after staging support attempt
After recent commits, beav was broken on every platform for a couple of reasons. Primarily the Makefile had a bug in it, so it was unexecutable. Secondly, the "man page fix" was done in ${STAGEDIR} using sed -i, causing the resultant .bak file to also be installed, or at least orphaned. Poudriere caught that issue. While here, add DragonFly support.
Diffstat (limited to 'editors')
-rw-r--r--editors/beav/Makefile6
-rw-r--r--editors/beav/files/patch-termio.c2
2 files changed, 5 insertions, 3 deletions
diff --git a/editors/beav/Makefile b/editors/beav/Makefile
index c0185a4f8bfa..8b6937a5a923 100644
--- a/editors/beav/Makefile
+++ b/editors/beav/Makefile
@@ -20,12 +20,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R:S/.//}
ALL_TARGET= beav
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DUNIX -DBSD -DNOPROTO"
+post-patch:
+ @${REINPLACE_CMD} -e 's|(OFILES):|$$(OFILES):|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/beav.1
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/beav ${STAGEDIR}${PREFIX}/bin/beav
${INSTALL_MAN} ${WRKSRC}/beav.1 ${STAGEDIR}${PREFIX}/man/man1/beav.1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/beav140.txt ${STAGEDIR}${DOCSDIR}/beav.txt
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${STAGEDIR}${PREFIX}/man/man1/beav.1
.include <bsd.port.mk>
diff --git a/editors/beav/files/patch-termio.c b/editors/beav/files/patch-termio.c
index 172a9531ed4c..dbf956d33584 100644
--- a/editors/beav/files/patch-termio.c
+++ b/editors/beav/files/patch-termio.c
@@ -5,7 +5,7 @@
#ifdef UNIX /* System V */
+#if defined(__GLIBC__) || \
-+ defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
++ defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
+#define TERMIOS 1
+#endif
+