aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoryoichi <yoichi@FreeBSD.org>2005-02-13 11:19:13 +0800
committeryoichi <yoichi@FreeBSD.org>2005-02-13 11:19:13 +0800
commit2a2f90518322a19f5d81798ab6a69797e3b7c7e5 (patch)
tree08c288ea008cb3e840a55a3908a21e856d38ff92 /editors
parentb62907dbeaedfd91f725b54f1b3c7b74a69343e0 (diff)
downloadfreebsd-ports-gnome-2a2f90518322a19f5d81798ab6a69797e3b7c7e5.tar.gz
freebsd-ports-gnome-2a2f90518322a19f5d81798ab6a69797e3b7c7e5.tar.zst
freebsd-ports-gnome-2a2f90518322a19f5d81798ab6a69797e3b7c7e5.zip
Security fix for usage of format string.
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs20/Makefile2
-rw-r--r--editors/emacs20/files/patch-lib-src::movemail.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/editors/emacs20/Makefile b/editors/emacs20/Makefile
index dbff0df97b26..03c3f0fa35ec 100644
--- a/editors/emacs20/Makefile
+++ b/editors/emacs20/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES+= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= emacs
diff --git a/editors/emacs20/files/patch-lib-src::movemail.c b/editors/emacs20/files/patch-lib-src::movemail.c
new file mode 100644
index 000000000000..6c04c1de3ecf
--- /dev/null
+++ b/editors/emacs20/files/patch-lib-src::movemail.c
@@ -0,0 +1,19 @@
+*** lib-src/movemail.c.orig Sun May 2 18:25:15 1999
+--- lib-src/movemail.c Thu Feb 10 21:38:32 2005
+***************
+*** 765,771 ****
+ mbx_delimit_begin (mbf);
+ if (pop_retr (server, i, mbf) != OK)
+ {
+! error (Errmsg);
+ close (mbfi);
+ return (1);
+ }
+--- 765,771 ----
+ mbx_delimit_begin (mbf);
+ if (pop_retr (server, i, mbf) != OK)
+ {
+! error ("%s", Errmsg);
+ close (mbfi);
+ return (1);
+ }