aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /editors
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile4
-rw-r--r--editors/calligraplan/Makefile4
-rw-r--r--editors/encryptpad/Makefile4
-rw-r--r--editors/focuswriter/Makefile4
-rw-r--r--editors/kate-kde4/Makefile4
-rw-r--r--editors/kate-plugin-pate-kde4/Makefile4
-rw-r--r--editors/kate/Makefile4
-rw-r--r--editors/kile-kde4/Makefile4
-rw-r--r--editors/kile/Makefile4
-rw-r--r--editors/klat4/Makefile4
-rw-r--r--editors/lfhex/Makefile4
-rw-r--r--editors/libreoffice/Makefile5
-rw-r--r--editors/mp/Makefile8
-rw-r--r--editors/neovim-qt/Makefile4
-rw-r--r--editors/plume-creator-devel/Makefile4
-rw-r--r--editors/tea/Makefile6
-rw-r--r--editors/texmacs/Makefile5
-rw-r--r--editors/texmaker/Makefile6
-rw-r--r--editors/texstudio/Makefile10
-rw-r--r--editors/textroom/Makefile4
-rw-r--r--editors/texworks/Makefile4
-rw-r--r--editors/yzis/Makefile8
22 files changed, 57 insertions, 51 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 97c4397b13be..c663a6df6837 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -38,7 +38,7 @@ RUN_DEPENDS= pstoedit:graphics/pstoedit
USES= cmake:outsource cpe compiler:c++11-lib desktop-file-utils eigen:3 \
gettext iconv:translit jpeg kde:5 localbase:ldflags perl5 pkgconfig \
- shared-mime-info sqlite tar:xz
+ qt:5 shared-mime-info sqlite tar:xz
USE_KDE= activities archive auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons doctools ecm \
emoticons guiaddons i18n iconthemes init itemmodels itemviews \
@@ -47,7 +47,7 @@ USE_KDE= activities archive auth bookmarks codecs completion config \
texteditor textwidgets threadweaver unitconversion wallet \
widgetsaddons windowsystem xmlgui \
calendarcore okular
-USE_QT5= buildtools_build core dbus gui network opengl \
+USE_QT= buildtools_build core dbus gui network opengl \
phonon4 printsupport qmake_build qml \
quick script sql svg testlib webkit widgets x11extras xml
USE_XORG= ice sm x11 xext
diff --git a/editors/calligraplan/Makefile b/editors/calligraplan/Makefile
index 84c8cb21cadf..668d67f41623 100644
--- a/editors/calligraplan/Makefile
+++ b/editors/calligraplan/Makefile
@@ -12,14 +12,14 @@ COMMENT= KDE Calligra project management application
LIB_DEPENDS= libKChart.so:graphics/kdiagram
USES= cmake:outsource cpe compiler:c++11-lib desktop-file-utils kde:5 \
- tar:xz
+ qt:5 tar:xz
USE_KDE= activities akonadi archive auth bookmarks codecs completion config \
configwidgets coreaddons dbusaddons ecm guiaddons holidays i18n \
iconthemes itemmodels itemviews jobwidgets js khtml kio \
notifications parts service solid sonnet textwidgets wallet \
widgetsaddons windowsystem xmlgui \
akonadicontacts calendarcore contacts
-USE_QT5= core dbus gui network printsupport widgets x11extras xml \
+USE_QT= core dbus gui network printsupport widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= ice sm x11 xext
diff --git a/editors/encryptpad/Makefile b/editors/encryptpad/Makefile
index 5617ddad99bd..386a8546b91e 100644
--- a/editors/encryptpad/Makefile
+++ b/editors/encryptpad/Makefile
@@ -19,11 +19,11 @@ LICENSE_FILE= ${WRKSRC}/license.txt
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libbotan-2.so:security/botan2
-USES= desktop-file-utils gmake pkgconfig shared-mime-info
+USES= desktop-file-utils gmake pkgconfig qt:5 shared-mime-info
USE_GITHUB= yes
GH_ACCOUNT= evpo
GH_PROJECT= EncryptPad
-USE_QT5= core gui widgets buildtools_build qmake_build
+USE_QT= core gui widgets buildtools_build qmake_build
USE_GL= gl
OPTIONS_DEFINE= DOCS
diff --git a/editors/focuswriter/Makefile b/editors/focuswriter/Makefile
index 550c5a2cbb16..1768c002b138 100644
--- a/editors/focuswriter/Makefile
+++ b/editors/focuswriter/Makefile
@@ -16,11 +16,11 @@ LICENSE_FILE_LGPL3+ = ${WRKSRC}/resources/images/icons/oxygen/COPYING
LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
-USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake
+USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= gottcode
USE_GL= gl
-USE_QT5= concurrent core gui multimedia network printsupport widgets \
+USE_QT= concurrent core gui multimedia network printsupport widgets \
buildtools_build linguisttools_build
PORTDATA= *
diff --git a/editors/kate-kde4/Makefile b/editors/kate-kde4/Makefile
index 1016dfe6eb58..2a5513c270c6 100644
--- a/editors/kate-kde4/Makefile
+++ b/editors/kate-kde4/Makefile
@@ -11,10 +11,10 @@ COMMENT= Basic editor framework for the KDE system
LIB_DEPENDS= libqjson.so:devel/qjson@qt4
-USES= cmake:outsource gettext kde:4 perl5 tar:xz
+USES= cmake:outsource gettext kde:4 perl5 qt:4 tar:xz
USE_KDE= kdelibs automoc4 kactivities
USE_PERL5= build
-USE_QT4= dbus gui script sql webkit xml \
+USE_QT= dbus gui script sql webkit xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/editors/kate-plugin-pate-kde4/Makefile b/editors/kate-plugin-pate-kde4/Makefile
index 784789978259..769aada9fde5 100644
--- a/editors/kate-plugin-pate-kde4/Makefile
+++ b/editors/kate-plugin-pate-kde4/Makefile
@@ -9,10 +9,10 @@ DISTNAME= kate-${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Support for Python plugins in Kate
-USES= cmake:outsource,noninja kde:4 python:2.7 tar:xz
+USES= cmake:outsource,noninja kde:4 python:2.7 qt:4 tar:xz
USE_KDE= kdelibs automoc4 kate \
pykde4_build pykde4_run
-USE_QT4= gui webkit \
+USE_QT= gui webkit \
moc_build qmake_build rcc_build uic_build
DISTINFO_FILE= ${.CURDIR:H:H}/editors/kate-kde4/distinfo
diff --git a/editors/kate/Makefile b/editors/kate/Makefile
index dab52a66a56e..64ca1947f402 100644
--- a/editors/kate/Makefile
+++ b/editors/kate/Makefile
@@ -11,14 +11,14 @@ BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-
docbook-xml>0:textproc/docbook-xml
LIB_DEPENDS= libgit2.so:devel/libgit2
-USES= cmake:outsource desktop-file-utils gettext pkgconfig kde:5 tar:xz
+USES= cmake:outsource desktop-file-utils gettext pkgconfig kde:5 qt:5 tar:xz
USE_KDE= activities attica auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons doctools ecm \
guiaddons i18n iconthemes init itemmodels itemviews \
jobwidgets kio newstuff package parts plasma-framework \
service solid sonnet texteditor textwidgets threadweaver \
wallet widgetsaddons windowsystem xmlgui
-USE_QT5= core dbus gui network script sql widgets xml \
+USE_QT= core dbus gui network script sql widgets xml \
buildtools_build qmake_build
.include <bsd.port.mk>
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index c909a84485ab..4027f4acb197 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -16,8 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= identify:graphics/ImageMagick
-USES= cmake gettext-tools kde:4 shared-mime-info tar:bzip2
-USE_QT4= qmake_build moc_build rcc_build uic_build
+USES= cmake gettext-tools kde:4 qt:4 shared-mime-info tar:bzip2
+USE_QT= qmake_build moc_build rcc_build uic_build
USE_KDE= kdelibs automoc4 kate_run
USE_TEX= latex
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index 79457472a29b..c44745d13663 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -15,13 +15,13 @@ LIB_DEPENDS= libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5
USES= cmake:outsource desktop-file-utils kde:5 \
- shared-mime-info shebangfix
+ qt:5 shared-mime-info shebangfix
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm guiaddons i18n iconthemes \
init itemviews jobwidgets js khtml kio parts service solid \
sonnet texteditor textwidgets widgetsaddons windowsystem xmlgui \
okular
-USE_QT5= concurrent core dbus gui network script widgets xml \
+USE_QT= concurrent core dbus gui network script widgets xml \
buildtools_build qmake_build
SHEBANG_FILES= *.pl
diff --git a/editors/klat4/Makefile b/editors/klat4/Makefile
index 3fbdfb704546..77cbdd84af5f 100644
--- a/editors/klat4/Makefile
+++ b/editors/klat4/Makefile
@@ -12,8 +12,8 @@ COMMENT= LaTeX source editor for KDE4
LICENSE= GPLv2+
-USES= cmake gettext-tools kde:4 tar:bzip2
+USES= cmake gettext-tools kde:4 qt:4 tar:bzip2
USE_KDE= automoc4 kate kdelibs
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index 890b183f36f9..1e878bddccc3 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -13,8 +13,8 @@ COMMENT= Large file hex editor
LICENSE= GPLv2 # only
LICENSE_FILE= ${WRKSRC}/../COPYING
-USES= bison qmake
-USE_QT4= corelib gui moc_build rcc_build
+USES= bison qmake qt:4
+USE_QT= corelib gui moc_build rcc_build
WRKSRC_SUBDIR= src
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index b8fbc201753a..5844f8ce3a40 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -107,7 +107,6 @@ GNU_CONFIGURE= yes
USE_GL= gl glew glu
USE_OPENLDAP= yes
USE_PERL5= build
-USE_QT4= # empty but required
USE_XORG= ice sm x11 xaw xext xinerama xrandr xrender
USES= autoreconf:build bison compiler:c++14-lang cpe gmake jpeg \
perl5 pkgconfig python shebangfix shared-mime-info ssl tar:xz
@@ -195,8 +194,8 @@ KDE4_CONFIGURE_ENV= KDE4DIR="${KDE_PREFIX}" \
QT4DIR="${PREFIX}" \
QT4INC="${QT_INCDIR}" \
QT4LIB="${QT_LIBDIR}"
-KDE4_USES= kde:4
-KDE4_USE= KDE=kdelibs QT4=moc_build,qmake_build
+KDE4_USES= kde:4 qt:4
+KDE4_USE= KDE=kdelibs QT=moc_build,qmake_build
MMEDIA_CONFIGURE_ENABLE= gstreamer-1-0
MMEDIA_USE= GSTREAMER1=yes
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index 4d1c395f6794..80d66a5e45d0 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -52,14 +52,15 @@ NCURSES_USES= ncurses
NCURSES_CONFIGURE_WITH= curses
NCURSES_CFLAGS= -I${NCURSESBASE}/include
-QT4_USE= qt4=corelib,gui,moc_build \
+QT4_USES= qmake:no_env qt:4
+QT4_USE= qt=corelib,gui,moc_build \
xorg=x11
QT4_CONFIGURE_WITH= qt4
-QT5_USES= compiler:c++11-lang
+QT5_USES= compiler:c++11-lang qmake:no_env qt:5
QT5_USE= cxxstd=-std=c++11 \
gl=gl \
- qt5=buildtools_build,core,gui,widgets
+ qt=buildtools_build,core,gui,widgets
QT5_CONFIGURE_WITH= qt5
.include <bsd.port.options.mk>
@@ -81,7 +82,6 @@ CONFIGURE_ARGS+= --without-gtk
DESKTOP_ENTRIES="Minimum Profit" "" "mp" "mp-5" "Utility;TextEditor;Qt;" ""
CONFIGURE_ARGS+=--with-moc=${MOC}
CONFIGURE_ENV+= CCLINK="${CXX}"
-QT_NONSTANDARD= yes
.endif
post-patch:
diff --git a/editors/neovim-qt/Makefile b/editors/neovim-qt/Makefile
index a6c0d2fef001..4427b5b33ec5 100644
--- a/editors/neovim-qt/Makefile
+++ b/editors/neovim-qt/Makefile
@@ -15,10 +15,10 @@ BUILD_DEPENDS= neovim>=0:editors/neovim
LIB_DEPENDS= libmsgpackc.so:devel/msgpack
RUN_DEPENDS= neovim>=0:editors/neovim
-USES= cmake:outsource desktop-file-utils
+USES= cmake:outsource desktop-file-utils qt:5
USE_GITHUB= yes
GH_ACCOUNT= equalsraf
-USE_QT5= core gui testlib network widgets buildtools_build qmake_build
+USE_QT= core gui testlib network widgets buildtools_build qmake_build
CMAKE_ON= USE_SYSTEM_MSGPACK
CMAKE_OFF= ENABLE_TESTS
diff --git a/editors/plume-creator-devel/Makefile b/editors/plume-creator-devel/Makefile
index 7a22251172c5..c555f140e3f7 100644
--- a/editors/plume-creator-devel/Makefile
+++ b/editors/plume-creator-devel/Makefile
@@ -12,8 +12,8 @@ LICENSE= GPLv3+
DATE= 20150510
-USES= desktop-file-utils qmake shared-mime-info tar:xz
-USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build webkit
+USES= desktop-file-utils qmake qt:4 shared-mime-info tar:xz
+USE_QT= corelib gui moc_build qmake_build rcc_build uic_build webkit
QMAKE_ARGS= ${WRKSRC}/plume-creator.pro
.include <bsd.port.mk>
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 41a1acdc1033..2a4f206072e0 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -24,8 +24,10 @@ USES= pkgconfig:build qmake tar:bzip2
USE_GL= gl
USE_LOCALE= en_US.UTF-8
-QT4_USE= qt4=corelib,gui,moc_build,network,rcc_build
-QT5_USE= qt5=buildtools_build,core,gui,network,widgets,printsupport,qml,quick
+QT4_USES= qt:4
+QT4_USE= qt=corelib,gui,moc_build,network,rcc_build
+QT5_USES= qt:5
+QT5_USE= qt=buildtools_build,core,gui,network,widgets,printsupport,qml,quick
LDFLAGS+= -lz
PLIST_FILES= bin/tea share/pixmaps/tea_icon_v2.png
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index 6331343b04ce..604d101663ee 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -56,8 +56,9 @@ IMLIB2_CONFIGURE_WITH= imlib2
PDF_CONFIGURE_ENABLE= pdf-renderer
PDF_LDFLAGS= -lz
PDF_IMPLIES= FREETYPE GHOSTSCRIPT
-QT4_USE= qt4=accessible,corelib,gui,imageformats \
- qt4=moc_build,qmake_build,rcc_build,uic_build
+QT4_USES= qt:4
+QT4_USE= qt=accessible,corelib,gui,imageformats \
+ qt=moc_build,qmake_build,rcc_build,uic_build
QT4_USE_OFF= xorg=xext
QT4_CONFIGURE_ON= --with-qt=${PREFIX} --enable-qtpipes
QT4_CONFIGURE_OFF= --disable-qt
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 35967e8969a6..d7d3b32d210e 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -31,9 +31,11 @@ OPTIONS_SINGLE_TOOLKIT= QT4 QT5
OPTIONS_DEFAULT= QT5
TOOLKIT_DESC= Qt toolkit
-QT4_USE= ${_USE_QT4:S/^/QT4=/}
+QT4_USES= qt:4
+QT4_USE= ${_USE_QT4:S/^/QT=/}
QT4_LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-QT5_USE= ${_USE_QT5:S/^/QT5=/}
+QT5_USES= qt:5
+QT5_USE= ${_USE_QT5:S/^/QT=/}
QT5_LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5
.include <bsd.port.mk>
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index cd064ec3fa28..dca46126907f 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -20,20 +20,22 @@ FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
qt4_LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4 \
- libquazip.so:archivers/quazip@qt4
+ libquazip.so:archivers/quazip@qt4
qt5_LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5 \
- libquazip5.so:archivers/quazip@qt5
+ libquazip5.so:archivers/quazip@qt5
USES= desktop-file-utils dos2unix ghostscript:run \
pkgconfig qmake
.if ${FLAVOR} == qt4
-USE_QT4= corelib gui network script svg xml \
+USES+= qt:4
+USE_QT= corelib gui network script svg xml \
iconengines_run designer_build moc_build rcc_build uic_build
QMAKE_ARGS= QUAZIP_INCLUDE="${LOCALBASE}/include/quazip" \
QUAZIP_LIB="-lquazip"
.else
-USE_QT5= core gui network script svg widgets xml \
+USES+= qt:5
+USE_QT = core gui network script svg widgets xml \
printsupport concurrent uitools buildtools_build
QMAKE_ARGS= QUAZIP_INCLUDE="${LOCALBASE}/include/quazip5" \
QUAZIP_LIB="-lquazip5"
diff --git a/editors/textroom/Makefile b/editors/textroom/Makefile
index a3e9b85e71e9..544f23801917 100644
--- a/editors/textroom/Makefile
+++ b/editors/textroom/Makefile
@@ -16,11 +16,11 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libhunspell-1.6.so:textproc/hunspell \
libxml++-2.6.so:textproc/libxml++26
-USES= compiler:c++11-lang desktop-file-utils pkgconfig qmake
+USES= compiler:c++11-lang desktop-file-utils pkgconfig qmake qt:4
USE_CXXSTD= c++11
USE_GL= gl
USE_SDL= mixer
-USE_QT4= moc_build rcc_build uic_build \
+USE_QT= moc_build rcc_build uic_build \
corelib gui opengl qt3support svg xml
post-patch:
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 7881c45525ea..a073bbc359d3 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -18,10 +18,10 @@ BROKEN_armv7= fails to install: PDFDocument.cpp:1836:39: cannot initialize a pa
BUILD_DEPENDS= hunspell:textproc/hunspell
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-USES= compiler:c++11-lang pkgconfig qmake
+USES= compiler:c++11-lang pkgconfig qmake qt:4
USE_GITHUB= yes
GH_ACCOUNT= TeXworks
-USE_QT4= gui corelib rcc_build moc_build uic_build \
+USE_QT= gui corelib rcc_build moc_build uic_build \
dbus xml scripttools designer_build
QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} \
DATA_DIR=${DATADIR} \
diff --git a/editors/yzis/Makefile b/editors/yzis/Makefile
index 70b0bc3fdcef..161dacb2bd95 100644
--- a/editors/yzis/Makefile
+++ b/editors/yzis/Makefile
@@ -17,9 +17,9 @@ LICENSE_COMB= multi
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LGPL
-USES= tar:bzip2 cmake gettext perl5 lua:51
+USES= qt:4 tar:bzip2 cmake gettext perl5 lua:51
USE_XORG= x11 xext ice
-USE_QT4= corelib qtestlib qmake_build rcc_build uic_build moc_build gui xml
+USE_QT= corelib qtestlib qmake_build rcc_build uic_build moc_build gui xml
CMAKE_ARGS+= -DLOCALBASE:STRING="${LOCALBASE}" \
-DLUA_INCDIR:STRING="${LUA_INCDIR}" \
-DLUA_LIBDIR:STRING="${LUA_LIBDIR}" \
@@ -34,8 +34,8 @@ USE_LDCONFIG= yes
OPTIONS_DEFINE= KYZIS NYZIS DOXYGEN
OPTIONS_SUB= yes
KYZIS_DESC= Build kyzis and Yzis kpart
-KYZIS_USES= kde:4
-KYZIS_USE= KDE=kdeprefix,kdelibs,automoc4 QT4=phonon
+KYZIS_USES= kde:4 qt:4
+KYZIS_USE= KDE=kdeprefix,kdelibs,automoc4 QT=phonon
KYZIS_CMAKE_ON= -DENABLE_KYZIS:BOOL=ON -DENABLE_KPART_YZIS:BOOL=ON
KYZIS_CMAKE_OFF= -DENABLE_KYZIS:BOOL=OFF -DENABLE_KPART_YZIS:BOOL=OFF
NYZIS_DESC= Build nyzis (ncurses frontend)