aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-07-28 14:23:54 +0800
committertobik <tobik@FreeBSD.org>2018-07-28 14:23:54 +0800
commit424eec1b216913fe49f49197421bcdee48c83f43 (patch)
tree71c6f3648f3375f770d3be170a5bf31e45099a86 /editors
parent5a1dba5b35fd3a744c51847e66439e44158f760b (diff)
downloadfreebsd-ports-gnome-424eec1b216913fe49f49197421bcdee48c83f43.tar.gz
freebsd-ports-gnome-424eec1b216913fe49f49197421bcdee48c83f43.tar.zst
freebsd-ports-gnome-424eec1b216913fe49f49197421bcdee48c83f43.zip
editors/zoinks: Fix build with Clang 6
TFWCursors.cpp:32:2: error: constant expression evaluates to 128 which cannot be narrowed to type 'char' [-Wc++11-narrowing] 0x80, 0x00, ^~~~ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475044_s336572/logs/zoinks-0.4.1_2.log - While here add missing dependencies and LICENSE_FILE
Diffstat (limited to 'editors')
-rw-r--r--editors/zoinks/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/editors/zoinks/Makefile b/editors/zoinks/Makefile
index 2f9da51d364f..30d4994036bb 100644
--- a/editors/zoinks/Makefile
+++ b/editors/zoinks/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zoinks
PORTVERSION= 0.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors
MASTER_SITES= http://zoinks.mikelockwood.com/download/
@@ -11,11 +11,15 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= X11 programmer's editor and development environment
LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-USE_XORG= xpm
+USES= compiler
+USE_XORG= x11 xext xpm
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= NLS