aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-05-12 01:58:55 +0800
committerhrs <hrs@FreeBSD.org>2013-05-12 01:58:55 +0800
commit514b35c5ff85906bace4b99b5298bb03779d8082 (patch)
tree4e99b662e9edb02c504f73d22596ea702c0f3d31 /editors
parent3c5290d5fb12b9f59c755a169a5953b92bcd083d (diff)
downloadfreebsd-ports-gnome-514b35c5ff85906bace4b99b5298bb03779d8082.tar.gz
freebsd-ports-gnome-514b35c5ff85906bace4b99b5298bb03779d8082.tar.zst
freebsd-ports-gnome-514b35c5ff85906bace4b99b5298bb03779d8082.zip
Rectify USE_TEX to support both of teTeX and TeXLive.
TEX_DEFAULT: A knob to choose teTeX or TeXLive. One can specify in /etc/make.conf. USE_TEX: A knob for port developers. Valid keywords are listed in bsd.tex.mk.
Diffstat (limited to 'editors')
-rw-r--r--editors/kile-kde4/Makefile2
-rw-r--r--editors/kile/Makefile2
-rw-r--r--editors/texmacs/Makefile2
-rw-r--r--editors/texmaker/Makefile5
-rw-r--r--editors/texmakerx/Makefile5
-rw-r--r--editors/winefish/Makefile2
-rw-r--r--editors/zim/Makefile2
7 files changed, 9 insertions, 11 deletions
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index 61e22d9c4485..e0e3aa91aa0e 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -15,7 +15,7 @@ USE_BZIP2= yes
USES= cmake
USE_QT4= qmake_build moc_build rcc_build uic_build
USE_KDE4= kdeprefix kdelibs automoc4 sharedmime kate_run
-USE_TEX= tetex
+USE_TEX= latex
MAKE_JOBS_SAFE= yes
LATEST_LINK= ${PORTNAME}-kde4
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index 30971f56e73f..f7e7fd202ec6 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -26,7 +26,7 @@ USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-USE_TEX= tetex
+USE_TEX= latex
OPTIONS_DEFINE= KPDF
OPTIONS_DEFAULT= KPDF
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index 73b6b4feb145..37d83613c659 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
MAKE_JOBS_SAFE= yes
USE_PYTHON= yes
-USE_TEX= tetex
+USE_TEX= tex
USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 64349c5886f8..402eedf182a9 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -12,14 +12,13 @@ COMMENT= LaTeX Development Environment
LIB_DEPENDS= poppler:${PORTSDIR}/graphics/poppler \
poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
-RUN_DEPENDS= dvips:${PORTSDIR}/print/dvipsk-tetex \
- ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USE_BZIP2= yes
USE_GHOSTSCRIPT=yes
USE_QT4= gui network xml webkit \
moc_build qmake_build rcc_build uic_build
-USE_TEX= tetex
+USE_TEX= latex dvipsk
HAS_CONFIGURE= yes
QMAKE_ARGS= PREFIX=${PREFIX} ICONDIR=${PREFIX}/share/pixmaps \
DESKTOPDIR=${DESKTOPDIR}
diff --git a/editors/texmakerx/Makefile b/editors/texmakerx/Makefile
index ec80b909cb76..b44e0fd7f554 100644
--- a/editors/texmakerx/Makefile
+++ b/editors/texmakerx/Makefile
@@ -13,15 +13,14 @@ COMMENT= A LaTeX IDE derived from Texmaker
LIB_DEPENDS= poppler:${PORTSDIR}/graphics/poppler \
poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
-RUN_DEPENDS= dvips:${PORTSDIR}/print/dvipsk-tetex \
- ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
USE_GHOSTSCRIPT=yes
USE_QT4= gui network xml moc_build qmake_build rcc_build \
uic_build qtestlib script
-USE_TEX= tetex
+USE_TEX= latex dvipsk
HAS_CONFIGURE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/editors/winefish/Makefile b/editors/winefish/Makefile
index 6038adddfed4..2c83788c3bf6 100644
--- a/editors/winefish/Makefile
+++ b/editors/winefish/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ARGS+= --with-freedesktop_org-menu=${GNOME_LOCALSTATEDIR}/applications
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= libgnomeui desktopfileutils gnomehier
-USE_TEX= tetex
+USE_TEX= latex
OPTIONS_DEFINE= CONTEXT VNTEX UNIKEY_GTK NLS DOCS
CONTEXT_DESC= ConTexT support (Experimental)
diff --git a/editors/zim/Makefile b/editors/zim/Makefile
index bda8fa7140d2..0690923c4dcc 100644
--- a/editors/zim/Makefile
+++ b/editors/zim/Makefile
@@ -38,7 +38,7 @@ DITAA_DESC= Diagram editor support
RUN_DEPENDS+= R:${PORTSDIR}/math/R
.endif
.if ${PORT_OPTIONS:MLATEX}
-USE_TEX= tetex
+USE_TEX= latex
.endif
.if ${PORT_OPTIONS:MGRAPHVIZ}
RUN_DEPENDS+= fdp:${PORTSDIR}/graphics/graphviz