aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
commit591689f7f7301da41e08d95976e1318322254d75 (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /editors
parent241bc346167b5bfc4beac8d3b3044454cf6b0f87 (diff)
downloadfreebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.gz
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.zst
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.zip
According to the Porter's Handbook (5.12.2.3.) default options must be added to
OPTIONS_DEFINE. This policy has been implemented only recently that's why we have many ports violating this policy. This patch adds the default options specified in the Porter's Handbook to OPTIONS_DEFINE where they are being used. Ports maintained by gnome@FreeBSD.org, kde@FreeBSD.org and x11@FreeBSD.org have been excluded. Approved by: portmgr (bapt)
Diffstat (limited to 'editors')
-rw-r--r--editors/hnb/Makefile2
-rw-r--r--editors/nano-devel/Makefile2
-rw-r--r--editors/nano/Makefile2
-rw-r--r--editors/ssed/Makefile2
-rw-r--r--editors/zoinks/Makefile3
5 files changed, 11 insertions, 0 deletions
diff --git a/editors/hnb/Makefile b/editors/hnb/Makefile
index 91322dba87ae..29c446f551a6 100644
--- a/editors/hnb/Makefile
+++ b/editors/hnb/Makefile
@@ -19,6 +19,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${ARCH} != "i386"
diff --git a/editors/nano-devel/Makefile b/editors/nano-devel/Makefile
index 1d9cf8326c91..2444f3599a26 100644
--- a/editors/nano-devel/Makefile
+++ b/editors/nano-devel/Makefile
@@ -20,6 +20,8 @@ CONFIGURE_ARGS= --docdir=${DOCSDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index e6863c750f81..1f61d2c848ea 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -21,6 +21,8 @@ CONFIGURE_ARGS= --docdir=${DOCSDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/editors/ssed/Makefile b/editors/ssed/Makefile
index 62bcca9fc9ed..0245521652ab 100644
--- a/editors/ssed/Makefile
+++ b/editors/ssed/Makefile
@@ -14,6 +14,8 @@ COMMENT= Super-sed - a heavily enhanced version of sed
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=s
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/editors/zoinks/Makefile b/editors/zoinks/Makefile
index 6049f45492cd..780b0d0548a3 100644
--- a/editors/zoinks/Makefile
+++ b/editors/zoinks/Makefile
@@ -21,6 +21,9 @@ USE_XORG= xpm
GNU_CONFIGURE= yes
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}