aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
committermarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
commit7315b1c16ae631c60d787b73475db448b86b7e0b (patch)
tree0a7edc722d829b9a98914843c0c09d978324e75f /editors
parente43bffa408ddb90519bcbf271791632a33f25217 (diff)
downloadfreebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.gz
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.zst
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'editors')
-rw-r--r--editors/gedit-autocomplete-plugin/Makefile4
-rw-r--r--editors/gedit/Makefile31
-rw-r--r--editors/gedit/distinfo6
-rw-r--r--editors/gedit/files/patch-configure31
-rw-r--r--editors/gedit/files/patch-gedit_gedit-module.c11
-rw-r--r--editors/gedit/files/patch-gedit_gedit-plugins-engine.c13
-rw-r--r--editors/gedit/pkg-plist186
-rw-r--r--editors/gnome2-office/Makefile4
8 files changed, 200 insertions, 86 deletions
diff --git a/editors/gedit-autocomplete-plugin/Makefile b/editors/gedit-autocomplete-plugin/Makefile
index f232f571676d..015edcfecc8c 100644
--- a/editors/gedit-autocomplete-plugin/Makefile
+++ b/editors/gedit-autocomplete-plugin/Makefile
@@ -18,7 +18,9 @@ COMMENT= A simple autocompletion plugin for gedit
BUILD_DEPENDS= gedit:${PORTSDIR}/editors/gedit
RUN_DEPENDS= gedit:${PORTSDIR}/editors/gedit
-GEDIT_VERSION= 2.12
+GEDIT_VERSION= 2.14
+
+BROKEN= Not compatible with gedit versions >= 2.14
USE_X_PREFIX= yes
MAKEFILE= makefile
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 0de92d763045..a63d9b369929 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit/Makefile,v 1.12 2005/10/03 15:49:09 ahze Exp $
+# $MCom: ports/editors/gedit/Makefile,v 1.33 2006/04/13 07:52:34 bland Exp $
#
PORTNAME= gedit
-PORTVERSION= 2.12.1
-PORTREVISION= 1
+PORTVERSION= 2.14.2
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -20,6 +19,7 @@ COMMENT= A small but powerful text editor for Gnome 2 Desktop Environment
LIB_DEPENDS= pspell.16:${PORTSDIR}/textproc/aspell
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
@@ -27,14 +27,33 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehack intlhack \
libgnomeprintui libgnomeui eel2 gtksourceview desktopfileutils
+WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB= VERSION="2.12"
+PLIST_SUB= VERSION="2.14"
MAN1= gedit.1
GCONF_SCHEMAS= gedit.schemas
+.if defined(PACKAGE_BUILDING)
+.undef WITHOUT_GNOME
+WITH_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mpygnomedesktop}!=""
+USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+USE_GNOME+= pygnomedesktop
+CONFIGURE_ARGS+=--enable-python
+PLIST_SUB+= PYTHON=""
+.else
+CONFIGURE_ARGS+=--disable-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
post-install:
@-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/gedit/distinfo b/editors/gedit/distinfo
index 33c7c27229e6..675f6f631bd3 100644
--- a/editors/gedit/distinfo
+++ b/editors/gedit/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gedit-2.12.1.tar.bz2) = 13f376c6c63b0fbd25ba9b6c7d6fb97c
-SHA256 (gnome2/gedit-2.12.1.tar.bz2) = a19cf963a655b9825f4f94ad8e83d4ce9df56a542b847d60a5bddd067ae07b3e
-SIZE (gnome2/gedit-2.12.1.tar.bz2) = 2018712
+MD5 (gnome2/gedit-2.14.2.tar.bz2) = 35d146a924fd426d448048e8db383334
+SHA256 (gnome2/gedit-2.14.2.tar.bz2) = 51b9833fa7b43a0e2207767d21ea6aedf0175bf7fde95c1bf56bf21670f2ef7e
+SIZE (gnome2/gedit-2.14.2.tar.bz2) = 2371194
diff --git a/editors/gedit/files/patch-configure b/editors/gedit/files/patch-configure
index 91c1e9a657d0..6bfadb0af650 100644
--- a/editors/gedit/files/patch-configure
+++ b/editors/gedit/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed Feb 25 02:26:37 2004
-+++ configure Wed Feb 25 02:27:22 2004
-@@ -22282,6 +22282,7 @@
+--- configure.orig Wed Dec 14 09:07:01 2005
++++ configure Wed Dec 14 09:07:01 2005
+@@ -22216,6 +22216,7 @@
if eval "test \"\${$as_ac_var+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -8,32 +8,11 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -22371,6 +22372,7 @@
+@@ -22304,6 +22305,7 @@
cat >>confdefs.h <<_ACEOF
#define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
_ACEOF
+LIBS="-lintl $LIBS"
- else
- { { echo "$as_me:$LINENO: error: ngettext function is required to build gedit." >&5
-@@ -22405,17 +22407,17 @@
- if test "x${prefix}" = "xNONE"; then
-
- cat >>confdefs.h <<_ACEOF
--#define PIXMAPS_DIR "${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/pixmaps"
-+
- _ACEOF
-
- pixmapsdir="${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/pixmaps"
- else
-
- cat >>confdefs.h <<_ACEOF
--#define PIXMAPS_DIR "${prefix}/${DATADIRNAME}/${PACKAGE}/pixmaps"
-+#define PIXMAPS_DIR "${datadir}/pixmaps"
- _ACEOF
-
-- pixmapsdir="${prefix}/${DATADIRNAME}/${PACKAGE}/pixmaps"
-+ pixmapsdir="${datadir}/pixmaps"
fi
-
-
+ done
diff --git a/editors/gedit/files/patch-gedit_gedit-module.c b/editors/gedit/files/patch-gedit_gedit-module.c
new file mode 100644
index 000000000000..b12781557ee5
--- /dev/null
+++ b/editors/gedit/files/patch-gedit_gedit-module.c
@@ -0,0 +1,11 @@
+--- gedit/gedit-module.c.orig Fri Jan 6 12:19:53 2006
++++ gedit/gedit-module.c Fri Jan 6 12:20:21 2006
+@@ -142,7 +142,7 @@ gedit_module_unload (GTypeModule *gmodul
+
+ gedit_debug_message (DEBUG_PLUGINS, "Unloading %s", module->path);
+
+- g_module_close (module->library);
++ /*g_module_close (module->library);*/
+
+ module->library = NULL;
+ module->type = 0;
diff --git a/editors/gedit/files/patch-gedit_gedit-plugins-engine.c b/editors/gedit/files/patch-gedit_gedit-plugins-engine.c
deleted file mode 100644
index 2fee7b8cd045..000000000000
--- a/editors/gedit/files/patch-gedit_gedit-plugins-engine.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- gedit/gedit-plugins-engine.c.orig Fri Aug 5 22:00:45 2005
-+++ gedit/gedit-plugins-engine.c Fri Aug 5 22:01:03 2005
-@@ -314,8 +314,8 @@ gedit_plugins_engine_shutdown (void)
- }
- }
-
-- if (info->plugin->handle != NULL)
-- g_module_close (info->plugin->handle);
-+ /*if (info->plugin->handle != NULL)
-+ g_module_close (info->plugin->handle);*/
-
- g_free (info->plugin->file);
- g_free (info->plugin->location);
diff --git a/editors/gedit/pkg-plist b/editors/gedit/pkg-plist
index 1a1dc0a9dc8e..e76de9653a69 100644
--- a/editors/gedit/pkg-plist
+++ b/editors/gedit/pkg-plist
@@ -1,34 +1,57 @@
bin/gedit
bin/gnome-text-editor
-include/gedit-%%VERSION%%/gedit/bonobo-mdi-child.h
-include/gedit-%%VERSION%%/gedit/bonobo-mdi.h
+include/gedit-%%VERSION%%/gedit/gedit-app.h
include/gedit-%%VERSION%%/gedit/gedit-convert.h
include/gedit-%%VERSION%%/gedit/gedit-debug.h
include/gedit-%%VERSION%%/gedit/gedit-document.h
include/gedit-%%VERSION%%/gedit/gedit-encodings-option-menu.h
include/gedit-%%VERSION%%/gedit/gedit-encodings.h
-include/gedit-%%VERSION%%/gedit/gedit-file.h
-include/gedit-%%VERSION%%/gedit/gedit-mdi-child.h
-include/gedit-%%VERSION%%/gedit/gedit-mdi.h
-include/gedit-%%VERSION%%/gedit/gedit-menus.h
+include/gedit-%%VERSION%%/gedit/gedit-file-chooser-dialog.h
+include/gedit-%%VERSION%%/gedit/gedit-help.h
+include/gedit-%%VERSION%%/gedit/gedit-message-area.h
include/gedit-%%VERSION%%/gedit/gedit-metadata-manager.h
-include/gedit-%%VERSION%%/gedit/gedit-output-window.h
+include/gedit-%%VERSION%%/gedit/gedit-notebook.h
+include/gedit-%%VERSION%%/gedit/gedit-panel.h
include/gedit-%%VERSION%%/gedit/gedit-plugin.h
include/gedit-%%VERSION%%/gedit/gedit-prefs-manager-app.h
include/gedit-%%VERSION%%/gedit/gedit-prefs-manager.h
+include/gedit-%%VERSION%%/gedit/gedit-print-job-preview.h
include/gedit-%%VERSION%%/gedit/gedit-print.h
+include/gedit-%%VERSION%%/gedit/gedit-progress-message-area.h
include/gedit-%%VERSION%%/gedit/gedit-recent.h
+include/gedit-%%VERSION%%/gedit/gedit-statusbar.h
+include/gedit-%%VERSION%%/gedit/gedit-tab.h
include/gedit-%%VERSION%%/gedit/gedit-utils.h
include/gedit-%%VERSION%%/gedit/gedit-view.h
-include/gedit-%%VERSION%%/gedit/gedit2.h
+include/gedit-%%VERSION%%/gedit/gedit-window.h
include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-item.h
include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-model.h
include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-util.h
-include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-view-bonobo.h
include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-view-gtk.h
+include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-view-uimanager.h
include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-view.h
lib/gedit-2/plugins/changecase.gedit-plugin
lib/gedit-2/plugins/docinfo.gedit-plugin
+%%PYTHON%%lib/gedit-2/plugins/externaltools.gedit-plugin
+%%PYTHON%%lib/gedit-2/plugins/externaltools/ElementTree.py
+%%PYTHON%%lib/gedit-2/plugins/externaltools/ElementTree.pyc
+%%PYTHON%%lib/gedit-2/plugins/externaltools/ElementTree.pyo
+%%PYTHON%%lib/gedit-2/plugins/externaltools/__init__.py
+%%PYTHON%%lib/gedit-2/plugins/externaltools/__init__.pyc
+%%PYTHON%%lib/gedit-2/plugins/externaltools/__init__.pyo
+%%PYTHON%%lib/gedit-2/plugins/externaltools/capture.py
+%%PYTHON%%lib/gedit-2/plugins/externaltools/capture.pyc
+%%PYTHON%%lib/gedit-2/plugins/externaltools/capture.pyo
+%%PYTHON%%lib/gedit-2/plugins/externaltools/functions.py
+%%PYTHON%%lib/gedit-2/plugins/externaltools/functions.pyc
+%%PYTHON%%lib/gedit-2/plugins/externaltools/functions.pyo
+%%PYTHON%%lib/gedit-2/plugins/externaltools/manager.py
+%%PYTHON%%lib/gedit-2/plugins/externaltools/manager.pyc
+%%PYTHON%%lib/gedit-2/plugins/externaltools/manager.pyo
+%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.py
+%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.pyc
+%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.pyo
+%%PYTHON%%lib/gedit-2/plugins/externaltools/tools.glade
lib/gedit-2/plugins/indent.gedit-plugin
lib/gedit-2/plugins/libchangecase.la
lib/gedit-2/plugins/libchangecase.so
@@ -38,10 +61,6 @@ lib/gedit-2/plugins/libindent.la
lib/gedit-2/plugins/libindent.so
lib/gedit-2/plugins/libsample.la
lib/gedit-2/plugins/libsample.so
-lib/gedit-2/plugins/libsavecopy.la
-lib/gedit-2/plugins/libsavecopy.so
-lib/gedit-2/plugins/libshell_output.la
-lib/gedit-2/plugins/libshell_output.so
lib/gedit-2/plugins/libsort.la
lib/gedit-2/plugins/libsort.so
lib/gedit-2/plugins/libspell.la
@@ -50,32 +69,81 @@ lib/gedit-2/plugins/libtaglist.la
lib/gedit-2/plugins/libtaglist.so
lib/gedit-2/plugins/libtime.la
lib/gedit-2/plugins/libtime.so
+%%PYTHON%%lib/gedit-2/plugins/modelines.gedit-plugin
+%%PYTHON%%lib/gedit-2/plugins/modelines.py
+%%PYTHON%%lib/gedit-2/plugins/modelines.pyc
+%%PYTHON%%lib/gedit-2/plugins/modelines.pyo
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole.gedit-plugin
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole.py
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole.pyc
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole.pyo
lib/gedit-2/plugins/sample.gedit-plugin
-lib/gedit-2/plugins/savecopy.gedit-plugin
-lib/gedit-2/plugins/shell_output.gedit-plugin
+%%PYTHON%%lib/gedit-2/plugins/snippets.gedit-plugin
+%%PYTHON%%lib/gedit-2/plugins/snippets/ElementTree.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/ElementTree.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/ElementTree.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/Snippet.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/Snippet.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/Snippet.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetComplete.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetComplete.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetComplete.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetController.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetController.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetController.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetPlaceholders.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetPlaceholders.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetPlaceholders.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetPluginInstance.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetPluginInstance.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetPluginInstance.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetsDialog.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetsDialog.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetsDialog.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetsLibrary.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetsLibrary.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/SnippetsLibrary.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/functions.py
+%%PYTHON%%lib/gedit-2/plugins/snippets/functions.pyc
+%%PYTHON%%lib/gedit-2/plugins/snippets/functions.pyo
+%%PYTHON%%lib/gedit-2/plugins/snippets/snippets.glade
lib/gedit-2/plugins/sort.gedit-plugin
lib/gedit-2/plugins/spell.gedit-plugin
lib/gedit-2/plugins/taglist.gedit-plugin
lib/gedit-2/plugins/time.gedit-plugin
-libdata/bonobo/servers/GNOME_Gedit.server
libdata/pkgconfig/gedit-%%VERSION%%.pc
-share/gnome/application-registry/gedit.applications
share/gnome/applications/gedit.desktop
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
share/gnome/gedit-2/glade/docinfo.glade2
-share/gnome/gedit-2/glade/gedit-encodings-dialog.glade2
-share/gnome/gedit-2/glade/gedit-preferences.glade2
-share/gnome/gedit-2/glade/goto-line.glade2
+share/gnome/gedit-2/glade/gedit-encodings-dialog.glade
+share/gnome/gedit-2/glade/gedit-open-location-dialog.glade
+share/gnome/gedit-2/glade/gedit-page-setup-dialog.glade
+share/gnome/gedit-2/glade/gedit-preferences-dialog.glade
+share/gnome/gedit-2/glade/gedit-search-dialog.glade
share/gnome/gedit-2/glade/languages-dialog.glade2
-share/gnome/gedit-2/glade/page-setup-dialog.glade2
-share/gnome/gedit-2/glade/plugin-manager.glade2
-share/gnome/gedit-2/glade/program-location-dialog.glade2
-share/gnome/gedit-2/glade/replace.glade2
-share/gnome/gedit-2/glade/shell_output.glade2
share/gnome/gedit-2/glade/sort.glade2
share/gnome/gedit-2/glade/spell-checker.glade2
share/gnome/gedit-2/glade/time.glade2
-share/gnome/gedit-2/glade/uri.glade2
+%%PYTHON%%share/gnome/gedit-2/plugins/externaltools/stock-tools.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/c++.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/c.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/css.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/global.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/haskell.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/html.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/idl.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/java.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/javascript.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/latex.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/perl.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/php.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/python.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/ruby.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/sh.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/tcl.xml
+%%PYTHON%%share/gnome/gedit-2/plugins/snippets/xml.xml
share/gnome/gedit-2/taglist/HTML.tags
share/gnome/gedit-2/taglist/Latex.tags
share/gnome/gedit-2/taglist/XSLT.tags
@@ -88,10 +156,26 @@ share/gnome/help/gedit/C/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/C/figures/gedit_window.png
share/gnome/help/gedit/C/gedit.xml
share/gnome/help/gedit/C/legal.xml
+share/gnome/help/gedit/bg/figures/gedit_format_bold.png
+share/gnome/help/gedit/bg/figures/gedit_format_italic.png
+share/gnome/help/gedit/bg/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/bg/figures/gedit_format_underline.png
+share/gnome/help/gedit/bg/figures/gedit_recent_files_menu_icon.png
+share/gnome/help/gedit/bg/figures/gedit_window.png
+share/gnome/help/gedit/bg/gedit.xml
+share/gnome/help/gedit/bg/legal.xml
+share/gnome/help/gedit/de/figures/gedit_format_bold.png
+share/gnome/help/gedit/de/figures/gedit_format_italic.png
+share/gnome/help/gedit/de/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/de/figures/gedit_format_underline.png
share/gnome/help/gedit/de/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/de/figures/gedit_window.png
share/gnome/help/gedit/de/gedit.xml
share/gnome/help/gedit/de/legal.xml
+share/gnome/help/gedit/es/figures/gedit_format_bold.png
+share/gnome/help/gedit/es/figures/gedit_format_italic.png
+share/gnome/help/gedit/es/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/es/figures/gedit_format_underline.png
share/gnome/help/gedit/es/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/es/figures/gedit_window.png
share/gnome/help/gedit/es/gedit.xml
@@ -100,14 +184,26 @@ share/gnome/help/gedit/eu/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/eu/figures/gedit_window.png
share/gnome/help/gedit/eu/gedit.xml
share/gnome/help/gedit/eu/legal.xml
+share/gnome/help/gedit/fr/figures/gedit_format_bold.png
+share/gnome/help/gedit/fr/figures/gedit_format_italic.png
+share/gnome/help/gedit/fr/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/fr/figures/gedit_format_underline.png
share/gnome/help/gedit/fr/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/fr/figures/gedit_window.png
share/gnome/help/gedit/fr/gedit.xml
share/gnome/help/gedit/fr/legal.xml
+share/gnome/help/gedit/it/figures/gedit_format_bold.png
+share/gnome/help/gedit/it/figures/gedit_format_italic.png
+share/gnome/help/gedit/it/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/it/figures/gedit_format_underline.png
share/gnome/help/gedit/it/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/it/figures/gedit_window.png
share/gnome/help/gedit/it/gedit.xml
share/gnome/help/gedit/it/legal.xml
+share/gnome/help/gedit/ja/figures/gedit_format_bold.png
+share/gnome/help/gedit/ja/figures/gedit_format_italic.png
+share/gnome/help/gedit/ja/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/ja/figures/gedit_format_underline.png
share/gnome/help/gedit/ja/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/ja/figures/gedit_window.png
share/gnome/help/gedit/ja/gedit.xml
@@ -123,21 +219,32 @@ share/gnome/help/gedit/sv/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/sv/figures/gedit_window.png
share/gnome/help/gedit/sv/gedit.xml
share/gnome/help/gedit/sv/legal.xml
+share/gnome/help/gedit/zh_CN/figures/gedit_format_bold.png
+share/gnome/help/gedit/zh_CN/figures/gedit_format_italic.png
+share/gnome/help/gedit/zh_CN/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/zh_CN/figures/gedit_format_underline.png
share/gnome/help/gedit/zh_CN/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/zh_CN/figures/gedit_window.png
share/gnome/help/gedit/zh_CN/gedit.xml
share/gnome/help/gedit/zh_CN/legal.xml
+share/gnome/help/gedit/zh_HK/figures/gedit_format_bold.png
+share/gnome/help/gedit/zh_HK/figures/gedit_format_italic.png
+share/gnome/help/gedit/zh_HK/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/zh_HK/figures/gedit_format_underline.png
share/gnome/help/gedit/zh_HK/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/zh_HK/figures/gedit_window.png
share/gnome/help/gedit/zh_HK/gedit.xml
share/gnome/help/gedit/zh_HK/legal.xml
+share/gnome/help/gedit/zh_TW/figures/gedit_format_bold.png
+share/gnome/help/gedit/zh_TW/figures/gedit_format_italic.png
+share/gnome/help/gedit/zh_TW/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/zh_TW/figures/gedit_format_underline.png
share/gnome/help/gedit/zh_TW/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/zh_TW/figures/gedit_window.png
share/gnome/help/gedit/zh_TW/gedit.xml
share/gnome/help/gedit/zh_TW/legal.xml
-share/gnome/idl/GNOME_Gedit.idl
-share/gnome/mime-info/gedit.keys
share/gnome/omf/gedit/gedit-C.omf
+share/gnome/omf/gedit/gedit-bg.omf
share/gnome/omf/gedit/gedit-de.omf
share/gnome/omf/gedit/gedit-es.omf
share/gnome/omf/gedit/gedit-eu.omf
@@ -160,12 +267,14 @@ share/locale/az/LC_MESSAGES/gedit.mo
share/locale/be/LC_MESSAGES/gedit.mo
share/locale/bg/LC_MESSAGES/gedit.mo
share/locale/bn/LC_MESSAGES/gedit.mo
+share/locale/br/LC_MESSAGES/gedit.mo
share/locale/bs/LC_MESSAGES/gedit.mo
share/locale/ca/LC_MESSAGES/gedit.mo
share/locale/cs/LC_MESSAGES/gedit.mo
share/locale/cy/LC_MESSAGES/gedit.mo
share/locale/da/LC_MESSAGES/gedit.mo
share/locale/de/LC_MESSAGES/gedit.mo
+share/locale/dz/LC_MESSAGES/gedit.mo
share/locale/el/LC_MESSAGES/gedit.mo
share/locale/en_CA/LC_MESSAGES/gedit.mo
share/locale/en_GB/LC_MESSAGES/gedit.mo
@@ -186,9 +295,9 @@ share/locale/id/LC_MESSAGES/gedit.mo
share/locale/is/LC_MESSAGES/gedit.mo
share/locale/it/LC_MESSAGES/gedit.mo
share/locale/ja/LC_MESSAGES/gedit.mo
+share/locale/ka/LC_MESSAGES/gedit.mo
share/locale/kn/LC_MESSAGES/gedit.mo
share/locale/ko/LC_MESSAGES/gedit.mo
-share/locale/ku/LC_MESSAGES/gedit.mo
share/locale/lt/LC_MESSAGES/gedit.mo
share/locale/lv/LC_MESSAGES/gedit.mo
share/locale/mi/LC_MESSAGES/gedit.mo
@@ -209,7 +318,6 @@ share/locale/pt/LC_MESSAGES/gedit.mo
share/locale/pt_BR/LC_MESSAGES/gedit.mo
share/locale/ro/LC_MESSAGES/gedit.mo
share/locale/ru/LC_MESSAGES/gedit.mo
-share/locale/rw/LC_MESSAGES/gedit.mo
share/locale/sk/LC_MESSAGES/gedit.mo
share/locale/sl/LC_MESSAGES/gedit.mo
share/locale/sq/LC_MESSAGES/gedit.mo
@@ -217,18 +325,18 @@ share/locale/sr/LC_MESSAGES/gedit.mo
share/locale/sr@Latn/LC_MESSAGES/gedit.mo
share/locale/sv/LC_MESSAGES/gedit.mo
share/locale/ta/LC_MESSAGES/gedit.mo
-share/locale/te/LC_MESSAGES/gedit.mo
share/locale/th/LC_MESSAGES/gedit.mo
share/locale/tk/LC_MESSAGES/gedit.mo
share/locale/tr/LC_MESSAGES/gedit.mo
share/locale/uk/LC_MESSAGES/gedit.mo
share/locale/vi/LC_MESSAGES/gedit.mo
share/locale/wa/LC_MESSAGES/gedit.mo
-share/locale/xh/LC_MESSAGES/gedit.mo
share/locale/zh_CN/LC_MESSAGES/gedit.mo
share/locale/zh_TW/LC_MESSAGES/gedit.mo
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/br/LC_MESSAGES
+@dirrmtry share/locale/br
@dirrm share/gnome/omf/gedit
@dirrm share/gnome/help/gedit/zh_TW/figures
@dirrm share/gnome/help/gedit/zh_TW
@@ -254,16 +362,24 @@ share/locale/zh_TW/LC_MESSAGES/gedit.mo
@dirrm share/gnome/help/gedit/es
@dirrm share/gnome/help/gedit/de/figures
@dirrm share/gnome/help/gedit/de
+@dirrm share/gnome/help/gedit/bg/figures
+@dirrm share/gnome/help/gedit/bg
@dirrm share/gnome/help/gedit/C/figures
@dirrm share/gnome/help/gedit/C
@dirrm share/gnome/help/gedit
@dirrm share/gnome/gedit-2/ui
@dirrm share/gnome/gedit-2/taglist
+%%PYTHON%%@dirrm share/gnome/gedit-2/plugins/snippets
+%%PYTHON%%@dirrm share/gnome/gedit-2/plugins/externaltools
+%%PYTHON%%@dirrm share/gnome/gedit-2/plugins
@dirrm share/gnome/gedit-2/glade
@dirrm share/gnome/gedit-2
+%%PYTHON%%@dirrm lib/gedit-2/plugins/snippets
+%%PYTHON%%@dirrm lib/gedit-2/plugins/externaltools
@dirrm lib/gedit-2/plugins
@dirrm lib/gedit-2
@dirrm include/gedit-%%VERSION%%/gedit/recent-files
@dirrm include/gedit-%%VERSION%%/gedit
@dirrm include/gedit-%%VERSION%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/editors/gnome2-office/Makefile b/editors/gnome2-office/Makefile
index 522c466f4cf8..3c661fc92b45 100644
--- a/editors/gnome2-office/Makefile
+++ b/editors/gnome2-office/Makefile
@@ -3,10 +3,10 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gnome2-office/Makefile,v 1.39 2005/08/11 02:55:29 marcus Exp $
+# $MCom: ports/editors/gnome2-office/Makefile,v 1.41 2006/04/12 22:11:33 marcus Exp $
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= editors gnome
PKGNAMESUFFIX= -office