aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2014-11-27 05:26:50 +0800
committerolivierd <olivierd@FreeBSD.org>2014-11-27 05:26:50 +0800
commit8801e0ddd323d7095b234b6acbd2e0eb627c95a1 (patch)
tree607d03023310b548ea50eb66000743edf92c9bb1 /editors
parent179b7d5c273483b21312e37652987ade3a5e8aa1 (diff)
downloadfreebsd-ports-gnome-8801e0ddd323d7095b234b6acbd2e0eb627c95a1.tar.gz
freebsd-ports-gnome-8801e0ddd323d7095b234b6acbd2e0eb627c95a1.tar.zst
freebsd-ports-gnome-8801e0ddd323d7095b234b6acbd2e0eb627c95a1.zip
LaTeXila is a LaTeX editor for the GNOME desktop. The idea of LaTeXila is
to always deal directly with the LaTeX code, while simplifying as most as possible the writing of this LaTeX code. WWW: https://wiki.gnome.org/Apps/LaTeXila
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/latexila/Makefile29
-rw-r--r--editors/latexila/distinfo2
-rw-r--r--editors/latexila/pkg-descr5
-rw-r--r--editors/latexila/pkg-plist49
5 files changed, 86 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 9b69738b68f9..f7feeeb34ccb 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -88,6 +88,7 @@
SUBDIR += kile-kde4
SUBDIR += klat4
SUBDIR += komodo-edit
+ SUBDIR += latexila
SUBDIR += lazarus
SUBDIR += lazarus-lcl-gtk
SUBDIR += lazarus-lcl-gtk2
diff --git a/editors/latexila/Makefile b/editors/latexila/Makefile
new file mode 100644
index 000000000000..68e3265ecaa3
--- /dev/null
+++ b/editors/latexila/Makefile
@@ -0,0 +1,29 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= latexila
+PORTVERSION= 3.14.2
+CATEGORIES= editors
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Integrated LaTeX environment
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala \
+ itstool:${PORTSDIR}/textproc/itstool
+LIB_DEPENDS= libgee-0.8.so:${PORTSDIR}/devel/libgee \
+ libgtkspell3-3.so:${PORTSDIR}/textproc/gtkspell3
+
+USES= pkgconfig gmake gettext desktop-file-utils tar:xz
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gtk30 gtksourceview3 intltool intlhack libxml2
+USE_TEX= latex dvipsk
+INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS=--without-help-dir
+
+GLIB_SCHEMAS= org.gnome.latexila.gschema.xml
+
+.include <bsd.port.mk>
diff --git a/editors/latexila/distinfo b/editors/latexila/distinfo
new file mode 100644
index 000000000000..f984874d5a0a
--- /dev/null
+++ b/editors/latexila/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/latexila-3.14.2.tar.xz) = 84e0bc8d0376bd8820abceacf700f461a158dbc7bde35fd05db7d5b8ed40941f
+SIZE (gnome3/latexila-3.14.2.tar.xz) = 1128752
diff --git a/editors/latexila/pkg-descr b/editors/latexila/pkg-descr
new file mode 100644
index 000000000000..b7e0ee50113d
--- /dev/null
+++ b/editors/latexila/pkg-descr
@@ -0,0 +1,5 @@
+LaTeXila is a LaTeX editor for the GNOME desktop. The idea of LaTeXila is
+to always deal directly with the LaTeX code, while simplifying as most as
+possible the writing of this LaTeX code.
+
+WWW: https://wiki.gnome.org/Apps/LaTeXila
diff --git a/editors/latexila/pkg-plist b/editors/latexila/pkg-plist
new file mode 100644
index 000000000000..fcf01bd7fc24
--- /dev/null
+++ b/editors/latexila/pkg-plist
@@ -0,0 +1,49 @@
+bin/latexila
+man/man1/latexila.1.gz
+share/appdata/latexila.appdata.xml
+share/applications/latexila.desktop
+share/icons/hicolor/128x128/apps/latexila.png
+share/icons/hicolor/16x16/apps/latexila.png
+share/icons/hicolor/22x22/apps/latexila.png
+share/icons/hicolor/24x24/apps/latexila.png
+share/icons/hicolor/256x256/apps/latexila.png
+share/icons/hicolor/32x32/apps/latexila.png
+share/icons/hicolor/48x48/apps/latexila.png
+share/icons/hicolor/scalable/apps/latexila.svg
+%%DATADIR%%/build_tools.xml
+%%DATADIR%%/completion.xml
+%%DATADIR%%/images/app/logo.png
+%%DATADIR%%/latexhelp.html
+%%DATADIR%%/templates/article.xml
+%%DATADIR%%/templates/beamer.xml
+%%DATADIR%%/templates/book.xml
+%%DATADIR%%/templates/letter.xml
+%%DATADIR%%/templates/report.xml
+%%DATADIR%%/ui/preferences_dialog.ui
+%%DATADIR%%/ui/ui.xml
+share/locale/ca/LC_MESSAGES/latexila.mo
+share/locale/cs/LC_MESSAGES/latexila.mo
+share/locale/de/LC_MESSAGES/latexila.mo
+share/locale/el/LC_MESSAGES/latexila.mo
+share/locale/eo/LC_MESSAGES/latexila.mo
+share/locale/es/LC_MESSAGES/latexila.mo
+share/locale/eu/LC_MESSAGES/latexila.mo
+share/locale/fr/LC_MESSAGES/latexila.mo
+share/locale/gl/LC_MESSAGES/latexila.mo
+share/locale/he/LC_MESSAGES/latexila.mo
+share/locale/hu/LC_MESSAGES/latexila.mo
+share/locale/id/LC_MESSAGES/latexila.mo
+share/locale/it/LC_MESSAGES/latexila.mo
+share/locale/lt/LC_MESSAGES/latexila.mo
+share/locale/lv/LC_MESSAGES/latexila.mo
+share/locale/nb/LC_MESSAGES/latexila.mo
+share/locale/nl/LC_MESSAGES/latexila.mo
+share/locale/pl/LC_MESSAGES/latexila.mo
+share/locale/pt_BR/LC_MESSAGES/latexila.mo
+share/locale/ru/LC_MESSAGES/latexila.mo
+share/locale/sl/LC_MESSAGES/latexila.mo
+share/locale/sr/LC_MESSAGES/latexila.mo
+share/locale/sr@latin/LC_MESSAGES/latexila.mo
+share/locale/sv/LC_MESSAGES/latexila.mo
+share/locale/uk/LC_MESSAGES/latexila.mo
+share/locale/zh_CN/LC_MESSAGES/latexila.mo