aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-16 16:06:21 +0800
committeryuri <yuri@FreeBSD.org>2018-03-16 16:06:21 +0800
commit9e1cd494d20a1b6350922a58a9858f03e7e2d7ab (patch)
treeff37f7f5b6d1f6c0480680cb82eaae848dd2b576 /editors
parentad3d461634257a91986c2f364a9969090faef0ed (diff)
downloadfreebsd-ports-gnome-9e1cd494d20a1b6350922a58a9858f03e7e2d7ab.tar.gz
freebsd-ports-gnome-9e1cd494d20a1b6350922a58a9858f03e7e2d7ab.tar.zst
freebsd-ports-gnome-9e1cd494d20a1b6350922a58a9858f03e7e2d7ab.zip
New port: editors/neovim-qt: Neovim client library and QT5 GUI
PR: 224427 Submitted by: chuck@tuffli.net
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/neovim-qt/Makefile28
-rw-r--r--editors/neovim-qt/distinfo3
-rw-r--r--editors/neovim-qt/pkg-descr5
-rw-r--r--editors/neovim-qt/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index ad32b7f7f83b..9d95aa493aab 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -197,6 +197,7 @@
SUBDIR += ne
SUBDIR += nedit
SUBDIR += neovim
+ SUBDIR += neovim-qt
SUBDIR += nvi-devel
SUBDIR += nvi-m17n
SUBDIR += omegaT
diff --git a/editors/neovim-qt/Makefile b/editors/neovim-qt/Makefile
new file mode 100644
index 000000000000..a6c0d2fef001
--- /dev/null
+++ b/editors/neovim-qt/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= neovim-qt
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.8
+CATEGORIES= editors
+
+MAINTAINER= chuck@tuffli.net
+COMMENT= Neovim client library and QT5 GUI
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= neovim>=0:editors/neovim
+LIB_DEPENDS= libmsgpackc.so:devel/msgpack
+RUN_DEPENDS= neovim>=0:editors/neovim
+
+USES= cmake:outsource desktop-file-utils
+USE_GITHUB= yes
+GH_ACCOUNT= equalsraf
+USE_QT5= core gui testlib network widgets buildtools_build qmake_build
+
+CMAKE_ON= USE_SYSTEM_MSGPACK
+CMAKE_OFF= ENABLE_TESTS
+
+DATADIR= ${PREFIX}/share/nvim-qt
+
+.include <bsd.port.mk>
diff --git a/editors/neovim-qt/distinfo b/editors/neovim-qt/distinfo
new file mode 100644
index 000000000000..a32434804939
--- /dev/null
+++ b/editors/neovim-qt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513608557
+SHA256 (equalsraf-neovim-qt-v0.2.8_GH0.tar.gz) = 53653c21de1dd41fb78a65f27e989b3478c74ad91cbde92f831fb3d81b25802b
+SIZE (equalsraf-neovim-qt-v0.2.8_GH0.tar.gz) = 969166
diff --git a/editors/neovim-qt/pkg-descr b/editors/neovim-qt/pkg-descr
new file mode 100644
index 000000000000..815df3b5ea70
--- /dev/null
+++ b/editors/neovim-qt/pkg-descr
@@ -0,0 +1,5 @@
+neovim is a Qt5 GUI for neovim.
+Commands for interacting with the GUI are regular commands,
+available in the documentation.
+
+WWW: https://github.com/equalsraf/neovim-qt/
diff --git a/editors/neovim-qt/pkg-plist b/editors/neovim-qt/pkg-plist
new file mode 100644
index 000000000000..10b9da688966
--- /dev/null
+++ b/editors/neovim-qt/pkg-plist
@@ -0,0 +1,7 @@
+bin/nvim-qt
+share/applications/nvim-qt.desktop
+%%DATADIR%%/runtime/README.md
+%%DATADIR%%/runtime/doc/nvim_gui_shim.txt
+%%DATADIR%%/runtime/doc/tags
+%%DATADIR%%/runtime/plugin/nvim_gui_shim.vim
+share/pixmaps/nvim-qt.png