aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
committermat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
commitb2012f72500300ecbba6933c68717ba52c454563 (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /editors
parente02e32ae84bd96a47a379dcd2c109efc58b41400 (diff)
downloadfreebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.gz
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.zst
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Diffstat (limited to 'editors')
-rw-r--r--editors/gwrite/Makefile10
-rw-r--r--editors/leo/Makefile6
-rw-r--r--editors/py-room/Makefile2
3 files changed, 9 insertions, 9 deletions
diff --git a/editors/gwrite/Makefile b/editors/gwrite/Makefile
index 8de253deded4..7acc01013320 100644
--- a/editors/gwrite/Makefile
+++ b/editors/gwrite/Makefile
@@ -14,13 +14,13 @@ COMMENT= Simple HTML format editor
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-distutils-extra>=2.15:devel/py-python-distutils-extra@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jswebkit>=0:www/py-jswebkit@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:www/py-webkitgtk@${FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-distutils-extra>=2.15:devel/py-python-distutils-extra@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jswebkit>=0:www/py-jswebkit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:www/py-webkitgtk@${PY_FLAVOR}
RUN_DEPENDS= gnome-icon-theme>=0:misc/gnome-icon-theme \
wvHtml:textproc/wv \
- ${PYTHON_PKGNAMEPREFIX}jswebkit>=0:www/py-jswebkit@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:www/py-webkitgtk@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}jswebkit>=0:www/py-jswebkit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:www/py-webkitgtk@${PY_FLAVOR}
NO_ARCH= yes
USES= desktop-file-utils gettext-tools python:2.7
diff --git a/editors/leo/Makefile b/editors/leo/Makefile
index 00699cfe0316..d7f58647fe3c 100644
--- a/editors/leo/Makefile
+++ b/editors/leo/Makefile
@@ -15,8 +15,8 @@ COMMENT= Advanced outline editor for programmers
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils@${FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils@${PY_FLAVOR} \
silvercity>0:textproc/silvercity
USES= pyqt:4 python:2.7 shebangfix zip
@@ -32,7 +32,7 @@ DESKTOP_ENTRIES="Leo" "Literate Editor with Outlines" \
OPTIONS_DEFINE= PYENCHANT
PYENCHANT_DESC= Spell checking support via PyEnchant
-PYENCHANT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}enchant>0:textproc/py-enchant@${FLAVOR}
+PYENCHANT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}enchant>0:textproc/py-enchant@${PY_FLAVOR}
post-patch:
@${LN} -sf leo/dist/leo-install.py ${WRKSRC}/leo-install.py
diff --git a/editors/py-room/Makefile b/editors/py-room/Makefile
index a3251d4feb08..4821c89a1837 100644
--- a/editors/py-room/Makefile
+++ b/editors/py-room/Makefile
@@ -12,7 +12,7 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= arundel@FreeBSD.org
COMMENT= PyRoom is a clone of WriteRoom and features "distraction-free writing"
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:devel/py-xdg@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:devel/py-xdg@${PY_FLAVOR}
USES= gettext python:2.7
USE_PYTHON= distutils