aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorkiri <kiri@FreeBSD.org>2003-05-08 13:54:24 +0800
committerkiri <kiri@FreeBSD.org>2003-05-08 13:54:24 +0800
commitce82fbdfcc9bd83789405ef49792a4eb29f93ed5 (patch)
tree78f10de6363d327bf3424de4b0888bfb7bebda09 /editors
parent24b455bbddc4ebc3bf19696c4f6f090b2fab2ca7 (diff)
downloadfreebsd-ports-gnome-ce82fbdfcc9bd83789405ef49792a4eb29f93ed5.tar.gz
freebsd-ports-gnome-ce82fbdfcc9bd83789405ef49792a4eb29f93ed5.tar.zst
freebsd-ports-gnome-ce82fbdfcc9bd83789405ef49792a4eb29f93ed5.zip
Set MASTER_SITES fetchable and correct reinplace commands.
Diffstat (limited to 'editors')
-rw-r--r--editors/muggy/Makefile13
-rw-r--r--editors/muggy/pkg-descr2
-rw-r--r--editors/muggy/pkg-plist1
-rw-r--r--editors/muggy/scripts/post-install12
4 files changed, 16 insertions, 12 deletions
diff --git a/editors/muggy/Makefile b/editors/muggy/Makefile
index 73c59540a4c3..44538603b8af 100644
--- a/editors/muggy/Makefile
+++ b/editors/muggy/Makefile
@@ -8,21 +8,24 @@
PORTNAME= muggy
PORTVERSION= 1.3.1
CATEGORIES+= editors windowmaker tkstep80
-
-MASTER_SITES= http://www.aaa-int.or.jp/~jfactory/Factory/JDE/dist/
+MASTER_SITES= http://www.aaa-int.or.jp/~jfactory/JDE/dist/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= . kiri
DISTNAME= Muggy-${PORTVERSION}
+EXTRACT_ONLY= # extracted directly in install target
-MAINTAINER= kiri@pis.toba-cmt.ac.jp
+MAINTAINER= kiri@FreeBSD.org
COMMENT= A simple text editor for the X on TkStep
RUN_DEPENDS= ${RUN_DEP_LIST}
LIB_DEPENDS= ${LIB_DEP_LIST}
-EXTRACT_ONLY= # extracted directly in install target
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
-SCRIPTS_ENV= LANG=C LN=${LN} PERL=${PERL} LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
+USE_REINPLACE= yes
+SCRIPTS_ENV= LANG=C LN=${LN} REINPLACE_CMD="${REINPLACE_CMD}" \
+ LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
PLIST_SUB= PIXMAP_PATH=${PIXMAPPATH:S@^${PREFIX}/@@}
# This port is for both editors/muggy and japanese/muggy.
diff --git a/editors/muggy/pkg-descr b/editors/muggy/pkg-descr
index 591d489b6911..e9010c829e90 100644
--- a/editors/muggy/pkg-descr
+++ b/editors/muggy/pkg-descr
@@ -16,4 +16,4 @@ Note that both editors/muggy and japanese/muggy are mutually exclusive and
SHOULD NOT BE INSTALLED SIMULTANEOUSLY!
-KIRIYAMA Kazuhiko
-<kiri@pis.toba-cmt.ac.jp>
+<kiri@FreeBSD.org>
diff --git a/editors/muggy/pkg-plist b/editors/muggy/pkg-plist
index e4e6cc6a4a81..16642dadebef 100644
--- a/editors/muggy/pkg-plist
+++ b/editors/muggy/pkg-plist
@@ -34,3 +34,4 @@ bin/Muggy.app
@dirrm JDE/Muggy/modules/Undo.m
@dirrm JDE/Muggy/modules
@dirrm JDE/Muggy
+@unexec rmdir %D/JDE 2>/dev/null || true
diff --git a/editors/muggy/scripts/post-install b/editors/muggy/scripts/post-install
index 0c4682353cb0..c87e77330fe8 100644
--- a/editors/muggy/scripts/post-install
+++ b/editors/muggy/scripts/post-install
@@ -5,9 +5,9 @@ installdir=${PREFIX}/JDE/Muggy; export installdir
case ${LANGUAGE} in
Japanese)
for f in Muggy.app; do
- ${PERL} -pi -e '
- s/^(exec[ \t]+)wishstep[^ \t]*([ \t]+.*)$/$1wishstep$ENV{VERSION}jp$2/
- ' ${installdir}/bin/${f}
+ ${REINPLACE_CMD} -E -e \
+ "s/^(exec[[:space:]]+)wishstep[[:space:]]*([[:space:]]+.*)\$/\1wishstep${VERSION}jp\2/" \
+ ${installdir}/bin/${f}
done
;;
*)
@@ -22,9 +22,9 @@ for f in Muggy Muggy.app; do
target=${installdir}/defaults/${f}
;;
esac
- ${PERL} -pi -e '
- s@^([ \t]*set[ \t]+Jlib[ \t]+)"[^"]*"$@$1"$ENV{installdir}/"@;
- ' ${target}
+ ${REINPLACE_CMD} -E -e \
+ "s@^([[:space:]]*set[[:space:]]+Jlib[[:space:]]+)\"[^\"]*\"\$@\1\"${installdir}/\"@" \
+ ${target}
done
${LN} -sf ${installdir}/bin/Muggy.app ${PREFIX}/bin