aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-06-22 00:52:57 +0800
committergarga <garga@FreeBSD.org>2006-06-22 00:52:57 +0800
commite416f6b5179372ab8fc11462fd3228f1af4b407c (patch)
tree3abb8b4e8f5a30d48a157f92362792c68a554e40 /editors
parent40e91b7981c1efc86d743e41890b0b4c441263f4 (diff)
downloadfreebsd-ports-gnome-e416f6b5179372ab8fc11462fd3228f1af4b407c.tar.gz
freebsd-ports-gnome-e416f6b5179372ab8fc11462fd3228f1af4b407c.tar.zst
freebsd-ports-gnome-e416f6b5179372ab8fc11462fd3228f1af4b407c.zip
- Update fpc to 2.0.2
PR: 98628, 98629, 98630, 98632, 98641, 98646, 98650, 98652, 98654, 98656, 98657, 98658, 98720, 98724 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'editors')
-rw-r--r--editors/fpc-ide/Makefile75
-rw-r--r--editors/fpc-ide/distinfo3
-rw-r--r--editors/fpc-ide/files/patch-share::src::fpc-1.0.10::ide::compiler::Makefile.fpc11
-rw-r--r--editors/fpc-ide/pkg-descr8
-rw-r--r--editors/fpc-ide/pkg-plist16
5 files changed, 7 insertions, 106 deletions
diff --git a/editors/fpc-ide/Makefile b/editors/fpc-ide/Makefile
index ba34606c8015..ec6fafe50b52 100644
--- a/editors/fpc-ide/Makefile
+++ b/editors/fpc-ide/Makefile
@@ -5,77 +5,16 @@
# $FreeBSD$
#
-PORTNAME= ide
-PORTVERSION= 1.0.10
CATEGORIES= editors lang
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= freepascal
-PKGNAMEPREFIX= fpc-
-DISTNAME= fpc-${PORTVERSION}.ELF
-EXTRACT_SUFX= .tar
+PKGNAMESUFFIX= -ide
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= acardenas@bsd.org.pe
COMMENT= Free Pascal integrated IDE/compiler
-BROKEN= Waiting for fpc-* updated to 2.0.2
+RUN_DEPENDS= ${UNITSDIR}/fv/Package.fpc:${PORTSDIR}/devel/fpc-fv
-.include <bsd.port.pre.mk>
+UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
+UNITPREFIX= # none
+MASTERDIR= ${.CURDIR}/../../lang/fpc
-BUILD_DEPENDS+= ppc386:${PORTSDIR}/lang/fpc \
- ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/freebsd/gdbint/gdbint.ppu:${PORTSDIR}/devel/fpc-gdbint \
- ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/freebsd/fv/drivers.ppu:${PORTSDIR}/devel/fpc-fv
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-.if ${OSVERSION} < 470000
-EXTRACT_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
-TAR= ${LOCALBASE}/bin/gtar
-.endif
-USE_GMAKE= yes
-ONLY_FOR_ARCHS= i386
-
-DOCSDIR= ${PREFIX}/share/doc/fpc
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
-
-MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
- FPC=${LOCALBASE}/bin/ppc386 \
- INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
- INSTALL_BINDIR=${PREFIX}/bin \
- INSTALL_DOCDIR=${DOCSDIR} \
- GCCLIBDIR=/usr/lib \
- GDBLIBDIR=${LOCALBASE}/lib/fpc/${PORTVERSION}/units/freebsd/gdbint/libgdb \
- RELEASE=1
-
-do-extract:
-# unpack distribution
- @${MKDIR} ${WRKSRC}
- @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
-# unpack sources distribution
- @${MKDIR} ${WRKSRC}/sources
- @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
-# further extract base sources
-#
-# ide and compiler sources
- @${TAR} zxf ${WRKSRC}/sources/compilersrc.tar.gz \
- --directory ${WRKSRC}
- @${TAR} zxf ${WRKSRC}/sources/idesrc.tar.gz \
- --directory ${WRKSRC}
-
-post-patch:
-# change to alter amount of optimization
- @${FIND} ${WRKSRC}/share/src -name "Makefile*" | \
- ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
-
-pre-build:
- cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/ide/compiler && \
- fpcmake
-
-do-build:
- @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
- ${WRKSRC}/share/src/fpc-${PORTVERSION}/ide \
- all
-
-do-install:
- @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
- ${WRKSRC}/share/src/fpc-${PORTVERSION}/ide \
- install
-
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/editors/fpc-ide/distinfo b/editors/fpc-ide/distinfo
deleted file mode 100644
index fb00975ada0c..000000000000
--- a/editors/fpc-ide/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (fpc-1.0.10.ELF.tar) = 6ad56eb115152174683499da3ece7667
-SHA256 (fpc-1.0.10.ELF.tar) = 318bab9d1269dffcc5fe737d224fca939c5f130f34f12d166319b3d1ba776bfb
-SIZE (fpc-1.0.10.ELF.tar) = 17448960
diff --git a/editors/fpc-ide/files/patch-share::src::fpc-1.0.10::ide::compiler::Makefile.fpc b/editors/fpc-ide/files/patch-share::src::fpc-1.0.10::ide::compiler::Makefile.fpc
deleted file mode 100644
index baf0f516754e..000000000000
--- a/editors/fpc-ide/files/patch-share::src::fpc-1.0.10::ide::compiler::Makefile.fpc
+++ /dev/null
@@ -1,11 +0,0 @@
---- share/src/fpc-1.0.10/ide/compiler/Makefile.fpc.old Fri Jan 16 00:23:44 2004
-+++ share/src/fpc-1.0.10/ide/compiler/Makefile.fpc Fri Jan 16 00:25:03 2004
-@@ -18,7 +18,7 @@
- fpcdir=../..
-
- [prerules]
--COMPILERDIR=$(FPCDIR)/compiler
-+COMPILERDIR=../../compiler
-
- # Use 1.0.2 and 1.0.4 require -Ca to generate simple ppu
- ifneq ($(findstring 1.0.2,$(FPC_VERSION)),)
diff --git a/editors/fpc-ide/pkg-descr b/editors/fpc-ide/pkg-descr
deleted file mode 100644
index 4305d3772783..000000000000
--- a/editors/fpc-ide/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-Regexpr is part of the base packages of Free Pascal,
-a 32-bit Turbo Pascal/Delphi compatible compiler. Regexpr
-provides regular expression routines.
-
-WWW: http://www.freepascal.org/
-
---
-John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/editors/fpc-ide/pkg-plist b/editors/fpc-ide/pkg-plist
deleted file mode 100644
index fed731fcfab1..000000000000
--- a/editors/fpc-ide/pkg-plist
+++ /dev/null
@@ -1,16 +0,0 @@
-bin/fp
-lib/fpc/%%PORTVERSION%%/ide/cvsco.tdf
-lib/fpc/%%PORTVERSION%%/ide/cvsdiff.tdf
-lib/fpc/%%PORTVERSION%%/ide/cvsup.tdf
-lib/fpc/%%PORTVERSION%%/ide/fp.ans
-lib/fpc/%%PORTVERSION%%/ide/gplprog.pt
-lib/fpc/%%PORTVERSION%%/ide/gplunit.pt
-lib/fpc/%%PORTVERSION%%/ide/grep.tdf
-lib/fpc/%%PORTVERSION%%/ide/program.pt
-lib/fpc/%%PORTVERSION%%/ide/tpgrep.tdf
-lib/fpc/%%PORTVERSION%%/ide/unit.pt
-%%DOCSDIR%%/readme.ide
-@dirrm %%DOCSDIR%%
-@dirrm lib/fpc/%%PORTVERSION%%/ide
-@dirrm lib/fpc/%%PORTVERSION%%
-@dirrm lib/fpc