aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2004-04-01 09:27:29 +0800
committernaddy <naddy@FreeBSD.org>2004-04-01 09:27:29 +0800
commit099233cfd90b9c5b7ee2774354970749ffa2e3cf (patch)
tree297f634bc15ea56cc1ce2962a61922ba190bed8e /editors
parent866a71f355f9c0b6d6bd903dc5d919c5a40e578f (diff)
downloadfreebsd-ports-gnome-099233cfd90b9c5b7ee2774354970749ffa2e3cf.tar.gz
freebsd-ports-gnome-099233cfd90b9c5b7ee2774354970749ffa2e3cf.tar.zst
freebsd-ports-gnome-099233cfd90b9c5b7ee2774354970749ffa2e3cf.zip
Expand $SYSCONFDIR in man pages.
Obtained from: Robert Nagy <thuglife@bsd.hu> via OpenBSD
Diffstat (limited to 'editors')
-rw-r--r--editors/nano/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index ee34629965c1..f026f508f521 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nano
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://www.nano-editor.org/dist/v1.2/ \
http://www.ewtoo.org/~astyanax/nano/dist/v1.2/
@@ -19,11 +20,16 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-all
USE_GETTEXT= yes
+USE_REINPLACE= yes
INFO= nano
MAN1= nano.1
MAN5= nanorc.5
+post-build:
+ ${REINPLACE_CMD} 's:\$$SYSCONFDIR:${PREFIX}/etc:g' \
+ ${WRKSRC}/${MAN1} ${WRKSRC}/${MAN5}
+
post-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/nanorc.sample ${EXAMPLESDIR}