aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2005-01-25 17:07:29 +0800
committerijliao <ijliao@FreeBSD.org>2005-01-25 17:07:29 +0800
commit187ecb4289bfb72ef9fde96fb0a552b88b044887 (patch)
tree2f0849178d1cefdb7b04b1b66e68a3fb6a981471 /editors
parent3fbfa7af2df4f97de6edbb83d91c60f29d9c3fcd (diff)
downloadfreebsd-ports-gnome-187ecb4289bfb72ef9fde96fb0a552b88b044887.tar.gz
freebsd-ports-gnome-187ecb4289bfb72ef9fde96fb0a552b88b044887.tar.zst
freebsd-ports-gnome-187ecb4289bfb72ef9fde96fb0a552b88b044887.zip
add code-browser 1.2
A Folding Text Editor
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/code-browser/Makefile28
-rw-r--r--editors/code-browser/distinfo2
-rw-r--r--editors/code-browser/pkg-descr14
-rw-r--r--editors/code-browser/pkg-plist4
5 files changed, 49 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index b97102304359..0910e471e3de 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -29,6 +29,7 @@
SUBDIR += bpatch
SUBDIR += bvi
SUBDIR += chexedit
+ SUBDIR += code-browser
SUBDIR += color-mate
SUBDIR += conglomerate
SUBDIR += cooledit
diff --git a/editors/code-browser/Makefile b/editors/code-browser/Makefile
new file mode 100644
index 000000000000..12fbed621b58
--- /dev/null
+++ b/editors/code-browser/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: code-browser
+# Date created: Jan 25, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= code-browser
+PORTVERSION= 1.2
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Folding Text Editor
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_REINPLACE= yes
+USE_GNOME= gtk20
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/local,${PREFIX}," \
+ -e "s,^CC,#CC," -e "s,^CFLAGS,#CFLAGS," \
+ ${WRKSRC}/${MAKEFILE} ${WRKSRC}/zinc/${MAKEFILE}
+
+.include <bsd.port.mk>
diff --git a/editors/code-browser/distinfo b/editors/code-browser/distinfo
new file mode 100644
index 000000000000..2361439d1b10
--- /dev/null
+++ b/editors/code-browser/distinfo
@@ -0,0 +1,2 @@
+MD5 (code-browser-1.2-src.tar.gz) = 769c3c591e42f68c536a9d231dc003a0
+SIZE (code-browser-1.2-src.tar.gz) = 413958
diff --git a/editors/code-browser/pkg-descr b/editors/code-browser/pkg-descr
new file mode 100644
index 000000000000..9cc16bfb5b39
--- /dev/null
+++ b/editors/code-browser/pkg-descr
@@ -0,0 +1,14 @@
+Code Browser is a folding and outlining editor.
+
+The editor is between a traditional text editor, a smalltalk class browser and
+a web browser like mozilla. It displays a structured text file (marker-based
+folding) hierarchically using multiple panes.
+
+It is especially designed to keep a good overview of the code of large
+projects.
+
+It supports syntax highlighting for C, C++, C#, VB.Net, Java, Python, Ruby,
+Pascal, TeX, Makefile, XML, HTML and CSS. Custom syntax highlighting can also
+be added.
+
+WWW: http://code-browser.sourceforge.net/
diff --git a/editors/code-browser/pkg-plist b/editors/code-browser/pkg-plist
new file mode 100644
index 000000000000..478853da2719
--- /dev/null
+++ b/editors/code-browser/pkg-plist
@@ -0,0 +1,4 @@
+bin/code-browser
+%%DATADIR%%/languages.cb-config
+%%DATADIR%%/user-preferences.cb-config
+@dirrm %%DATADIR%%