aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2000-12-24 22:21:47 +0800
committeralex <alex@FreeBSD.org>2000-12-24 22:21:47 +0800
commit1b1d74bb24c333f4418813689228b1573a1573d8 (patch)
tree3057fab69bb9451bc9912f0d2885bee47a124f4d /editors
parent2cc0345fddb7f41a53311a7c9e5d8256cca29643 (diff)
downloadfreebsd-ports-gnome-1b1d74bb24c333f4418813689228b1573a1573d8.tar.gz
freebsd-ports-gnome-1b1d74bb24c333f4418813689228b1573a1573d8.tar.zst
freebsd-ports-gnome-1b1d74bb24c333f4418813689228b1573a1573d8.zip
Fix default $PATH settings for user-installation.
PR: 23773 Submitted by: Martin Blapp <mb@imp.ch> (maintainer) Thanks to: jedgar ("or bug Alex") =)
Diffstat (limited to 'editors')
-rw-r--r--editors/staroffice52/Makefile4
-rw-r--r--editors/staroffice60/Makefile4
-rw-r--r--editors/staroffice70/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/editors/staroffice52/Makefile b/editors/staroffice52/Makefile
index 4085d13df594..b081bfe47260 100644
--- a/editors/staroffice52/Makefile
+++ b/editors/staroffice52/Makefile
@@ -36,6 +36,7 @@ DIST_SUBDIR= staroffice52
WRKSRC= ${WRKDIR}/office52
TMPDIR= ${WRKDIR}/tmp
LD_PATH= ${TMPDIR}:${WRKSRC}:${LINUXBASE}/lib:${LINUXBASE}/usr/lib
+INSTDB.INS= ${PREFIX}/office52/program/instdb.ins
.include <bsd.port.pre.mk>
@@ -121,6 +122,9 @@ do-install:
post-install:
@${PATCH} -s ${PREFIX}/office52/program/setup ${FILESDIR}/setup.patch
@${PATCH} -s ${PREFIX}/office52/program/soffice ${FILESDIR}/soffice.patch
+ @${CP} ${INSTDB.INS} ${INSTDB.INS}.orig
+ @${SED} -e 's%DefaultDestPath = "/usr/local/office52%DefaultDestPath = "office52%' \
+ < ${INSTDB.INS}.orig > ${INSTDB.INS}
install-user:
${PREFIX}/office52/program/setup
diff --git a/editors/staroffice60/Makefile b/editors/staroffice60/Makefile
index 4085d13df594..b081bfe47260 100644
--- a/editors/staroffice60/Makefile
+++ b/editors/staroffice60/Makefile
@@ -36,6 +36,7 @@ DIST_SUBDIR= staroffice52
WRKSRC= ${WRKDIR}/office52
TMPDIR= ${WRKDIR}/tmp
LD_PATH= ${TMPDIR}:${WRKSRC}:${LINUXBASE}/lib:${LINUXBASE}/usr/lib
+INSTDB.INS= ${PREFIX}/office52/program/instdb.ins
.include <bsd.port.pre.mk>
@@ -121,6 +122,9 @@ do-install:
post-install:
@${PATCH} -s ${PREFIX}/office52/program/setup ${FILESDIR}/setup.patch
@${PATCH} -s ${PREFIX}/office52/program/soffice ${FILESDIR}/soffice.patch
+ @${CP} ${INSTDB.INS} ${INSTDB.INS}.orig
+ @${SED} -e 's%DefaultDestPath = "/usr/local/office52%DefaultDestPath = "office52%' \
+ < ${INSTDB.INS}.orig > ${INSTDB.INS}
install-user:
${PREFIX}/office52/program/setup
diff --git a/editors/staroffice70/Makefile b/editors/staroffice70/Makefile
index 4085d13df594..b081bfe47260 100644
--- a/editors/staroffice70/Makefile
+++ b/editors/staroffice70/Makefile
@@ -36,6 +36,7 @@ DIST_SUBDIR= staroffice52
WRKSRC= ${WRKDIR}/office52
TMPDIR= ${WRKDIR}/tmp
LD_PATH= ${TMPDIR}:${WRKSRC}:${LINUXBASE}/lib:${LINUXBASE}/usr/lib
+INSTDB.INS= ${PREFIX}/office52/program/instdb.ins
.include <bsd.port.pre.mk>
@@ -121,6 +122,9 @@ do-install:
post-install:
@${PATCH} -s ${PREFIX}/office52/program/setup ${FILESDIR}/setup.patch
@${PATCH} -s ${PREFIX}/office52/program/soffice ${FILESDIR}/soffice.patch
+ @${CP} ${INSTDB.INS} ${INSTDB.INS}.orig
+ @${SED} -e 's%DefaultDestPath = "/usr/local/office52%DefaultDestPath = "office52%' \
+ < ${INSTDB.INS}.orig > ${INSTDB.INS}
install-user:
${PREFIX}/office52/program/setup