aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-07-17 04:53:28 +0800
committerkwm <kwm@FreeBSD.org>2015-07-17 04:53:28 +0800
commit4490d4bc75707dbdea79b297aac91b4ce174c25f (patch)
tree3fa9947d2b38c86d548ab0b4face968420a2825b /editors
parent929b8a6a2120516c63b8fecd8eba713ab5aafae2 (diff)
downloadfreebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.tar.gz
freebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.tar.zst
freebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.zip
Convert code in bsd.port.mk for USE_GHOSTSCRIPT* to USES=ghostscript.
Add GHOSTSCRIPT_DEFAULT to bsd.default-versions.mk for easy version selection. Arguments supported: <empty>, build, run, nox11 and agpl PR: 201201 (exp-run) Approved by: portmgr (mat@) Exp run by: antione@ (previous patch) Differential Revision: https://reviews.freebsd.org/D2938
Diffstat (limited to 'editors')
-rw-r--r--editors/ted/Makefile3
-rw-r--r--editors/texmacs/Makefile2
-rw-r--r--editors/texmaker/Makefile3
-rw-r--r--editors/texstudio/Makefile4
4 files changed, 5 insertions, 7 deletions
diff --git a/editors/ted/Makefile b/editors/ted/Makefile
index 8c3f3dc2b472..67c2ae1a7a54 100644
--- a/editors/ted/Makefile
+++ b/editors/ted/Makefile
@@ -26,8 +26,7 @@ GTK2_DESC= Use GTK2 instead of MOTIF
WRKSRC= ${WRKDIR}/Ted-${PORTVERSION}
USE_XORG= xext xft
-USES= iconv
-USE_GHOSTSCRIPT_RUN= yes
+USES= ghostscript:run iconv
GNU_CONFIGURE= yes
MAKE_ENV= DEF_AFMDIR="-DAFMDIR=\"\\\"${AFMDIR}/\\\"\"" \
DEF_INDDIR="-DINDDIR=\"\\\"${INDDIR}/\\\"\"" \
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index d5bb52a759a8..9868057c1d0c 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -40,7 +40,7 @@ PDF_DESC= Experimental PDF renderer
FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
FREETYPE_CONFIGURE_WITH=freetype=linked
-GHOSTSCRIPT_USE= GHOSTSCRIPT=yes
+GHOSTSCRIPT_USES= ghostscript
GHOSTSCRIPT_CONFIGURE_WITH= gs=yes
ICONV_USES= iconv
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index af79d994389c..659aaf04b468 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -13,8 +13,7 @@ COMMENT= LaTeX Development Environment
LIB_DEPENDS= libpoppler.so:${PORTSDIR}/graphics/poppler
-USES= desktop-file-utils pkgconfig qmake tar:bzip2
-USE_GHOSTSCRIPT_RUN= yes
+USES= desktop-file-utils ghostscript:run pkgconfig qmake tar:bzip2
_USE_QT4= gui network xml webkit \
moc_build rcc_build uic_build
_USE_QT5= concurrent network printsupport script webkit widgets \
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index eac291513859..5a8242dc9c95 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -12,9 +12,9 @@ COMMENT= Integrated writing environment for creating LaTeX documents
LIB_DEPENDS= libpoppler.so:${PORTSDIR}/graphics/poppler \
libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
-USES= desktop-file-utils dos2unix execinfo pkgconfig qmake
+USES= desktop-file-utils dos2unix execinfo ghostscript:run \
+ pkgconfig qmake
DOS2UNIX_FILES= ${PORTNAME}.pro
-USE_GHOSTSCRIPT_RUN= yes
USE_QT4= gui network script svg xml iconengines_run \
designer_build moc_build rcc_build uic_build
USE_TEX= latex dvipsk