aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-06 15:01:48 +0800
committerbapt <bapt@FreeBSD.org>2013-05-06 15:01:48 +0800
commit55d0741661fb8c8862b383d81d0eb498f1c51ae6 (patch)
tree9bb92c7ef944cb6f89581b84d95897330d992111 /editors
parentd710175d83c8aa4d07a683513f7a149d53bb716e (diff)
downloadfreebsd-ports-gnome-55d0741661fb8c8862b383d81d0eb498f1c51ae6.tar.gz
freebsd-ports-gnome-55d0741661fb8c8862b383d81d0eb498f1c51ae6.tar.zst
freebsd-ports-gnome-55d0741661fb8c8862b383d81d0eb498f1c51ae6.zip
Finish converting e* from WITHOUT_NLS to PORT_OPTIONS:MNLS
Diffstat (limited to 'editors')
-rw-r--r--editors/ssed/Makefile16
-rw-r--r--editors/zoinks/Makefile18
2 files changed, 15 insertions, 19 deletions
diff --git a/editors/ssed/Makefile b/editors/ssed/Makefile
index e1343fda9876..825cee580c68 100644
--- a/editors/ssed/Makefile
+++ b/editors/ssed/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ssed
-# Date created: 28 May 2002
-# Whom: verm
-#
+# Created by: verm
# $FreeBSD$
-#
PORTNAME= sed
PORTVERSION= 3.62
@@ -20,13 +16,15 @@ CONFIGURE_ARGS= --program-prefix=s
MAN1= ssed.1
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.mk>
diff --git a/editors/zoinks/Makefile b/editors/zoinks/Makefile
index e7e93b4ef277..d391ae1ae8e9 100644
--- a/editors/zoinks/Makefile
+++ b/editors/zoinks/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zoinks
-# Date created: 26 July 2003
-# Whom: Mike Lockwood <mike@mikelockwood.com>
-#
+# Created by: Mike Lockwood <mike@mikelockwood.com>
# $FreeBSD$
-#
PORTNAME= zoinks
PORTVERSION= 0.3.7
@@ -12,7 +8,7 @@ CATEGORIES= editors
MASTER_SITES= http://zoinks.mikelockwood.com/download/
MAINTAINER= mike@mikelockwood.com
-COMMENT= An X11 programmer's editor and development environment
+COMMENT= X11 programmer's editor and development environment
.if defined(WITH_IMLIB)
USE_GNOME= imlib
@@ -21,7 +17,12 @@ CONFIGURE_ARGS+= --enable-imlib
CONFIGURE_ARGS+= --disable-imlib
.endif
-.if !defined(WITHOUT_NLS)
+USE_XORG= xpm
+GNU_CONFIGURE= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -29,9 +30,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-USE_XORG= xpm
-GNU_CONFIGURE= yes
-
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Zoinks can be built with optional support for calculating image sizes"