aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2006-09-26 08:00:11 +0800
committermarkus <markus@FreeBSD.org>2006-09-26 08:00:11 +0800
commit6051cbfa867c76c26ae0a95eca10cf469564f586 (patch)
tree4e70e22a29c670f3f9b0bd93a6e8bee71f6f5a36 /editors
parentb29a8d11b9e89665909eda580d66c1d36203a7e8 (diff)
downloadfreebsd-ports-gnome-6051cbfa867c76c26ae0a95eca10cf469564f586.tar.gz
freebsd-ports-gnome-6051cbfa867c76c26ae0a95eca10cf469564f586.tar.zst
freebsd-ports-gnome-6051cbfa867c76c26ae0a95eca10cf469564f586.zip
- Adjust CONFLICTS entry in order to silence portlint
- Optionally depend on kdegraphics3 for kpdf and kdvi defaulting to "on" [1] Suggested by: Lars Engels <lars.engels@0x20.net> [1]
Diffstat (limited to 'editors')
-rw-r--r--editors/kile-kde4/Makefile12
-rw-r--r--editors/kile/Makefile12
2 files changed, 20 insertions, 4 deletions
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index 0327b843bc3b..b6c145bdfe3d 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -17,15 +17,23 @@ COMMENT= A LaTeX source editor for KDE
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
identify:${PORTSDIR}/graphics/ImageMagick
-CONFLICTS= kile-i18n-*
+CONFLICTS= kile-i18n-[0-9]*
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
+OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| syntax||g' ${WRKSRC}/src/kile/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_KPDF)
+RUN_DEPENDS+= kpdf:${PORTSDIR}/graphics/kdegraphics3
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index 0327b843bc3b..b6c145bdfe3d 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -17,15 +17,23 @@ COMMENT= A LaTeX source editor for KDE
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
identify:${PORTSDIR}/graphics/ImageMagick
-CONFLICTS= kile-i18n-*
+CONFLICTS= kile-i18n-[0-9]*
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
+OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| syntax||g' ${WRKSRC}/src/kile/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_KPDF)
+RUN_DEPENDS+= kpdf:${PORTSDIR}/graphics/kdegraphics3
+.endif
+
+.include <bsd.port.post.mk>