aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-10-19 23:43:33 +0800
committermva <mva@FreeBSD.org>2014-10-19 23:43:33 +0800
commit68713e63a873487d61e13839964717ad31707a77 (patch)
tree007c8519a6455a0a0c70a67ca551339c6c99673c /editors
parent4448b190fd5abad17e3c075074dea29adb16f0db (diff)
downloadfreebsd-ports-gnome-68713e63a873487d61e13839964717ad31707a77.tar.gz
freebsd-ports-gnome-68713e63a873487d61e13839964717ad31707a77.tar.zst
freebsd-ports-gnome-68713e63a873487d61e13839964717ad31707a77.zip
- Convert ports from dns/, editors/ and emulators/ to new
USES=python Approved by: portmgr (implicit)
Diffstat (limited to 'editors')
-rw-r--r--editors/cooledit/Makefile3
-rw-r--r--editors/gedit-plugins/Makefile2
-rw-r--r--editors/gwrite/Makefile5
-rw-r--r--editors/leo/Makefile3
-rw-r--r--editors/libreoffice/Makefile3
-rw-r--r--editors/openoffice-devel/Makefile3
-rw-r--r--editors/py-room/Makefile5
-rw-r--r--editors/rox-edit/Makefile3
-rw-r--r--editors/scribes/Makefile3
-rw-r--r--editors/spe/Makefile2
-rw-r--r--editors/texworks/Makefile2
11 files changed, 13 insertions, 21 deletions
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 6ee46a7bfd0a..a147212c835c 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= SUNSITE/apps/editors/X/cooledit
MAINTAINER= ports@FreeBSD.org
COMMENT= Suite of utilities, including a GUI editor
-USE_PYTHON= yes
-USES= gettext gmake libtool
+USES= gettext gmake libtool python
GNU_CONFIGURE= yes
USE_XORG= x11 xt
USE_LDCONFIG= yes
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index cc6c38ced8fa..44f51ac45277 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -35,7 +35,7 @@ OPTIONS_DEFINE= PYTHON
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
USE_GNOME+= pygtksourceview
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte \
${PYTHON_SITELIBDIR}/dbus/bus.py:${PORTSDIR}/devel/py-dbus \
diff --git a/editors/gwrite/Makefile b/editors/gwrite/Makefile
index 3582a0f8959b..592b719a977f 100644
--- a/editors/gwrite/Makefile
+++ b/editors/gwrite/Makefile
@@ -22,9 +22,8 @@ RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
${PYTHON_PKGNAMEPREFIX}jswebkit>=0:${PORTSDIR}/www/py-jswebkit \
${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:${PORTSDIR}/www/py-webkitgtk
-USES= desktop-file-utils
+USES= desktop-file-utils python
USE_GNOME= pygtk2
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USE_PYTHON= distutils
.include <bsd.port.mk>
diff --git a/editors/leo/Makefile b/editors/leo/Makefile
index afdc571d85ac..437ddf95ed69 100644
--- a/editors/leo/Makefile
+++ b/editors/leo/Makefile
@@ -26,9 +26,8 @@ PYENCHANT_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}enchant>=0:${PORTSDIR}/textproc/py-
WRKSRC= ${WRKDIR}/Leo-${PORTVERSION}-final
-USES= shebangfix zip
+USES= python shebangfix zip
SHEBANG_FILES= leo/doc/html/fixup.pl leo/scripts/LinixInstall.py
-USE_PYTHON= yes
DESKTOP_ENTRIES="Leo" "Literate Editor with Outlines" \
"${LEO_DIR}/Icons/leoapp32.png" "leo" "" ""
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 5b85c57d7857..b429f44814ea 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -73,10 +73,9 @@ USE_AUTOTOOLS= autoconf aclocal
USE_GL= gl glu
USE_OPENLDAP= yes
USE_PERL5= build
-USE_PYTHON= yes
USE_QT4= # empty but required
USE_XORG= xaw xrandr
-USES= bison compiler:c++11-lang gmake perl5 pkgconfig shared-mime-info tar:xz
+USES= bison compiler:c++11-lang gmake perl5 pkgconfig python shared-mime-info tar:xz
WANT_GNOME= yes
DISTFILES+= ${PORTNAME}-${LOVERSION}${EXTRACT_SUFX}
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 1a3e59aebebe..96a42ead6112 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -26,8 +26,7 @@ USE_XORG= x11 ice xaw xau xext xrender xrandr \
USE_GL= gl glu
USE_GSTREAMER= yes
USE_GCC= yes
-USE_PYTHON= yes
-USES+= bison perl5 gmake pkgconfig tar:bzip2 desktop-file-utils
+USES+= bison perl5 gmake pkgconfig tar:bzip2 desktop-file-utils python
USE_PERL5= build
WITHOUT_CPU_CFLAGS= true
MAKE_JOBS_SAFE= yes
diff --git a/editors/py-room/Makefile b/editors/py-room/Makefile
index 168871d50705..22c71deb9b94 100644
--- a/editors/py-room/Makefile
+++ b/editors/py-room/Makefile
@@ -14,10 +14,9 @@ COMMENT= PyRoom is a clone of WriteRoom and features "distraction-free writing"
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
-USES= gettext
-USE_PYTHON= yes
+USES= gettext python
+USE_PYTHON= distutils
USE_GNOME= pygtk2
-USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= PyRoom
post-patch:
diff --git a/editors/rox-edit/Makefile b/editors/rox-edit/Makefile
index dbbec2661533..34cd1a8bacaa 100644
--- a/editors/rox-edit/Makefile
+++ b/editors/rox-edit/Makefile
@@ -13,8 +13,7 @@ COMMENT= Text editor for the ROX desktop
RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer \
${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:${PORTSDIR}/devel/py-roxlib
-USES= tar:bzip2
-USE_PYTHON= yes
+USES= python tar:bzip2
post-extract:
@${FIND} ${WRKSRC} -name .cvsignore | ${XARGS} ${RM}
diff --git a/editors/scribes/Makefile b/editors/scribes/Makefile
index f51ef32d35f8..4d2b6d649215 100644
--- a/editors/scribes/Makefile
+++ b/editors/scribes/Makefile
@@ -19,10 +19,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:${PORTSDIR}/devel/py-dbus \
${LOCALBASE}/share/xml/docbook/4.5:${PORTSDIR}/textproc/docbook-xml \
yelp:${PORTSDIR}/x11/yelp
-USES= desktop-file-utils gettext gmake shebangfix tar:bzip2
+USES= desktop-file-utils gettext gmake python shebangfix tar:bzip2
SHEBANG_FILES= scribes.in
USE_GNOME= gnomeprefix pygnomeextras pygtksourceview gnomedocutils
-USE_PYTHON= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
diff --git a/editors/spe/Makefile b/editors/spe/Makefile
index beb78f2ad444..02d26ea2c5a7 100644
--- a/editors/spe/Makefile
+++ b/editors/spe/Makefile
@@ -14,7 +14,7 @@ COMMENT= Stani's Python Editor
NO_BUILD= yes
-USE_PYTHON= yes
+USES= python
USE_WX= 3.0+
WX_COMPS= python
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 3d13b1c64a71..3f5b7b2274a9 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -56,7 +56,7 @@ PLIST_FILES+= lib/texworks/libTWLuaPlugin.so
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 3
+USES+= python:3
PLIST_FILES+= lib/texworks/libTWPythonPlugin.so
.endif