aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2012-06-08 10:42:29 +0800
committermaho <maho@FreeBSD.org>2012-06-08 10:42:29 +0800
commit6c11789aa9b0c83ca22214ed5da9ba0092f01b39 (patch)
tree018940ac62a79ac636dbb2356dbdc0beb4f6c3e7 /editors
parentf7565cbc102d8b26db650959e016706b3e5cb79c (diff)
downloadfreebsd-ports-gnome-6c11789aa9b0c83ca22214ed5da9ba0092f01b39.tar.gz
freebsd-ports-gnome-6c11789aa9b0c83ca22214ed5da9ba0092f01b39.tar.zst
freebsd-ports-gnome-6c11789aa9b0c83ca22214ed5da9ba0092f01b39.zip
allow gconf2 and gnomevfs2 to be optional.
PR: 168781 Submitted by: scf@
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile18
-rw-r--r--editors/openoffice-3/Makefile18
2 files changed, 34 insertions, 2 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index a6980f23e756..2601482a56d2 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -24,7 +24,7 @@ LICENSE= AL2
NO_LATEST_LINK= yes
-USE_GNOME= desktopfileutils gtk20 libxslt libidl gconf2 gnomevfs2 glib20
+USE_GNOME= desktopfileutils gtk20 libxslt libidl glib20
USE_XORG= x11 ice xaw xau xext xrender xrandr \
xi xt xcursor xdamage xcomposite xfixes
USE_GL= gl glu
@@ -37,6 +37,10 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
MAKE_JOBS_SAFE= yes
+OPTIONS_DEFINE= GCONF GNOMEVFS
+OPTIONS_DEFAULT=GCONF GNOMEVFS
+GNOMEVFS_DESC= Enable GNOME Virtual File System
+
.include <bsd.port.pre.mk>
USE_JAVA= yes
@@ -44,6 +48,18 @@ JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava openjdk
JAVA_VERSION= 1.5 1.6
+.if !defined(WITHOUT_GCONF)
+USE_GNOME+= gconf2
+.else
+CONFIGURE_ARGS+=--disable-gconf
+.endif
+
+.if !defined(WITHOUT_GNOMEVFS)
+USE_GNOME+= gnomevfs2
+.else
+CONFIGURE_ARGS+=--disable-gnome-vfs
+.endif
+
.include <${FILESDIR}/Makefile.localized>
ONLY_FOR_ARCHS= i386 amd64
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index c2c1b08e2e2c..a092cc73969a 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -23,7 +23,7 @@ LICENSE= AL2
NO_LATEST_LINK= yes
-USE_GNOME= desktopfileutils gtk20 libxslt libidl gconf2 gnomevfs2 glib20
+USE_GNOME= desktopfileutils gtk20 libxslt libidl glib20
USE_XORG= x11 ice xaw xau xext xrender xrandr \
xi xt xcursor xdamage xcomposite xfixes
USE_GL= gl glu
@@ -36,6 +36,10 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
MAKE_JOBS_SAFE= yes
+OPTIONS_DEFINE= GCONF GNOMEVFS
+OPTIONS_DEFAULT=GCONF GNOMEVFS
+GNOMEVFS_DESC= Enable GNOME Virtual File System
+
.include <bsd.port.pre.mk>
USE_JAVA= yes
@@ -43,6 +47,18 @@ JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava openjdk
JAVA_VERSION= 1.5 1.6
+.if !defined(WITHOUT_GCONF)
+USE_GNOME+= gconf2
+.else
+CONFIGURE_ARGS+=--disable-gconf
+.endif
+
+.if !defined(WITHOUT_GNOMEVFS)
+USE_GNOME+= gnomevfs2
+.else
+CONFIGURE_ARGS+=--disable-gnome-vfs
+.endif
+
.include <${FILESDIR}/Makefile.localized>
ONLY_FOR_ARCHS= i386 amd64