aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-05 20:02:48 +0800
committerbapt <bapt@FreeBSD.org>2011-04-05 20:02:48 +0800
commit79dd39f874640171714196a32b635fb3697ea783 (patch)
tree0c491d7bdd6bd2841fe8862cdef4783a5cc5390b /editors
parent73151a52870ceff85fca38fe85d52fbda943e175 (diff)
downloadfreebsd-ports-gnome-79dd39f874640171714196a32b635fb3697ea783.tar.gz
freebsd-ports-gnome-79dd39f874640171714196a32b635fb3697ea783.tar.zst
freebsd-ports-gnome-79dd39f874640171714196a32b635fb3697ea783.zip
This module provides a simple API to calling an external text editor
from within your perl program. WWW: http://search.cpan.org/dist/Proc-InvokeEditor/
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/p5-Proc-InvokeEditor/Makefile25
-rw-r--r--editors/p5-Proc-InvokeEditor/distinfo2
-rw-r--r--editors/p5-Proc-InvokeEditor/pkg-descr4
-rw-r--r--editors/p5-Proc-InvokeEditor/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index abc0cf343a9f..f4b3fb3f9016 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -195,6 +195,7 @@
SUBDIR += openoffice.org-3-devel
SUBDIR += openoffice.org-vcltesttool
SUBDIR += p5-Padre
+ SUBDIR += p5-Proc-InvokeEditor
SUBDIR += p5-Vimana
SUBDIR += paredit-mode.el
SUBDIR += pdfedit
diff --git a/editors/p5-Proc-InvokeEditor/Makefile b/editors/p5-Proc-InvokeEditor/Makefile
new file mode 100644
index 000000000000..0b9e1c53095f
--- /dev/null
+++ b/editors/p5-Proc-InvokeEditor/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Proc-InvokeEditor
+# Date created: 2011-04-05
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Proc-InvokeEditor
+PORTVERSION= 1.05
+CATEGORIES= editors perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MSTEVENS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Perl extension for starting a text editor
+
+LICENSE_COMB= dual
+LICENSE= ART20 GPLv1
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::InvokeEditor.3
+
+.include <bsd.port.mk>
diff --git a/editors/p5-Proc-InvokeEditor/distinfo b/editors/p5-Proc-InvokeEditor/distinfo
new file mode 100644
index 000000000000..5e40c75c93b7
--- /dev/null
+++ b/editors/p5-Proc-InvokeEditor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Proc-InvokeEditor-1.05.tar.gz) = 6933511acb260478154db002f7cdea8d8d748e1a53d87d24530327b4c077a2e5
+SIZE (Proc-InvokeEditor-1.05.tar.gz) = 6267
diff --git a/editors/p5-Proc-InvokeEditor/pkg-descr b/editors/p5-Proc-InvokeEditor/pkg-descr
new file mode 100644
index 000000000000..2344500b2bd2
--- /dev/null
+++ b/editors/p5-Proc-InvokeEditor/pkg-descr
@@ -0,0 +1,4 @@
+This module provides a simple API to calling an external text editor
+from within your perl program.
+
+WWW: http://search.cpan.org/dist/Proc-InvokeEditor/
diff --git a/editors/p5-Proc-InvokeEditor/pkg-plist b/editors/p5-Proc-InvokeEditor/pkg-plist
new file mode 100644
index 000000000000..c52c4d1e615e
--- /dev/null
+++ b/editors/p5-Proc-InvokeEditor/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/InvokeEditor/.packlist
+%%SITE_PERL%%/Proc/InvokeEditor.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/InvokeEditor
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc
+@dirrm %%SITE_PERL%%/Proc