aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2015-01-19 08:57:30 +0800
committertruckman <truckman@FreeBSD.org>2015-01-19 08:57:30 +0800
commit7c299314b8ca966c52f0acabee3acd105b8e8b17 (patch)
tree26c151cd408940c31ecd261f8216f6cb9b135082 /editors
parent713c2f116311e6eee984cc4a15a70173f66d787f (diff)
downloadfreebsd-ports-gnome-7c299314b8ca966c52f0acabee3acd105b8e8b17.tar.gz
freebsd-ports-gnome-7c299314b8ca966c52f0acabee3acd105b8e8b17.tar.zst
freebsd-ports-gnome-7c299314b8ca966c52f0acabee3acd105b8e8b17.zip
The editors/openoffice-4 port currently depends on textproc/saxon-devel and
relies on features that are only present in this version of saxon. The recent update to math/scilab added a dependency to textproc/saxon-he, and it requires features that are only present in this version. Unfortunately saxon-devel and saxon-he conflict because they both want to install /usr/local/share/java/classes/saxon9-xqj.jar, which means that openoffice-4 and scilab can't both be installed on the same machine. Avoid this problem by tweaking openoffice-4 use a private copy of saxon. This requires a new version of the ext_sources tarball. Bump PORTREVISION so that users pick up the updated port. Modernize MASTER_SITES syntax and update MASTER_SITE for unowinreg.dll. Update comment to take de facto mainternship. PR: 193776 Differential Revision: https://reviews.freebsd.org/D1553 Reviewed by: bapt, pfg Approved by: mat (mentor)
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-4/Makefile17
-rw-r--r--editors/openoffice-4/distinfo4
2 files changed, 9 insertions, 12 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index bc455e21f547..1aa991f93062 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,21 +3,22 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors java
-MASTER_SITES= ${MASTER_SITE_APACHE:S@%SUBDIR%@openoffice/${PORTVERSION}/source@} \
- ${MASTER_SITE_LOCAL:S@%SUBDIR%@truckman/openoffice@}:extsrc
+MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
+ http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
+ LOCAL/truckman/openoffice:extsrc
.if defined(LANG_PKGNAME)
PKGNAMEPREFIX= ${LANG_PKGNAME}-
.endif
.if defined(LANG_SUFFIX)
PKGNAMESUFFIX= -${LANG_SUFFIX}
.endif
-DISTFILES= ${OOOSRC} unowinreg.dll ${EXTSRC}:extsrc
+DISTFILES= ${OOOSRC} unowinreg.dll:unoreg ${EXTSRC}:extsrc
EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= office@FreeBSD.org
-#de facto maintainer is maho@FreeBSD.org
+#de facto maintainer is truckman@FreeBSD.org
#Frequent Patch submitters should optionally sign Apache iCLA
COMMENT= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
@@ -39,7 +40,6 @@ BUILD_DEPENDS= \
${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
bash:${PORTSDIR}/shells/bash \
- ${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel \
${JAVALIBDIR}/lucene-core-3.6.2.jar:${PORTSDIR}/textproc/lucene \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
LIB_DEPENDS= \
@@ -64,7 +64,6 @@ RUN_DEPENDS= \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
- ${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel \
${LOCALBASE}/lib/X11/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
AOOVERSION1= 4
@@ -74,7 +73,7 @@ AOOVERSION= ${AOOVERSION1}.${AOOVERSION2}.${AOOVERSION3}
AOOXXX= ${AOOVERSION1}${AOOVERSION2}${AOOVERSION3}
SVNREVISION= 1617669
OOOSRC= apache-openoffice-${AOOVERSION}-r${SVNREVISION}-src${EXTRACT_SUFX}
-EXTSRC= ApacheOpenOffice.ext_sources.${AOOVERSION1}.x.x.20140809.tar.gz
+EXTSRC= ApacheOpenOffice.ext_sources.${AOOVERSION1}.x.x.20140918.tar.gz
OOODIR= openoffice${AOOVERSION1}
AOOSUFFIX= ${PORTVERSION}
@@ -201,8 +200,6 @@ CONFIGURE_ARGS+= \
--with-system-poppler \
--with-system-python \
--with-system-redland \
- --with-system-saxon \
- --with-saxon-jar=${JAVALIBDIR}/saxon9.jar \
--with-system-serf \
--with-system-stdlibs \
--enable-symbols=small \
diff --git a/editors/openoffice-4/distinfo b/editors/openoffice-4/distinfo
index 282f63f151bc..e1c45f26e3d7 100644
--- a/editors/openoffice-4/distinfo
+++ b/editors/openoffice-4/distinfo
@@ -1,6 +1,6 @@
SHA256 (openoffice/apache-openoffice-4.1.1-r1617669-src.tar.bz2) = bb89a6d2324ddfe4c475e5484fde0dea316078f6b8ff4d8a4ebc801d17f3ff9f
SIZE (openoffice/apache-openoffice-4.1.1-r1617669-src.tar.bz2) = 219054455
-SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20140809.tar.gz) = d0b4925cbf8a32b9dfbf8ca708a485e150c85fe131cc60cff9eb8f0d0b5a710d
-SIZE (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20140809.tar.gz) = 94099621
+SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20140918.tar.gz) = c7085dbf597a31ef332585ab57041b7ec8baf29c5f6029a60be7b7c63cfcb166
+SIZE (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20140918.tar.gz) = 97839277
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice/unowinreg.dll) = 6144