aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-08-24 04:18:14 +0800
committermarino <marino@FreeBSD.org>2016-08-24 04:18:14 +0800
commitfe718345bf45d64ec2f64362831e768e2e69c71c (patch)
treebe745c20cbfd619a0efd1d6dfc024d884a27165b /editors
parent7e16713fdba6d69a838550415e57965a60e784e0 (diff)
downloadfreebsd-ports-gnome-fe718345bf45d64ec2f64362831e768e2e69c71c.tar.gz
freebsd-ports-gnome-fe718345bf45d64ec2f64362831e768e2e69c71c.tar.zst
freebsd-ports-gnome-fe718345bf45d64ec2f64362831e768e2e69c71c.zip
editors/mg: document and fix ncurses requirement
Approved by: ncurses blanket
Diffstat (limited to 'editors')
-rw-r--r--editors/mg/Makefile2
-rw-r--r--editors/mg/files/patch-GNUmakefile22
-rw-r--r--editors/mg/files/patch-Makefile11
3 files changed, 35 insertions, 0 deletions
diff --git a/editors/mg/Makefile b/editors/mg/Makefile
index 426388f8a6a6..8860aa4b1c66 100644
--- a/editors/mg/Makefile
+++ b/editors/mg/Makefile
@@ -3,12 +3,14 @@
PORTNAME= mg
PORTVERSION= 20160421
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://homepage.boetes.org/software/mg/
MAINTAINER= darcsis@gmail.com
COMMENT= Small, fast Emacs-like editor
+USES= ncurses
PLIST_FILES= bin/mg man/man1/mg.1.gz
PORTDOCS= README tutorial
diff --git a/editors/mg/files/patch-GNUmakefile b/editors/mg/files/patch-GNUmakefile
new file mode 100644
index 000000000000..8aaf7ab71e43
--- /dev/null
+++ b/editors/mg/files/patch-GNUmakefile
@@ -0,0 +1,22 @@
+--- GNUmakefile.orig 2016-01-18 15:01:49 UTC
++++ GNUmakefile
+@@ -17,16 +17,10 @@ PKG_CONFIG= /usr/bin/pkg-config
+ INSTALL= /usr/bin/install
+ STRIP= /usr/bin/strip
+
+-UNAME:= $(shell uname)
+-ifeq ($(UNAME),FreeBSD)
+- BSD_CPPFLAGS:=
+- BSD_LIBS:= -lutil
+-else
+- BSD_CPPFLAGS:=$(shell $(PKG_CONFIG) --cflags libbsd-overlay)
+- BSD_LIBS:= $(shell $(PKG_CONFIG) --libs libbsd-overlay)
+-endif
++BSD_CPPFLAGS:=
++BSD_LIBS:= -lutil
+
+-CURSES_LIBS= -lcurses
++CURSES_LIBS= -lncurses
+
+ CC?= gcc
+ CFLAGS?= -O2 -pipe
diff --git a/editors/mg/files/patch-Makefile b/editors/mg/files/patch-Makefile
new file mode 100644
index 000000000000..fa86826ccd80
--- /dev/null
+++ b/editors/mg/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-01-07 18:55:54 UTC
++++ Makefile
+@@ -2,7 +2,7 @@
+
+ PROG= mg
+
+-LDADD+= -lcurses -lutil
++LDADD+= -lncurses -lutil
+ DPADD+= ${LIBCURSES} ${LIBUTIL}
+
+ # (Common) compile-time options: