aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2012-12-26 00:28:05 +0800
committerashish <ashish@FreeBSD.org>2012-12-26 00:28:05 +0800
commit02cce63d0ba9e0462b017b0949b51cb2482be2c8 (patch)
tree21ccb49191e671705f60f96d6d08af35e25d4ccc /editors
parent0ebcc2be5691c3c22c1e402eb178b4570c5a0c87 (diff)
downloadfreebsd-ports-gnome-02cce63d0ba9e0462b017b0949b51cb2482be2c8.tar.gz
freebsd-ports-gnome-02cce63d0ba9e0462b017b0949b51cb2482be2c8.tar.zst
freebsd-ports-gnome-02cce63d0ba9e0462b017b0949b51cb2482be2c8.zip
editors/emacs-devel:
- Update to bzr snapshot 111312 - Add OPTION for LTO support - Remove ABI versions from LIB_DEPENDS - Fix configure command-line arguments - Add patches to make sure it compiles with GCC 4.6+ - Add patch for compilation on FreeBSD/arm[1] Mk/bsd.emacs.mk - Update EMACS_VER for editors/emacs-devel Submitted by: kientzle[1]
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs-devel/Makefile34
-rw-r--r--editors/emacs-devel/distinfo4
-rw-r--r--editors/emacs-devel/files/patch-configure.ac28
-rw-r--r--editors/emacs-devel/files/patch-lib_verify.h17
-rw-r--r--editors/emacs-devel/files/patch-src_lisp.h16
-rw-r--r--editors/emacs-devel/files/patch-src_sysdep.c6
-rw-r--r--editors/emacs-devel/pkg-plist4
7 files changed, 63 insertions, 46 deletions
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index 3ae193515638..9b47cda00bd4 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -26,8 +26,8 @@ CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-23.* \
xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]* \
emacs-nox11-[0-9]*
-EMACS_VER= 24.1.50
-EMACS_REV= 109364
+EMACS_VER= 24.3.50
+EMACS_REV= 111312
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_NCURSES= yes
@@ -57,7 +57,7 @@ INFO= ada-mode auth autotype calc ccmode cl dbus dired-x \
LATEST_LINK= emacs-devel
OPTIONS_DEFINE= DBUS GCONF GIF JPEG M17N OTF PNG SOUND SOURCES SVG TIFF SYNC_INPUT SCROLLBARS XFT \
- XIM XML XPM MAGICK GNUTLS GSETTINGS
+ XIM XML XPM MAGICK GNUTLS GSETTINGS LTO
OPTIONS_SINGLE= X11TOOLKIT
@@ -71,6 +71,7 @@ XAW3D_DESC= Athena3D widgets
XIM_DESC= X Input Method Support
M17N_DESC= M17N support for text-shaping
OTF_DESC= Opentype fonts suport
+LTO_DESC= Enable link-time optimization (requires GCC 4.6+)
OPTIONS_SINGLE_X11TOOLKIT= GTK2 GTK3 XAW XAW3D MOTIF
@@ -100,7 +101,7 @@ CONFIGURE_ARGS+= --with-x-toolkit=gtk
USE_GNOME+= gtk30
CONFIGURE_ARGS+= --with-x-toolkit=gtk3
.elif ${PORT_OPTIONS:MXAW3D}
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+= --with-x-toolkit=athena
.elif ${PORT_OPTIONS:MXAW}
USE_XORG= xaw
@@ -119,19 +120,19 @@ CONFIGURE_ARGS+= --without-sync-input
.endif
.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
.else
CONFIGURE_ARGS+= --without-jpeg
.endif
.if ${PORT_OPTIONS:MTIFF}
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
.else
CONFIGURE_ARGS+= --without-tiff
.endif
.if ${PORT_OPTIONS:MGIF}
-LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
+LIB_DEPENDS+= gif:${PORTSDIR}/graphics/giflib
.else
CONFIGURE_ARGS+= --without-gif
.endif
@@ -150,17 +151,17 @@ CONFIGURE_ARGS+= --without-xpm
.if ${PORT_OPTIONS:MXFT}
USE_XORG+= xft
-LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
CONFIGURE_ARGS+= --with-xft
.if ${PORT_OPTIONS:MM17N}
CONFIGURE_ARGS+= --with-m17n-flt
-LIB_DEPENDS+= m17n.4:${PORTSDIR}/devel/m17n-lib
+LIB_DEPENDS+= m17n:${PORTSDIR}/devel/m17n-lib
.else
CONFIGURE_ARGS+= --without-m17n-flt
.endif
.if ${PORT_OPTIONS:MOTF}
-CONFIGURE_ARGS+= --with-otf
-LIB_DEPENDS+= otf.0:${PORTSDIR}/print/libotf
+CONFIGURE_ARGS+= --with-libotf
+LIB_DEPENDS+= otf:${PORTSDIR}/print/libotf
.else
CONFIGURE_ARGS+= --without-libotf
.endif
@@ -171,7 +172,7 @@ IGNORE= m17n support for text-shaping requires Xft. Please run 'make config'
.elif ${PORT_OPTIONS:MOTF}
IGNORE= opentype fonts support requires Xft. Please run 'make config'
.endif
-CONFIGURE_ARGS+= --without-otf --without-m17n-flt
+CONFIGURE_ARGS+= --without-libotf --without-m17n-flt
.endif
.if ${PORT_OPTIONS:MMAGICK}
@@ -210,7 +211,7 @@ CONFIGURE_ARGS+= --without-sound
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
CONFIGURE_ARGS+= --with-dbus
.else
CONFIGURE_ARGS+= --without-dbus
@@ -224,12 +225,17 @@ CONFIGURE_ARGS+= --without-xml2
.endif
.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --with-gnutls
.else
CONFIGURE_ARGS+= --without-gnutls
.endif
+.if ${PORT_OPTIONS:MLTO}
+USE_GCC= 4.6+
+CONFIGURE_ARGS+= --enable-link-time-optimization
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
diff --git a/editors/emacs-devel/distinfo b/editors/emacs-devel/distinfo
index aa2186062ce5..bdb00ef9046b 100644
--- a/editors/emacs-devel/distinfo
+++ b/editors/emacs-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (emacs-24.1.50.109364.tar.xz) = dc24def5dc368a33ac2dbb388bbd9e9f292d71bcf64e6712b72a899b07f138c9
-SIZE (emacs-24.1.50.109364.tar.xz) = 31119924
+SHA256 (emacs-24.3.50.111312.tar.xz) = 1fa8d78640de16c4f14f84ae8baffaf47cf6ec305e4e07ab13e96c823717a757
+SIZE (emacs-24.3.50.111312.tar.xz) = 31610424
diff --git a/editors/emacs-devel/files/patch-configure.ac b/editors/emacs-devel/files/patch-configure.ac
index 38a808a6bffb..c0c4c23f37d1 100644
--- a/editors/emacs-devel/files/patch-configure.ac
+++ b/editors/emacs-devel/files/patch-configure.ac
@@ -3,7 +3,7 @@ $FreeBSD$
--- configure.ac.orig
+++ configure.ac
-@@ -1166,39 +1166,10 @@
+@@ -1240,39 +1240,10 @@
AC_CHECK_LIB(ossaudio, _oss_ioctl, LIBSOUND=-lossaudio, LIBSOUND=)
AC_SUBST(LIBSOUND)
@@ -44,30 +44,12 @@ $FreeBSD$
case "$opsys" in
dnl defined __FreeBSD__ || defined __NetBSD__ || defined __linux__
gnu-linux|freebsd|netbsd)
-@@ -1215,7 +1186,7 @@
+@@ -1289,7 +1260,7 @@
linux/version.h sys/systeminfo.h
- stdio_ext.h fcntl.h coff.h pty.h
+ coff.h pty.h
sys/vlimit.h sys/resource.h
-- sys/utsname.h pwd.h utmp.h dirent.h util.h)
-+ sys/utsname.h pwd.h utmp.h dirent.h util.h libutil.h)
+- sys/utsname.h pwd.h utmp.h util.h)
++ sys/utsname.h pwd.h utmp.h util.h libutil.h)
AC_MSG_CHECKING(if personality LINUX32 can be set)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/personality.h>]], [[personality (PER_LINUX32)]])],
-@@ -3378,7 +3349,7 @@
- AC_DEFINE(PTY_TTY_NAME_SPRINTF, [] )
- ;;
-
-- darwin )
-+ darwin | freebsd )
- AC_DEFINE(PTY_ITERATION, [int i; for (i = 0; i < 1; i++)] )
- dnl Not used, because PTY_ITERATION is defined.
- AC_DEFINE(FIRST_PTY_LETTER, ['p'])
-@@ -3390,7 +3361,7 @@
- AC_DEFINE(PTY_TTY_NAME_SPRINTF, [] )
- ;;
-
-- gnu | freebsd | netbsd | openbsd )
-+ gnu | netbsd | openbsd )
- AC_DEFINE(FIRST_PTY_LETTER, ['p'])
- ;;
-
diff --git a/editors/emacs-devel/files/patch-lib_verify.h b/editors/emacs-devel/files/patch-lib_verify.h
new file mode 100644
index 000000000000..14bffe4b6c87
--- /dev/null
+++ b/editors/emacs-devel/files/patch-lib_verify.h
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- lib/verify.h.orig
++++ lib/verify.h
+@@ -21,6 +21,11 @@
+ # define _GL_VERIFY_H
+
+
++// undefine the _Static_assert definition present in <sys/cdefs.h>
++#ifdef __FreeBSD__
++#undef _Static_assert
++#endif
++
+ /* Define _GL_HAVE__STATIC_ASSERT to 1 if _Static_assert works as per C11.
+ This is supported by GCC 4.6.0 and later, in C mode, and its use
+ here generates easier-to-read diagnostics when verify (R) fails.
diff --git a/editors/emacs-devel/files/patch-src_lisp.h b/editors/emacs-devel/files/patch-src_lisp.h
new file mode 100644
index 000000000000..1ac2caff4beb
--- /dev/null
+++ b/editors/emacs-devel/files/patch-src_lisp.h
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- src/lisp.h.orig
++++ src/lisp.h
+@@ -21,6 +21,10 @@
+ #define EMACS_LISP_H
+
+ #include <setjmp.h>
++#ifdef __FreeBSD__
++#undef _Alignof
++#undef _Alignas
++#endif
+ #include <stdalign.h>
+ #include <stdarg.h>
+ #include <stdbool.h>
diff --git a/editors/emacs-devel/files/patch-src_sysdep.c b/editors/emacs-devel/files/patch-src_sysdep.c
index a5c26fd702f7..7b03201d37e5 100644
--- a/editors/emacs-devel/files/patch-src_sysdep.c
+++ b/editors/emacs-devel/files/patch-src_sysdep.c
@@ -9,12 +9,12 @@ $FreeBSD$
+#ifdef __FreeBSD__
+#include <sys/sysctl.h>
-+/* machine/frame.h in Sparc has 'struct frame' which conflicts with Emacs' 'struct frame', so rename it */
-+#ifdef __sparc__
++/* machine/frame.h in Sparc/ARM has 'struct frame' which conflicts with Emacs' 'struct frame', so rename it */
++#if defined(__sparc__) || defined(__arm__)
+#define frame freebsd_sparc_frame
+#endif
+#include <sys/user.h>
-+#ifdef __sparc__
++#if defined(__sparc__) || defined(__arm__)
+#undef frame
+#endif
+#include <sys/resource.h>
diff --git a/editors/emacs-devel/pkg-plist b/editors/emacs-devel/pkg-plist
index d1cb27e36fce..9afefdf00a1b 100644
--- a/editors/emacs-devel/pkg-plist
+++ b/editors/emacs-devel/pkg-plist
@@ -11,13 +11,9 @@ share/applications/emacs.desktop
%%DATADIR%%/site-lisp/subdirs.el
share/icons/hicolor/128x128/apps/emacs.png
share/icons/hicolor/16x16/apps/emacs.png
-share/icons/hicolor/16x16/apps/emacs22.png
share/icons/hicolor/24x24/apps/emacs.png
-share/icons/hicolor/24x24/apps/emacs22.png
share/icons/hicolor/32x32/apps/emacs.png
-share/icons/hicolor/32x32/apps/emacs22.png
share/icons/hicolor/48x48/apps/emacs.png
-share/icons/hicolor/48x48/apps/emacs22.png
share/icons/hicolor/scalable/apps/emacs.svg
share/icons/hicolor/scalable/mimetypes/emacs-document.svg
@dirrmtry %%DATADIR%%/%%EMACS_VER%%/site-lisp