aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-28 18:49:21 +0800
committergarga <garga@FreeBSD.org>2005-10-28 18:49:21 +0800
commit0ae08caf44c535a8a6ca754425b3ba8beeaa4c45 (patch)
tree9247c4154384375d2e17767d525cf44653704c21 /editors
parentda91b14f643b7b7fb1e3b303e6c4c0fc32d7a6b3 (diff)
downloadfreebsd-ports-gnome-0ae08caf44c535a8a6ca754425b3ba8beeaa4c45.tar.gz
freebsd-ports-gnome-0ae08caf44c535a8a6ca754425b3ba8beeaa4c45.tar.zst
freebsd-ports-gnome-0ae08caf44c535a8a6ca754425b3ba8beeaa4c45.zip
- Respect CFLAGS/LDFLAGS
- Add an option to use libslang2
Diffstat (limited to 'editors')
-rw-r--r--editors/jed-devel/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/editors/jed-devel/Makefile b/editors/jed-devel/Makefile
index fd0428e24fc2..842c67ff1ed4 100644
--- a/editors/jed-devel/Makefile
+++ b/editors/jed-devel/Makefile
@@ -15,19 +15,17 @@ DISTNAME= ${PORTNAME}-B${DISTVERSION}
MAINTAINER= garga@FreeBSD.org
COMMENT= A SLang-based text editor. Development version
-LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
-
CONFLICTS= jed-[0-9]*
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-OPTIONS= X11 "Build xjed (depends of X11)" on
+
+OPTIONS= X11 "Build xjed (depends of X11)" on \
+ SLANG2 "Build using libslang-2.x" off
DIST_SUBDIR= jed
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= JED_ROOT=${PREFIX}/lib/jed \
- CFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV+= JED_ROOT=${PREFIX}/lib/jed
MAKE_ENV+= DEST_INFO_DIR=${PREFIX}/${INFO_PATH} \
DEST_DOC_DIR=${DOCSDIR}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -45,6 +43,12 @@ INFO= jed
.include <bsd.port.pre.mk>
+.if defined(WITH_SLANG2)
+LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
+.else
+LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
+.endif
+
.if defined(WITHOUT_X11)
PLIST_SUB+= XJED="@comment "
.else