aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commit194069571a0e4c7bad7bce0f33a042d707e9e171 (patch)
treec3c8a6312bab5325147ea9ea2ad87f0cc44a5fec /editors
parent232533f87b435da7ed2bac7daeae3e90680d9e1d (diff)
downloadfreebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.gz
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.zst
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'editors')
-rw-r--r--editors/gedit/Makefile9
-rw-r--r--editors/gedit/distinfo4
-rw-r--r--editors/gedit/pkg-plist1
-rw-r--r--editors/gnome2-office/Makefile16
-rw-r--r--editors/gnome2-office/pkg-plist1
5 files changed, 15 insertions, 16 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 751484043968..af6ac9b792f6 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/editors/gedit/Makefile,v 1.12 2005/10/03 15:49:09 ahze Exp $
#
PORTNAME= gedit
-PORTVERSION= 2.10.5
+PORTVERSION= 2.12.1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -22,12 +23,12 @@ USE_X_PREFIX= yes
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomeprefix gnomehack intlhack \
libgnomeprintui libgnomeui eel2 gtksourceview desktopfileutils
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB= VERSION="2.10"
+PLIST_SUB= VERSION="2.12"
MAN1= gedit.1
GCONF_SCHEMAS= gedit.schemas
diff --git a/editors/gedit/distinfo b/editors/gedit/distinfo
index 828e7fbc2dd6..1b22cc699a1b 100644
--- a/editors/gedit/distinfo
+++ b/editors/gedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gedit-2.10.5.tar.bz2) = 790f804d4754c382630ba70d8d264e18
-SIZE (gnome2/gedit-2.10.5.tar.bz2) = 2099478
+MD5 (gnome2/gedit-2.12.1.tar.bz2) = 13f376c6c63b0fbd25ba9b6c7d6fb97c
+SIZE (gnome2/gedit-2.12.1.tar.bz2) = 2018712
diff --git a/editors/gedit/pkg-plist b/editors/gedit/pkg-plist
index d256d789cb6c..ee3dd784d391 100644
--- a/editors/gedit/pkg-plist
+++ b/editors/gedit/pkg-plist
@@ -178,6 +178,7 @@ share/locale/it/LC_MESSAGES/gedit.mo
share/locale/ja/LC_MESSAGES/gedit.mo
share/locale/kn/LC_MESSAGES/gedit.mo
share/locale/ko/LC_MESSAGES/gedit.mo
+share/locale/ku/LC_MESSAGES/gedit.mo
share/locale/lt/LC_MESSAGES/gedit.mo
share/locale/lv/LC_MESSAGES/gedit.mo
share/locale/mi/LC_MESSAGES/gedit.mo
diff --git a/editors/gnome2-office/Makefile b/editors/gnome2-office/Makefile
index 55c2a61c3681..97743d7cda2f 100644
--- a/editors/gnome2-office/Makefile
+++ b/editors/gnome2-office/Makefile
@@ -3,16 +3,13 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/editors/gnome2-office/Makefile,v 1.39 2005/08/11 02:55:29 marcus Exp $
#
-PORTNAME= gnome2-office
-PORTVERSION= 2.10.2
+PORTREVISION= 0
CATEGORIES= editors gnome
-MASTER_SITES= # empty
-DISTFILES= # empty
-EXTRACT_ONLY= # empty
+PKGNAMESUFFIX= -office
-MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2 office applications
RUN_DEPENDS= gnumeric:${PORTSDIR}/math/gnumeric \
@@ -22,8 +19,9 @@ RUN_DEPENDS= gnumeric:${PORTSDIR}/math/gnumeric \
abiword:${PORTSDIR}/editors/abiword \
mergeant:${PORTSDIR}/databases/mergeant
-NO_BUILD= yes
+MASTERDIR= ${.CURDIR}/../../x11/gnome2
+GNOME_SLAVE= yes
-do-install: # empty
+DESCR= ${.CURDIR}/pkg-descr
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/editors/gnome2-office/pkg-plist b/editors/gnome2-office/pkg-plist
deleted file mode 100644
index 549a621fec0c..000000000000
--- a/editors/gnome2-office/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-@comment this plist intentionally left empty