aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
committertcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
commit19b60f6341c1340c532b32ab42000f8ef533e37c (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /editors
parentcc28d78986356b14cfa92360db6e23f595431254 (diff)
downloadfreebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.gz
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.zst
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Diffstat (limited to 'editors')
-rw-r--r--editors/codelite/Makefile2
-rw-r--r--editors/jucipp/Makefile2
-rw-r--r--editors/kate-plugin-pate/Makefile2
-rw-r--r--editors/neovim/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index 91441ab118c9..413b9a02cf53 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -19,7 +19,7 @@ BROKEN_armv6= fails to configure: has leading or trailing whitespace. This is
USE_GITHUB= yes
GH_ACCOUNT= eranif
-USES= cmake:outsource compiler:c++11-lib dos2unix execinfo gettext \
+USES= cmake:outsource,noninja compiler:c++11-lib dos2unix execinfo gettext \
pathfix shebangfix sqlite
USE_GNOME+= cairo gtk20
DOS2UNIX_GLOB= *.cpp *.txt
diff --git a/editors/jucipp/Makefile b/editors/jucipp/Makefile
index 6012cfef971a..11bd95d6af64 100644
--- a/editors/jucipp/Makefile
+++ b/editors/jucipp/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libaspell.so:textproc/aspell \
libclang.so:devel/llvm40
USE_GNOME= gdkpixbuf2 gtkmm30 gtksourceviewmm3
-USES= cmake:outsource desktop-file-utils ninja pkgconfig
+USES= cmake:outsource desktop-file-utils pkgconfig
INSTALLS_ICONS= yes
USE_GITHUB= yes
diff --git a/editors/kate-plugin-pate/Makefile b/editors/kate-plugin-pate/Makefile
index 3f270846cfa6..e3d78b3923a0 100644
--- a/editors/kate-plugin-pate/Makefile
+++ b/editors/kate-plugin-pate/Makefile
@@ -9,7 +9,7 @@ DISTNAME= kate-${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Support for Python plugins in Kate
-USES= cmake:outsource kde:4 python tar:xz
+USES= cmake:outsource,noninja kde:4 python tar:xz
USE_KDE= kdelibs automoc4 kate \
pykde4_build pykde4_run
USE_QT4= gui webkit \
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 65cf89152725..62aa61841277 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libunibilium.so:devel/unibilium \
libuv.so:devel/libuv \
libmsgpackc.so:devel/msgpack
-USES= cmake:outsource gettext iconv ninja lua:build pathfix pkgconfig
+USES= cmake:outsource gettext iconv lua:build pathfix pkgconfig
USE_GITHUB= yes
GH_TUPLE= libmpack:libmpack:1.0.5:libmpack \
libmpack:libmpack-lua:1.0.6:libmpack_lua