aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-09-29 19:05:40 +0800
committermaho <maho@FreeBSD.org>2006-09-29 19:05:40 +0800
commit2d4af337abb1b093113f699e748f0176ed39ec0d (patch)
tree984cd241ed952501009e707cb96f67c14e08d45f /editors
parent48ab00cde83057ee4c9b67f86d7648f26ba888a7 (diff)
downloadfreebsd-ports-gnome-2d4af337abb1b093113f699e748f0176ed39ec0d.tar.gz
freebsd-ports-gnome-2d4af337abb1b093113f699e748f0176ed39ec0d.tar.zst
freebsd-ports-gnome-2d4af337abb1b093113f699e748f0176ed39ec0d.zip
Build fix for when ooo-build and openoffice.org-2.0
ports expect different source tarball. Generally both port expect the same tarball, but for RCs, they can be different. This fix is bit more flexible than hardcoding.
Diffstat (limited to 'editors')
-rw-r--r--editors/ooo-build/Makefile1
-rw-r--r--editors/openoffice-3/Makefile8
-rw-r--r--editors/openoffice.org-2-RC/Makefile8
-rw-r--r--editors/openoffice.org-2.0/Makefile8
-rw-r--r--editors/openoffice.org-2/Makefile8
-rw-r--r--editors/openoffice.org-3-RC/Makefile8
-rw-r--r--editors/openoffice.org-3/Makefile8
7 files changed, 19 insertions, 30 deletions
diff --git a/editors/ooo-build/Makefile b/editors/ooo-build/Makefile
index 9942f3dcd626..d7d63ccdd534 100644
--- a/editors/ooo-build/Makefile
+++ b/editors/ooo-build/Makefile
@@ -32,6 +32,7 @@ OOO_PATCHDIR=src680
.else
OOOBUILD_VERSION=2.0.4.m4
OOOBUILD_TAG=ood680-m4
+OOOSRC= OOo_2.0.4rc2_src.tar.gz
#OOOBUILD= ooo-build-${OOOBUILD_VERSION}
OOOBUILD= ooo-build-${OOOBUILD_TAG}
OOOBUILD_SOURCE=${OOOBUILD}.tar.gz
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index d223edca3b50..a9486ebf21f6 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -16,17 +16,14 @@ MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOV
${MASTER_SITE_MOZILLA:S/$/:mozsrc/} \
http://tools.openoffice.org/unowinreg_prebuild/680/:unowinreg
MASTER_SITE_SUBDIR+= mozilla/releases/mozilla${MOZILLA_VERSION}/source/:mozsrc
-#DISTFILES+= OOo_${OOOVERSION}_src.tar.gz
-DISTFILES+= OOo_2.0.4rc3_src.tar.gz
-DISTFILES+= unowinreg.dll:unowinreg
+DISTFILES+= ${OOOSRC} unowinreg.dll:unowinreg
.if defined(WITH_GPC)
DISTFILES+= gpc231.tar.Z:gpc
.endif
.if defined(WITH_GNUGCJ)
DISTFILES+= ${ANT_DISTFILE}:antbin
.endif
-#EXTRACT_ONLY= OOo_${OOOVERSION}_src.tar.gz
-EXTRACT_ONLY= OOo_2.0.4rc3_src.tar.gz
+EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= openoffice@FreeBSD.org
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
@@ -76,6 +73,7 @@ IGNORE= install lang/perl5.8 then try again
CODELINE= 680
RELEASE_NR= 2.0
OOOTAG?= OOD680_m5
+OOOSRC?= OOo_2.0.4rc3_src.tar.gz
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
EXECBASE?= openoffice.org-${OOOVERSION}
DIST_SUBDIR= openoffice.org2.0
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index d223edca3b50..a9486ebf21f6 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -16,17 +16,14 @@ MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOV
${MASTER_SITE_MOZILLA:S/$/:mozsrc/} \
http://tools.openoffice.org/unowinreg_prebuild/680/:unowinreg
MASTER_SITE_SUBDIR+= mozilla/releases/mozilla${MOZILLA_VERSION}/source/:mozsrc
-#DISTFILES+= OOo_${OOOVERSION}_src.tar.gz
-DISTFILES+= OOo_2.0.4rc3_src.tar.gz
-DISTFILES+= unowinreg.dll:unowinreg
+DISTFILES+= ${OOOSRC} unowinreg.dll:unowinreg
.if defined(WITH_GPC)
DISTFILES+= gpc231.tar.Z:gpc
.endif
.if defined(WITH_GNUGCJ)
DISTFILES+= ${ANT_DISTFILE}:antbin
.endif
-#EXTRACT_ONLY= OOo_${OOOVERSION}_src.tar.gz
-EXTRACT_ONLY= OOo_2.0.4rc3_src.tar.gz
+EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= openoffice@FreeBSD.org
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
@@ -76,6 +73,7 @@ IGNORE= install lang/perl5.8 then try again
CODELINE= 680
RELEASE_NR= 2.0
OOOTAG?= OOD680_m5
+OOOSRC?= OOo_2.0.4rc3_src.tar.gz
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
EXECBASE?= openoffice.org-${OOOVERSION}
DIST_SUBDIR= openoffice.org2.0
diff --git a/editors/openoffice.org-2.0/Makefile b/editors/openoffice.org-2.0/Makefile
index d223edca3b50..a9486ebf21f6 100644
--- a/editors/openoffice.org-2.0/Makefile
+++ b/editors/openoffice.org-2.0/Makefile
@@ -16,17 +16,14 @@ MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOV
${MASTER_SITE_MOZILLA:S/$/:mozsrc/} \
http://tools.openoffice.org/unowinreg_prebuild/680/:unowinreg
MASTER_SITE_SUBDIR+= mozilla/releases/mozilla${MOZILLA_VERSION}/source/:mozsrc
-#DISTFILES+= OOo_${OOOVERSION}_src.tar.gz
-DISTFILES+= OOo_2.0.4rc3_src.tar.gz
-DISTFILES+= unowinreg.dll:unowinreg
+DISTFILES+= ${OOOSRC} unowinreg.dll:unowinreg
.if defined(WITH_GPC)
DISTFILES+= gpc231.tar.Z:gpc
.endif
.if defined(WITH_GNUGCJ)
DISTFILES+= ${ANT_DISTFILE}:antbin
.endif
-#EXTRACT_ONLY= OOo_${OOOVERSION}_src.tar.gz
-EXTRACT_ONLY= OOo_2.0.4rc3_src.tar.gz
+EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= openoffice@FreeBSD.org
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
@@ -76,6 +73,7 @@ IGNORE= install lang/perl5.8 then try again
CODELINE= 680
RELEASE_NR= 2.0
OOOTAG?= OOD680_m5
+OOOSRC?= OOo_2.0.4rc3_src.tar.gz
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
EXECBASE?= openoffice.org-${OOOVERSION}
DIST_SUBDIR= openoffice.org2.0
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index d223edca3b50..a9486ebf21f6 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -16,17 +16,14 @@ MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOV
${MASTER_SITE_MOZILLA:S/$/:mozsrc/} \
http://tools.openoffice.org/unowinreg_prebuild/680/:unowinreg
MASTER_SITE_SUBDIR+= mozilla/releases/mozilla${MOZILLA_VERSION}/source/:mozsrc
-#DISTFILES+= OOo_${OOOVERSION}_src.tar.gz
-DISTFILES+= OOo_2.0.4rc3_src.tar.gz
-DISTFILES+= unowinreg.dll:unowinreg
+DISTFILES+= ${OOOSRC} unowinreg.dll:unowinreg
.if defined(WITH_GPC)
DISTFILES+= gpc231.tar.Z:gpc
.endif
.if defined(WITH_GNUGCJ)
DISTFILES+= ${ANT_DISTFILE}:antbin
.endif
-#EXTRACT_ONLY= OOo_${OOOVERSION}_src.tar.gz
-EXTRACT_ONLY= OOo_2.0.4rc3_src.tar.gz
+EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= openoffice@FreeBSD.org
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
@@ -76,6 +73,7 @@ IGNORE= install lang/perl5.8 then try again
CODELINE= 680
RELEASE_NR= 2.0
OOOTAG?= OOD680_m5
+OOOSRC?= OOo_2.0.4rc3_src.tar.gz
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
EXECBASE?= openoffice.org-${OOOVERSION}
DIST_SUBDIR= openoffice.org2.0
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index d223edca3b50..a9486ebf21f6 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -16,17 +16,14 @@ MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOV
${MASTER_SITE_MOZILLA:S/$/:mozsrc/} \
http://tools.openoffice.org/unowinreg_prebuild/680/:unowinreg
MASTER_SITE_SUBDIR+= mozilla/releases/mozilla${MOZILLA_VERSION}/source/:mozsrc
-#DISTFILES+= OOo_${OOOVERSION}_src.tar.gz
-DISTFILES+= OOo_2.0.4rc3_src.tar.gz
-DISTFILES+= unowinreg.dll:unowinreg
+DISTFILES+= ${OOOSRC} unowinreg.dll:unowinreg
.if defined(WITH_GPC)
DISTFILES+= gpc231.tar.Z:gpc
.endif
.if defined(WITH_GNUGCJ)
DISTFILES+= ${ANT_DISTFILE}:antbin
.endif
-#EXTRACT_ONLY= OOo_${OOOVERSION}_src.tar.gz
-EXTRACT_ONLY= OOo_2.0.4rc3_src.tar.gz
+EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= openoffice@FreeBSD.org
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
@@ -76,6 +73,7 @@ IGNORE= install lang/perl5.8 then try again
CODELINE= 680
RELEASE_NR= 2.0
OOOTAG?= OOD680_m5
+OOOSRC?= OOo_2.0.4rc3_src.tar.gz
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
EXECBASE?= openoffice.org-${OOOVERSION}
DIST_SUBDIR= openoffice.org2.0
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index d223edca3b50..a9486ebf21f6 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -16,17 +16,14 @@ MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOV
${MASTER_SITE_MOZILLA:S/$/:mozsrc/} \
http://tools.openoffice.org/unowinreg_prebuild/680/:unowinreg
MASTER_SITE_SUBDIR+= mozilla/releases/mozilla${MOZILLA_VERSION}/source/:mozsrc
-#DISTFILES+= OOo_${OOOVERSION}_src.tar.gz
-DISTFILES+= OOo_2.0.4rc3_src.tar.gz
-DISTFILES+= unowinreg.dll:unowinreg
+DISTFILES+= ${OOOSRC} unowinreg.dll:unowinreg
.if defined(WITH_GPC)
DISTFILES+= gpc231.tar.Z:gpc
.endif
.if defined(WITH_GNUGCJ)
DISTFILES+= ${ANT_DISTFILE}:antbin
.endif
-#EXTRACT_ONLY= OOo_${OOOVERSION}_src.tar.gz
-EXTRACT_ONLY= OOo_2.0.4rc3_src.tar.gz
+EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= openoffice@FreeBSD.org
COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
@@ -76,6 +73,7 @@ IGNORE= install lang/perl5.8 then try again
CODELINE= 680
RELEASE_NR= 2.0
OOOTAG?= OOD680_m5
+OOOSRC?= OOo_2.0.4rc3_src.tar.gz
INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
EXECBASE?= openoffice.org-${OOOVERSION}
DIST_SUBDIR= openoffice.org2.0