aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2004-04-30 22:01:50 +0800
committerclive <clive@FreeBSD.org>2004-04-30 22:01:50 +0800
commit44cd70dfab2ef7e08fad2f6b6d152f31da9b79a6 (patch)
treead491cbb6e2a309accc5ab2da6841f30b874d1ca /editors
parent1fef57de37794a65b532b6a4e484f07bc053e55a (diff)
downloadfreebsd-ports-gnome-44cd70dfab2ef7e08fad2f6b6d152f31da9b79a6.tar.gz
freebsd-ports-gnome-44cd70dfab2ef7e08fad2f6b6d152f31da9b79a6.tar.zst
freebsd-ports-gnome-44cd70dfab2ef7e08fad2f6b6d152f31da9b79a6.zip
Previous commit is wrong. The proper way to do it right is by adding
${PKGNAMEPREFIX} prefix before LATEST_LINK of the master port. Obtained from: eik Reminded (again) by: kris
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs20/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/editors/emacs20/Makefile b/editors/emacs20/Makefile
index c209cb2e4b15..0088fd6fcc08 100644
--- a/editors/emacs20/Makefile
+++ b/editors/emacs20/Makefile
@@ -24,7 +24,7 @@ ONLY_FOR_ARCHS= i386 alpha
USE_AUTOCONF_VER=213
USE_GMAKE= yes
EMACS_VER= 20.7
-LATEST_LINK?= emacs20
+LATEST_LINK?= ${PKGNAMEPREFIX}emacs20
CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
.if defined(WITHOUT_X11)
CONFIGURE_ARGS= --with-x=no --with-pop
@@ -34,8 +34,6 @@ USE_XLIB= yes
.endif
CONFIGURE_ARGS+= --with-line-space
-NO_LATEST_LINK= yes
-
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
MAN1= emacs.1 etags.1 ctags.1
PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${CONFIGURE_TARGET}