aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-08-26 05:14:00 +0800
committermbr <mbr@FreeBSD.org>2002-08-26 05:14:00 +0800
commit45df4ba8defd167135a060f2594efc111f93f2b7 (patch)
tree78c42795c7aa46099970bb4059cd0e09abe064e6 /editors
parent0e44fe42c6fac45d4f9602e3c9dfa06c1e077caa (diff)
downloadfreebsd-ports-gnome-45df4ba8defd167135a060f2594efc111f93f2b7.tar.gz
freebsd-ports-gnome-45df4ba8defd167135a060f2594efc111f93f2b7.tar.zst
freebsd-ports-gnome-45df4ba8defd167135a060f2594efc111f93f2b7.zip
Work around yet another stupid bug in bsd.port.mk. WRKDIR is defined in the
post section, so any exists() will fail. I still don't understand why CDROM and WRKDIR and such paths need to be defined in the post section. Use build command instead of dmake. This is the common way to build also subprojects of OO.org
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.0/Makefile15
-rw-r--r--editors/openoffice.org-1.0/Makefile15
-rw-r--r--editors/openoffice/Makefile15
3 files changed, 24 insertions, 21 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index 3675db769315..acb0ee2fea70 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -112,18 +112,19 @@ JAVAVM= ${JDK13DIR}/bin/java
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
-WRKSRC= ${WRKDIR}/oo_1.0.1_src/config_office
+WRKDIR= ${WRKDIRPREFIX}${.CURDIR}/work
+WRKSRC= ${WRKDIR}/oo_1.0.1_src/config_office
LD_PATH1= ${WRKSRC}/../vos/unxfbsd.pro/lib/:${WRKSRC}/../ucbhelper/unxfbsd.pro/lib/
LD_PATH= ${LD_PATH1}:${WRKSRC}/../solver/641/unxfbsd.pro/lib/
.if defined(WITH_DEBUG)
CFLAGS+= -g
.if ${WITH_DEBUG} == 2
-DMAKE= dmake debug="true"
+BUILD= build debug="true"
.else
-DMAKE= dmake
+BUILD= build
.endif
.else
-DMAKE= dmake strip="true"
+BUILD= build strip="true"
.endif
.if !defined(DISPLAY)
@@ -389,16 +390,16 @@ do-build:
.endif
.if !defined(DISPLAY)
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAYHACK} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${BUILD}'
@${CAT} ${WRKDIR}/.Xvfb.pid | xargs kill
@${RM} -f ${WRKDIR}/.Xvfb.pid
.else
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAY} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${BUILD}'
.endif
.if defined(LANG_PKGNAME)
@cd ${WRKSRC}/.. && PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && cd instsetoo/util && ${DMAKE} LANGEXT=${LANGEXT}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && cd instsetoo/util && ${BUILD} LANGEXT=${LANGEXT}'
.endif
pre-install:
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 3675db769315..acb0ee2fea70 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -112,18 +112,19 @@ JAVAVM= ${JDK13DIR}/bin/java
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
-WRKSRC= ${WRKDIR}/oo_1.0.1_src/config_office
+WRKDIR= ${WRKDIRPREFIX}${.CURDIR}/work
+WRKSRC= ${WRKDIR}/oo_1.0.1_src/config_office
LD_PATH1= ${WRKSRC}/../vos/unxfbsd.pro/lib/:${WRKSRC}/../ucbhelper/unxfbsd.pro/lib/
LD_PATH= ${LD_PATH1}:${WRKSRC}/../solver/641/unxfbsd.pro/lib/
.if defined(WITH_DEBUG)
CFLAGS+= -g
.if ${WITH_DEBUG} == 2
-DMAKE= dmake debug="true"
+BUILD= build debug="true"
.else
-DMAKE= dmake
+BUILD= build
.endif
.else
-DMAKE= dmake strip="true"
+BUILD= build strip="true"
.endif
.if !defined(DISPLAY)
@@ -389,16 +390,16 @@ do-build:
.endif
.if !defined(DISPLAY)
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAYHACK} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${BUILD}'
@${CAT} ${WRKDIR}/.Xvfb.pid | xargs kill
@${RM} -f ${WRKDIR}/.Xvfb.pid
.else
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAY} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${BUILD}'
.endif
.if defined(LANG_PKGNAME)
@cd ${WRKSRC}/.. && PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && cd instsetoo/util && ${DMAKE} LANGEXT=${LANGEXT}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && cd instsetoo/util && ${BUILD} LANGEXT=${LANGEXT}'
.endif
pre-install:
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index 3675db769315..acb0ee2fea70 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -112,18 +112,19 @@ JAVAVM= ${JDK13DIR}/bin/java
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
-WRKSRC= ${WRKDIR}/oo_1.0.1_src/config_office
+WRKDIR= ${WRKDIRPREFIX}${.CURDIR}/work
+WRKSRC= ${WRKDIR}/oo_1.0.1_src/config_office
LD_PATH1= ${WRKSRC}/../vos/unxfbsd.pro/lib/:${WRKSRC}/../ucbhelper/unxfbsd.pro/lib/
LD_PATH= ${LD_PATH1}:${WRKSRC}/../solver/641/unxfbsd.pro/lib/
.if defined(WITH_DEBUG)
CFLAGS+= -g
.if ${WITH_DEBUG} == 2
-DMAKE= dmake debug="true"
+BUILD= build debug="true"
.else
-DMAKE= dmake
+BUILD= build
.endif
.else
-DMAKE= dmake strip="true"
+BUILD= build strip="true"
.endif
.if !defined(DISPLAY)
@@ -389,16 +390,16 @@ do-build:
.endif
.if !defined(DISPLAY)
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAYHACK} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${BUILD}'
@${CAT} ${WRKDIR}/.Xvfb.pid | xargs kill
@${RM} -f ${WRKDIR}/.Xvfb.pid
.else
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAY} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${BUILD}'
.endif
.if defined(LANG_PKGNAME)
@cd ${WRKSRC}/.. && PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
- tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && cd instsetoo/util && ${DMAKE} LANGEXT=${LANGEXT}'
+ tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && cd instsetoo/util && ${BUILD} LANGEXT=${LANGEXT}'
.endif
pre-install: