aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2018-02-01 15:17:13 +0800
committeracm <acm@FreeBSD.org>2018-02-01 15:17:13 +0800
commit577473c712310464ef62223b60c5f8ef7e373013 (patch)
tree68d869a05af4c46afc7cf1b12ae34be042aa0003 /editors
parenta919706c63f06c9461dc101a26a9bbf8a8c57124 (diff)
downloadfreebsd-ports-gnome-577473c712310464ef62223b60c5f8ef7e373013.tar.gz
freebsd-ports-gnome-577473c712310464ef62223b60c5f8ef7e373013.tar.zst
freebsd-ports-gnome-577473c712310464ef62223b60c5f8ef7e373013.zip
- New port: editors/lazarus-lcl-qt5
Lazarus components library - QT5 backend
Diffstat (limited to 'editors')
-rw-r--r--editors/lazarus-lcl-qt5/Makefile17
-rw-r--r--editors/lazarus-lcl-qt5/files/patch-interfaces_qt_qt45.pas11
2 files changed, 28 insertions, 0 deletions
diff --git a/editors/lazarus-lcl-qt5/Makefile b/editors/lazarus-lcl-qt5/Makefile
new file mode 100644
index 000000000000..9891096a8f5d
--- /dev/null
+++ b/editors/lazarus-lcl-qt5/Makefile
@@ -0,0 +1,17 @@
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -lcl-qt5
+
+COMMENT= Lazarus components library - QT5 backend
+
+BUILD_DEPENDS= ${LCL_UNITS_DIR}/alllclunits.ppu:editors/lazarus-lcl-units
+
+USE_FPC= fcl-base fcl-db fcl-image fcl-registry fcl-res \
+ fcl-xml pasjpeg x11
+
+LCL_INTERFACE= qt5
+
+MASTERDIR= ${.CURDIR}/../../editors/lazarus
+
+.include "${MASTERDIR}/Makefile"
diff --git a/editors/lazarus-lcl-qt5/files/patch-interfaces_qt_qt45.pas b/editors/lazarus-lcl-qt5/files/patch-interfaces_qt_qt45.pas
new file mode 100644
index 000000000000..0f1fdf1fc625
--- /dev/null
+++ b/editors/lazarus-lcl-qt5/files/patch-interfaces_qt_qt45.pas
@@ -0,0 +1,11 @@
+--- interfaces/qt/qt45.pas.orig 2014-02-05 12:08:29 UTC
++++ interfaces/qt/qt45.pas
+@@ -45,7 +45,7 @@ const
+ {$ENDIF}
+
+ {$IFNDEF QTOPIA}
+- {$IF DEFINED(LINUX) or DEFINED(FREEBSD) or DEFINED(NETBSD)}
++ {$IF DEFINED(LINUX) or DEFINED(FREEBSD) or DEFINED(NETBSD) or DEFINED(DRAGONFLY)}
+ {$DEFINE BINUX}
+ Qt4PasLib = 'libQt4Pas.so.5';
+ {$ENDIF}