aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-24 00:11:38 +0800
committermiwi <miwi@FreeBSD.org>2014-02-24 00:11:38 +0800
commit5d3636c7f7869c3711e6e9bee22d75f52d5d2e40 (patch)
treede38a72b1df011815266f1976d1c1f18d220f339 /editors
parent8ec330f6137eaa7bcaa83c6a252fa7aeab39b318 (diff)
downloadfreebsd-ports-gnome-5d3636c7f7869c3711e6e9bee22d75f52d5d2e40.tar.gz
freebsd-ports-gnome-5d3636c7f7869c3711e6e9bee22d75f52d5d2e40.tar.zst
freebsd-ports-gnome-5d3636c7f7869c3711e6e9bee22d75f52d5d2e40.zip
- Fix clang build
- Add License - Stage support PR: 186735 Submitted by: ports fury
Diffstat (limited to 'editors')
-rw-r--r--editors/klat4/Makefile9
-rw-r--r--editors/klat4/files/patch-klatexecsettingsdlgimpl.cpp18
-rw-r--r--editors/klat4/files/patch-klathtmlwidget.cpp21
3 files changed, 43 insertions, 5 deletions
diff --git a/editors/klat4/Makefile b/editors/klat4/Makefile
index eb85d0d512c0..6539ff8e86a1 100644
--- a/editors/klat4/Makefile
+++ b/editors/klat4/Makefile
@@ -8,14 +8,13 @@ CATEGORIES= editors
MASTER_SITES= http://klat.algebraic.ru/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A LaTeX source editor for KDE4
+COMMENT= LaTeX source editor for KDE4
-RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/katepart.so:${PORTSDIR}/editors/kate
+LICENSE= GPLv2 # (or later)
USE_BZIP2= yes
USES= cmake
-USE_KDE4= kdeprefix kdelibs automoc4
-USE_QT4= corelib qmake_build moc_build rcc_build uic_build
+USE_KDE4= automoc4 kate kdelibs kdeprefix
+USE_QT4= moc_build qmake_build rcc_build uic_build
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/editors/klat4/files/patch-klatexecsettingsdlgimpl.cpp b/editors/klat4/files/patch-klatexecsettingsdlgimpl.cpp
new file mode 100644
index 000000000000..888a7ae2495f
--- /dev/null
+++ b/editors/klat4/files/patch-klatexecsettingsdlgimpl.cpp
@@ -0,0 +1,18 @@
+--- klatexecsettingsdlgimpl.cpp.orig
++++ klatexecsettingsdlgimpl.cpp
+@@ -271,6 +271,7 @@
+ return tmp.entry().commandLine();
+ // else if (index.column() == 4)
+ // return tmp.entry().shortcut().toString();
++ return QVariant();
+ }
+ else
+ return QVariant();
+@@ -294,6 +295,7 @@
+ return QString(i18n("Parameters"));
+ // else if(sect == 4)
+ // return QString("Shortcut");
++ return QString("Invisible");
+ }
+
+ void KlatExecConfigModel::slotDataChanged(const QModelIndex &top, const QModelIndex &bottom)
diff --git a/editors/klat4/files/patch-klathtmlwidget.cpp b/editors/klat4/files/patch-klathtmlwidget.cpp
new file mode 100644
index 000000000000..29ecc0ca192f
--- /dev/null
+++ b/editors/klat4/files/patch-klathtmlwidget.cpp
@@ -0,0 +1,21 @@
+--- klathtmlwidget.cpp.orig
++++ klathtmlwidget.cpp
+@@ -73,7 +73,7 @@
+ }
+ if(cURL.protocol() == LTRTOKLATPROT && found == true)
+ {
+- for (i ,found = false ; !found && i < len ; i++)
++ for (i = 0, found = false ; !found && i < len ; i++)
+ {
+ if (code[i] == '}')
+ {
+@@ -85,7 +85,9 @@
+ }
+
+ emit signalSymbolCodeSelected(code,advance);
++ return found;
+ }
++ return false;
+ }
+
+ void KlatHTMLWidget::openAppDataUrl(const QString &relpath)