aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-04-29 03:34:59 +0800
committerknu <knu@FreeBSD.org>2001-04-29 03:34:59 +0800
commit621b1b7b8dfd38e6e89e069f82298ea248176629 (patch)
treec656e20c175e8c652729bd4f64b9358c9651598f /editors
parentec908822a0ee26b4d315dbc388a8a41849b3f218 (diff)
downloadfreebsd-ports-gnome-621b1b7b8dfd38e6e89e069f82298ea248176629.tar.gz
freebsd-ports-gnome-621b1b7b8dfd38e6e89e069f82298ea248176629.tar.zst
freebsd-ports-gnome-621b1b7b8dfd38e6e89e069f82298ea248176629.zip
Apply a hotfix against ruby-interp. This fixes the coredump when $_
is set to non-string in a :rubydo command. (e.g. :rubydo $_ = 0) It will be submitted to the vim6 author soon.
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/files/patch-if_ruby.c13
-rw-r--r--editors/vim6+ruby/Makefile2
-rw-r--r--editors/vim6/files/patch-if_ruby.c13
3 files changed, 28 insertions, 0 deletions
diff --git a/editors/vim/files/patch-if_ruby.c b/editors/vim/files/patch-if_ruby.c
new file mode 100644
index 000000000000..1b219841aac2
--- /dev/null
+++ b/editors/vim/files/patch-if_ruby.c
@@ -0,0 +1,13 @@
+--- if_ruby.c.orig Thu Apr 5 02:32:59 2001
++++ if_ruby.c Sun Apr 29 01:47:30 2001
+@@ -66,6 +66,10 @@
+ }
+ line = rb_lastline_get();
+ if (!NIL_P(line)) {
++ if (TYPE(line) != T_STRING) {
++ EMSG("$_ must be an instance of String");
++ return;
++ }
+ ml_replace(i, (char_u *) STR2CSTR(line), 1);
+ changed();
+ #ifdef SYNTAX_HL
diff --git a/editors/vim6+ruby/Makefile b/editors/vim6+ruby/Makefile
index 1db3441e1b54..84df3f38b4b3 100644
--- a/editors/vim6+ruby/Makefile
+++ b/editors/vim6+ruby/Makefile
@@ -7,6 +7,8 @@
MASTERDIR= ${.CURDIR}/../vim6
+PORTREVISION= 1
+
CATEGORIES= editors ruby
PKGNAMESUFFIX= +ruby
diff --git a/editors/vim6/files/patch-if_ruby.c b/editors/vim6/files/patch-if_ruby.c
new file mode 100644
index 000000000000..1b219841aac2
--- /dev/null
+++ b/editors/vim6/files/patch-if_ruby.c
@@ -0,0 +1,13 @@
+--- if_ruby.c.orig Thu Apr 5 02:32:59 2001
++++ if_ruby.c Sun Apr 29 01:47:30 2001
+@@ -66,6 +66,10 @@
+ }
+ line = rb_lastline_get();
+ if (!NIL_P(line)) {
++ if (TYPE(line) != T_STRING) {
++ EMSG("$_ must be an instance of String");
++ return;
++ }
+ ml_replace(i, (char_u *) STR2CSTR(line), 1);
+ changed();
+ #ifdef SYNTAX_HL