aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2007-10-26 00:52:59 +0800
committerobrien <obrien@FreeBSD.org>2007-10-26 00:52:59 +0800
commit6adb3e81ae388eae52b3c7cf510aab65402e9e88 (patch)
tree2deb112bdc4c993a09e662de2f3573bdb4036e33 /editors
parent216c346a9c1c983b38f9f980184064c036246bb5 (diff)
downloadfreebsd-ports-gnome-6adb3e81ae388eae52b3c7cf510aab65402e9e88.tar.gz
freebsd-ports-gnome-6adb3e81ae388eae52b3c7cf510aab65402e9e88.tar.zst
freebsd-ports-gnome-6adb3e81ae388eae52b3c7cf510aab65402e9e88.zip
Move around the package-building options to make other ones easier to see,
and conditionalize WANT_PERL & WANT_GNOME.
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile33
1 files changed, 19 insertions, 14 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 097607c4f982..9f21cab7eb40 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -33,18 +33,6 @@ SLAVEDIRS= editors/vim-lite
.include "${.CURDIR}/options"
.endif
-.if defined(PACKAGE_BUILDING) && !defined(LITE)
-#WITH_TCL= yes
-WITH_PERL= yes
-WITH_PYTHON= yes
-WITH_CSCOPE= yes
-WITH_EXUBERANT_CTAGS=yes
-.endif
-
-.if defined(WITH_TCL)
-BROKEN= Does not compile
-.endif
-
USE_BZIP2= yes
DIST_SUBDIR= vim
WRKSRC= ${WRKDIR}/vim${PORTVERSION:C/\.[0-9]*$//:S/.//g}/src
@@ -66,8 +54,17 @@ MLINKS+= vim.1 gvim.1 vim.1 gview.1 vimdiff.1 gvimdiff.1 \
MANLANG= "" ru.KOI8-R ru.UTF-8 pl.ISO8859-2 pl.UTF-8 pl fr.ISO8859-1 \
fr.UTF-8 fr it.ISO8859-1 it.UTF-8 it
-WANT_GNOME= yes
-WANT_PERL= yes
+.if defined(PACKAGE_BUILDING) && !defined(LITE)
+#WITH_TCL= yes
+WITH_PERL= yes
+WITH_PYTHON= yes
+WITH_CSCOPE= yes
+WITH_EXUBERANT_CTAGS=yes
+.endif
+
+.if defined(WITH_TCL)
+BROKEN= Does not compile
+.endif
.if defined(WITH_PYTHON)
USE_PYTHON= yes
@@ -79,6 +76,14 @@ USE_RUBY= yes
MAKE_ARGS+= CONF_OPT_RUBY="--enable-rubyinterp"
.endif
+.if defined(WITH_PERL)
+WANT_PERL= yes
+.endif
+
+.if !defined(WITHOUT_X11)
+WANT_GNOME= yes
+.endif
+
.include <bsd.port.pre.mk>
.if !defined(LITE)