aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2003-11-26 23:05:08 +0800
committernobutaka <nobutaka@FreeBSD.org>2003-11-26 23:05:08 +0800
commite68b837d6bc14ab1acdae10926b048f16585ea53 (patch)
tree8939ff4c8026eceb85134d8fadd33af59335baeb /editors
parentda5a97f7aa1d9e087f811c2bb619346e855f4e0e (diff)
downloadfreebsd-ports-gnome-e68b837d6bc14ab1acdae10926b048f16585ea53.tar.gz
freebsd-ports-gnome-e68b837d6bc14ab1acdae10926b048f16585ea53.tar.zst
freebsd-ports-gnome-e68b837d6bc14ab1acdae10926b048f16585ea53.zip
Fix build on ia64.
Submitted by: Ken Smith <kensmith@cse.Buffalo.EDU> Approved by: portmgr (kris)
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs21/files/patch-configure.in11
-rw-r--r--editors/emacs21/files/patch-src:m:ia64.h11
2 files changed, 17 insertions, 5 deletions
diff --git a/editors/emacs21/files/patch-configure.in b/editors/emacs21/files/patch-configure.in
index a8f299a7bff4..954b7743170d 100644
--- a/editors/emacs21/files/patch-configure.in
+++ b/editors/emacs21/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig Fri Oct 19 23:09:18 2001
-+++ configure.in Mon Oct 22 21:19:32 2001
-@@ -179,6 +179,16 @@
+--- configure.in.orig Sun Mar 16 14:06:05 2003
++++ configure.in Thu Nov 20 13:54:06 2003
+@@ -179,6 +179,17 @@
machine='' opsys='' unported=no
case "${canonical}" in
@@ -9,6 +9,7 @@
+ opsys=freebsd
+ case "${canonical}" in
+ alpha*-*-freebsd*) machine=alpha ;;
++ ia64-*-freebsd*) machine=ia64 ;;
+ i[3456]86-*-freebsd*) machine=intel386 ;;
+ sparc64-*-freebsd*) machine=sparc ;;
+ esac
@@ -17,7 +18,7 @@
## NetBSD ports
*-*-netbsd* )
opsys=netbsd
-@@ -1017,7 +1026,6 @@
+@@ -1032,7 +1043,6 @@
;;
*-sysv4.2uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
*-386bsd* ) opsys=386bsd ;;
@@ -25,7 +26,7 @@
*-nextstep* ) opsys=nextstep ;;
## Otherwise, we'll fall through to the generic opsys code at the bottom.
esac
-@@ -2007,6 +2015,7 @@
+@@ -2050,6 +2060,7 @@
# Solaris requires -lintl if you want strerror (which calls dgettext)
# to return localized messages.
AC_CHECK_LIB(intl, dgettext)
diff --git a/editors/emacs21/files/patch-src:m:ia64.h b/editors/emacs21/files/patch-src:m:ia64.h
new file mode 100644
index 000000000000..34f7a1eec276
--- /dev/null
+++ b/editors/emacs21/files/patch-src:m:ia64.h
@@ -0,0 +1,11 @@
+--- src/m/ia64.h.orig Fri Sep 29 06:00:37 2000
++++ src/m/ia64.h Thu Nov 20 13:44:02 2003
+@@ -147,7 +147,7 @@
+
+ #ifndef NOT_C_CODE
+ /* We need these because pointers are larger than the default ints. */
+-# if !defined(__NetBSD__) && !defined(__OpenBSD__)
++# if !defined(__NetBSD__) && !defined(__OpenBSD__) && !defined(__FreeBSD__)
+ # include <alloca.h>
+ # else
+ # include <stdlib.h>