aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-12 10:59:57 +0800
committermiwi <miwi@FreeBSD.org>2014-02-12 10:59:57 +0800
commite7898d53801d229b3e35f77e50c249295be2cca9 (patch)
tree48972dbc77737a2682b87c44ab6656f58f004db7 /editors
parent7448dffdf5a71ae7c374c47ce3261ce267e562df (diff)
downloadfreebsd-ports-gnome-e7898d53801d229b3e35f77e50c249295be2cca9.tar.gz
freebsd-ports-gnome-e7898d53801d229b3e35f77e50c249295be2cca9.tar.zst
freebsd-ports-gnome-e7898d53801d229b3e35f77e50c249295be2cca9.zip
- Fix lua support
PR: 185650 184588 Submitted by: Kenji Rikitake <kenji@k2r.org> Approved by: maintainer timeout
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile2
-rw-r--r--editors/vim/files/patch-configure2
2 files changed, 2 insertions, 2 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 93300f94a7b4..b2b49f2615ce 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -12,7 +12,7 @@ PORTNAME= vim
# ! PATCHLEVEL to that level.
PATCHLEVEL= 169
PORTVERSION= 7.4.${PATCHLEVEL}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= editors
MASTER_SITES= VIM
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
diff --git a/editors/vim/files/patch-configure b/editors/vim/files/patch-configure
index af86862677af..67f951f5d0e8 100644
--- a/editors/vim/files/patch-configure
+++ b/editors/vim/files/patch-configure
@@ -42,7 +42,7 @@
LUA_LIBS=""
- LUA_CFLAGS="-DDYNAMIC_LUA_DLL=\\\"${vi_cv_dll_name_lua}\\\" $LUA_CFLAGS"
+ vi_cv_version_lua=${LUA_VER}
-+ LUA_CFLAGS="-DDYNAMIC_LUA_DLL=\\\"liblua-${vi_cv_version_lua}\\\" $LUA_CFLAGS"
++ LUA_CFLAGS="-DDYNAMIC_LUA_DLL=\\\"liblua-${vi_cv_version_lua}.so\\\" $LUA_CFLAGS"
fi
if test "X$LUA_CFLAGS$LUA_LIBS" != "X" && \
test "x$MACOSX" = "xyes" && test "x$vi_cv_with_luajit" != "xno" && \