aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-09-12 16:29:01 +0800
committerahze <ahze@FreeBSD.org>2005-09-12 16:29:01 +0800
commite9f59dcf2dbfe9a4ae897c135bbe10eb4b5f4523 (patch)
tree16bbf0acdec2a5b5658ecb4ac2a89958ffcf4f15 /editors
parent09a75fb75323e8f658fbca761336f8e9c98ffd71 (diff)
downloadfreebsd-ports-gnome-e9f59dcf2dbfe9a4ae897c135bbe10eb4b5f4523.tar.gz
freebsd-ports-gnome-e9f59dcf2dbfe9a4ae897c135bbe10eb4b5f4523.tar.zst
freebsd-ports-gnome-e9f59dcf2dbfe9a4ae897c135bbe10eb4b5f4523.zip
- Add EXTRACT_AFTER_ARGS to shave off a few seconds and 59MB for abiword
89MB for abiword-plugins
Diffstat (limited to 'editors')
-rw-r--r--editors/abiword-plugins/Makefile4
-rw-r--r--editors/abiword/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/editors/abiword-plugins/Makefile b/editors/abiword-plugins/Makefile
index 4ae57f4e1e93..84669bbb84c9 100644
--- a/editors/abiword-plugins/Makefile
+++ b/editors/abiword-plugins/Makefile
@@ -37,6 +37,10 @@ MD5_FILE= ${.CURDIR}/../abiword/distinfo
ABIVERSION= 2.2
PLIST_SUB+= ABIVERSION=${ABIVERSION}
+EXCLUDE_EXTRACT= MSVC6 MSVC71 abidistfiles abipbx abiword-docs expat \
+ fribidi libiconv libpng pbx popt wv zlib
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXCLUDE_EXTRACT:S/^/--exclude /}
+
# NOTE: Please, keep those knobs in the ABC's order.
.if defined(WITH_AIKSAURUS) || defined(PACKAGE_BUILDING)
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 02d133ff1613..b4b9f1d34d05 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -41,6 +41,10 @@ CONFIGURE_ARGS= --enable-xft \
--disable-peer-config
MAKEFILE= GNUmakefile
+EXCLUDE_EXTRACT= MSVC6 MSVC71 abipbx abiword-docs abiword-plugins expat \
+ fribidi libiconv libpng pbx popt wv zlib
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXCLUDE_EXTRACT:S/^/--exclude /}
+
ABIVERSION= 2.2
PLIST_SUB+= ABIVERSION=${ABIVERSION}
WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi