aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-09-28 11:28:46 +0800
committermaho <maho@FreeBSD.org>2007-09-28 11:28:46 +0800
commitf1eb3610c4d50cbbb35d8326b0afb305758358ce (patch)
tree1ca98b5b0a7eb96aa4c08e31d88b700dd5f6bfde /editors
parent67aa77cab990c0f7646819ca9fc802d4032c884c (diff)
downloadfreebsd-ports-gnome-f1eb3610c4d50cbbb35d8326b0afb305758358ce.tar.gz
freebsd-ports-gnome-f1eb3610c4d50cbbb35d8326b0afb305758358ce.tar.zst
freebsd-ports-gnome-f1eb3610c4d50cbbb35d8326b0afb305758358ce.zip
Unbreak for 7-CURRENT.
Truckman was able to successfully build the port on a September 22nd copy of 7.0-CURRENT on an i386 machine with jdk-1.5.0.12p6_2,1, also use only 1.4 and 1.5, as JDK 1.6 has problem. See PR 116607. PR: 116607 Submitted by: truckman
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile8
-rw-r--r--editors/openoffice-3/Makefile8
-rw-r--r--editors/openoffice.org-2-RC/Makefile8
-rw-r--r--editors/openoffice.org-2-devel/Makefile8
-rw-r--r--editors/openoffice.org-2/Makefile8
-rw-r--r--editors/openoffice.org-3-RC/Makefile8
-rw-r--r--editors/openoffice.org-3-devel/Makefile8
-rw-r--r--editors/openoffice.org-3/Makefile8
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile8
9 files changed, 53 insertions, 19 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 61d3b2042bf7..3288d5c6b410 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -50,11 +50,17 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} >= 700000)
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
+.endif
+
.include <${FILESDIR}/Makefile.localized>
ONLY_FOR_ARCHS= i386 amd64
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 5b8bf2721e9a..a17af37671bc 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -51,17 +51,19 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
-.include <${FILESDIR}/Makefile.localized>
.if (${OSVERSION} >= 700000)
-BROKEN= Build broken with JDK internal error
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
.endif
+.include <${FILESDIR}/Makefile.localized>
+
ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index 7c12ce830b22..5aa811464951 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -50,17 +50,19 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
-.include <${FILESDIR}/Makefile.localized>
.if (${OSVERSION} >= 700000)
-BROKEN= Build broken with JDK internal error
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
.endif
+.include <${FILESDIR}/Makefile.localized>
+
ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 61d3b2042bf7..3288d5c6b410 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -50,11 +50,17 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} >= 700000)
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
+.endif
+
.include <${FILESDIR}/Makefile.localized>
ONLY_FOR_ARCHS= i386 amd64
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 5b8bf2721e9a..a17af37671bc 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -51,17 +51,19 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
-.include <${FILESDIR}/Makefile.localized>
.if (${OSVERSION} >= 700000)
-BROKEN= Build broken with JDK internal error
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
.endif
+.include <${FILESDIR}/Makefile.localized>
+
ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 7c12ce830b22..5aa811464951 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -50,17 +50,19 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
-.include <${FILESDIR}/Makefile.localized>
.if (${OSVERSION} >= 700000)
-BROKEN= Build broken with JDK internal error
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
.endif
+.include <${FILESDIR}/Makefile.localized>
+
ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 61d3b2042bf7..3288d5c6b410 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -50,11 +50,17 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} >= 700000)
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
+.endif
+
.include <${FILESDIR}/Makefile.localized>
ONLY_FOR_ARCHS= i386 amd64
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index 5b8bf2721e9a..a17af37671bc 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -51,17 +51,19 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
-.include <${FILESDIR}/Makefile.localized>
.if (${OSVERSION} >= 700000)
-BROKEN= Build broken with JDK internal error
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
.endif
+.include <${FILESDIR}/Makefile.localized>
+
ONLY_FOR_ARCHS= i386 amd64
.if ${ARCH} == amd64
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 61d3b2042bf7..3288d5c6b410 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -50,11 +50,17 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
USE_JAVA= yes
-JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} >= 700000)
+JAVA_VERSION= 1.5
+.else
+JAVA_VERSION= 1.4 1.5
+.endif
+
.include <${FILESDIR}/Makefile.localized>
ONLY_FOR_ARCHS= i386 amd64