aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>2000-07-19 16:07:47 +0800
committershige <shige@FreeBSD.org>2000-07-19 16:07:47 +0800
commit0a2021589a4a919f30f1b789db00476edfc23b78 (patch)
treeb063daf3eb544060b1489633d870927325db3c11 /editors
parent1c16ebdb044f28de91aad17af09d45a3a9f9b399 (diff)
downloadfreebsd-ports-gnome-0a2021589a4a919f30f1b789db00476edfc23b78.tar.gz
freebsd-ports-gnome-0a2021589a4a919f30f1b789db00476edfc23b78.tar.zst
freebsd-ports-gnome-0a2021589a4a919f30f1b789db00476edfc23b78.zip
Fix broken apel-dependency in the case of xemacs and xemacs20.
Diffstat (limited to 'editors')
-rw-r--r--editors/flim-emacs-current/Makefile4
-rw-r--r--editors/flim-emacs/Makefile4
-rw-r--r--editors/flim/Makefile4
-rw-r--r--editors/flim113-emacs/Makefile4
-rw-r--r--editors/flim113/Makefile4
-rw-r--r--editors/flim114-emacs20/Makefile4
6 files changed, 24 insertions, 0 deletions
diff --git a/editors/flim-emacs-current/Makefile b/editors/flim-emacs-current/Makefile
index 2265d76451a0..61cc10fc34d6 100644
--- a/editors/flim-emacs-current/Makefile
+++ b/editors/flim-emacs-current/Makefile
@@ -46,6 +46,10 @@ PLIST_SUB+= FLIMDOCDIR=${FLIMDOCDIR} FLIM_SETUPEL=${FLIM_SETUPEL} \
.if defined(EMACS_PACKAGESDIR)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.elif (${EMACS_PORT_NAME} == "xemacs") || (${EMACS_PORT_NAME} == "xemacs20")
+# depends on apel (case of xemacs-20.x or former)
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
.else
# depends on apel (case of other emacsen etc...)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
diff --git a/editors/flim-emacs/Makefile b/editors/flim-emacs/Makefile
index 9c9b9ca8be7d..32679dff8e44 100644
--- a/editors/flim-emacs/Makefile
+++ b/editors/flim-emacs/Makefile
@@ -46,6 +46,10 @@ PLIST_SUB+= FLIMDOCDIR=${FLIMDOCDIR} FLIM_SETUPEL=${FLIM_SETUPEL} \
.if defined(EMACS_PACKAGESDIR)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.elif (${EMACS_PORT_NAME} == "xemacs") || (${EMACS_PORT_NAME} == "xemacs20")
+# depends on apel (case of xemacs-20.x or former)
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
.else
# depends on apel (case of other emacsen etc...)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
diff --git a/editors/flim/Makefile b/editors/flim/Makefile
index 2265d76451a0..61cc10fc34d6 100644
--- a/editors/flim/Makefile
+++ b/editors/flim/Makefile
@@ -46,6 +46,10 @@ PLIST_SUB+= FLIMDOCDIR=${FLIMDOCDIR} FLIM_SETUPEL=${FLIM_SETUPEL} \
.if defined(EMACS_PACKAGESDIR)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.elif (${EMACS_PORT_NAME} == "xemacs") || (${EMACS_PORT_NAME} == "xemacs20")
+# depends on apel (case of xemacs-20.x or former)
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
.else
# depends on apel (case of other emacsen etc...)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
diff --git a/editors/flim113-emacs/Makefile b/editors/flim113-emacs/Makefile
index 2265d76451a0..61cc10fc34d6 100644
--- a/editors/flim113-emacs/Makefile
+++ b/editors/flim113-emacs/Makefile
@@ -46,6 +46,10 @@ PLIST_SUB+= FLIMDOCDIR=${FLIMDOCDIR} FLIM_SETUPEL=${FLIM_SETUPEL} \
.if defined(EMACS_PACKAGESDIR)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.elif (${EMACS_PORT_NAME} == "xemacs") || (${EMACS_PORT_NAME} == "xemacs20")
+# depends on apel (case of xemacs-20.x or former)
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
.else
# depends on apel (case of other emacsen etc...)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
diff --git a/editors/flim113/Makefile b/editors/flim113/Makefile
index 2265d76451a0..61cc10fc34d6 100644
--- a/editors/flim113/Makefile
+++ b/editors/flim113/Makefile
@@ -46,6 +46,10 @@ PLIST_SUB+= FLIMDOCDIR=${FLIMDOCDIR} FLIM_SETUPEL=${FLIM_SETUPEL} \
.if defined(EMACS_PACKAGESDIR)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.elif (${EMACS_PORT_NAME} == "xemacs") || (${EMACS_PORT_NAME} == "xemacs20")
+# depends on apel (case of xemacs-20.x or former)
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
.else
# depends on apel (case of other emacsen etc...)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
diff --git a/editors/flim114-emacs20/Makefile b/editors/flim114-emacs20/Makefile
index 2265d76451a0..61cc10fc34d6 100644
--- a/editors/flim114-emacs20/Makefile
+++ b/editors/flim114-emacs20/Makefile
@@ -46,6 +46,10 @@ PLIST_SUB+= FLIMDOCDIR=${FLIMDOCDIR} FLIM_SETUPEL=${FLIM_SETUPEL} \
.if defined(EMACS_PACKAGESDIR)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.elif (${EMACS_PORT_NAME} == "xemacs") || (${EMACS_PORT_NAME} == "xemacs20")
+# depends on apel (case of xemacs-20.x or former)
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
.else
# depends on apel (case of other emacsen etc...)
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}