aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2009-05-16 12:29:27 +0800
committermaho <maho@FreeBSD.org>2009-05-16 12:29:27 +0800
commit18acae43c93bfae60193670a46e31b43f9126164 (patch)
tree9f30749c63d722ac96cee2c708d65a5427085fbc /editors
parentb0ef497500c18431bcb2eb08d64f2815ca43a883 (diff)
downloadfreebsd-ports-gnome-18acae43c93bfae60193670a46e31b43f9126164.tar.gz
freebsd-ports-gnome-18acae43c93bfae60193670a46e31b43f9126164.tar.zst
freebsd-ports-gnome-18acae43c93bfae60193670a46e31b43f9126164.zip
Workaround for CRLF issue for some patchfiles.
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice.org-3-RC/Makefile7
-rw-r--r--editors/openoffice.org-3-RC/files/patch-i8454914
2 files changed, 14 insertions, 7 deletions
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 67c1777de1a7..5c208da78ce2 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -177,7 +177,13 @@ pre-everything::
@${TOUCH} ${BUILD_COOKIE}
.endif
+#issue XXXXXX not raised yet...
+CRLFFILES=curl/curl*patch neon/neon*patch
+
post-extract:
+ for i in ${CRLFFILES}; do \
+ cd ${WRKSRC} ; ${REINPLACE_CMD} -e 's# ##g' $$i ; \
+ done
@${CP} ${DISTDIR}/${DIST_SUBDIR}/unowinreg.dll ${WRKSRC}/external/unowinreg/
.if defined(WITH_CWS)
cd ${WRKSRC} ; ${TAR} xvfz ${DISTDIR}/${DIST_SUBDIR}/${CWSARCHIVE}
@@ -190,6 +196,7 @@ post-extract:
.if !defined(WITHOUT_MOZILLA)
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${MOZILLA_SOURCE} ${WRKSRC}/moz/download
.endif
+
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
diff --git a/editors/openoffice.org-3-RC/files/patch-i84549 b/editors/openoffice.org-3-RC/files/patch-i84549
index 95ec361dcdb1..1d7f6517953b 100644
--- a/editors/openoffice.org-3-RC/files/patch-i84549
+++ b/editors/openoffice.org-3-RC/files/patch-i84549
@@ -6,11 +6,11 @@ diff -u -r1.25 neon.patch
--- neon/neon.patch 22 Jul 2008 17:17:06 -0000 1.25
+++ neon/neon.patch 10 Aug 2008 04:20:27 -0000
@@ -266,7 +266,7 @@
- +#define HAVE_SYS_TYPES_H 1
- +
- +/* Define if the timezone global is available */
--+#ifndef MACOSX
+ +#define HAVE_SYS_TYPES_H 1
+ +
+ +/* Define if the timezone global is available */
+-+#ifndef MACOSX
++#if !defined(MACOSX) && !defined(FREEBSD)
- +#define HAVE_TIMEZONE 1
- +#endif
- +
+ +#define HAVE_TIMEZONE 1
+ +#endif
+ +