aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-12-31 07:46:29 +0800
committermarcus <marcus@FreeBSD.org>2007-12-31 07:46:29 +0800
commit29ed26b8f8812661af633d306d94ad0f180acba1 (patch)
tree2cf74367c69d82b85c54ff52fb10c684fb52bfe6 /editors
parentfa11fde52e67a2e69a44af9c7d28edf3ba80a011 (diff)
downloadfreebsd-ports-gnome-29ed26b8f8812661af633d306d94ad0f180acba1.tar.gz
freebsd-ports-gnome-29ed26b8f8812661af633d306d94ad0f180acba1.tar.zst
freebsd-ports-gnome-29ed26b8f8812661af633d306d94ad0f180acba1.zip
Use an explicit (void *)0 instead of NULL to indicate a varargs sentinel.
This fixes the runtime on 64-bit platforms since since C++ treats NULL as simply 0. PR: 119127
Diffstat (limited to 'editors')
-rw-r--r--editors/abiword/Makefile2
-rw-r--r--editors/abiword/files/patch-src_wp_ap_unix_ap_UnixApp.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 981c1e639bdc..b0f5e4622378 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -8,7 +8,7 @@
PORTNAME= abiword
PORTVERSION= 2.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/%SUBDIR%/${PORTVERSION}/source/
MASTER_SITE_SUBDIR= abiword
diff --git a/editors/abiword/files/patch-src_wp_ap_unix_ap_UnixApp.cpp b/editors/abiword/files/patch-src_wp_ap_unix_ap_UnixApp.cpp
new file mode 100644
index 000000000000..c0ff7430562f
--- /dev/null
+++ b/editors/abiword/files/patch-src_wp_ap_unix_ap_UnixApp.cpp
@@ -0,0 +1,11 @@
+--- src/wp/ap/unix/ap_UnixApp.cpp.orig 2007-12-30 18:44:50.000000000 -0500
++++ src/wp/ap/unix/ap_UnixApp.cpp 2007-12-30 18:41:23.000000000 -0500
+@@ -1405,7 +1405,7 @@ int AP_UnixApp::main(const char * szAppN
+ GNOME_PARAM_APP_DATADIR, ABIWORD_DATADIR,
+ GNOME_PARAM_APP_LIBDIR, ABIWORD_APP_LIBDIR,
+ GNOME_PARAM_POPT_TABLE, AP_Args::options,
+- GNOME_PARAM_NONE);
++ (void *)0);
+ #ifdef LOGFILE
+ fprintf(logfile,"gnome_program_init completed \n");
+ #endif