aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-04-03 21:50:54 +0800
committerkris <kris@FreeBSD.org>2004-04-03 21:50:54 +0800
commit4d30d66bb6a423ef307bbdb2b5d0a19ef4eafb74 (patch)
tree91108d9835a9a3ff379e6da5c27db9a3e1907830 /editors
parente93d731d8936af8aa77f5a4cfdd3f5af02195661 (diff)
downloadfreebsd-ports-gnome-4d30d66bb6a423ef307bbdb2b5d0a19ef4eafb74.tar.gz
freebsd-ports-gnome-4d30d66bb6a423ef307bbdb2b5d0a19ef4eafb74.tar.zst
freebsd-ports-gnome-4d30d66bb6a423ef307bbdb2b5d0a19ef4eafb74.zip
BROKEN on amd64 (missing -fPIC) and ia64 (hangs during configure)
Diffstat (limited to 'editors')
-rw-r--r--editors/bed/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/editors/bed/Makefile b/editors/bed/Makefile
index 5f750b237fb1..a81997a48d31 100644
--- a/editors/bed/Makefile
+++ b/editors/bed/Makefile
@@ -40,6 +40,16 @@ PLIST_SUB+= X11="@comment "
.else
PLIST_SUB+= X11=""
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not compile on amd64 (missing -fPIC)"
+.endif
+
+.if ${ARCH} == "ia64"
+BROKEN= "Hangs during configure"
+.endif
+
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
pre-configure:
@if "${X11BASE}/bin/rxvt" -h 2>&1 | ${GREP} -qi menubar; then \
@@ -57,4 +67,4 @@ post-configure:
${ECHO_MSG} 'CONFIG_MMAP=y' >> ${WRKSRC}/config
${GMAKE} -C ${WRKSRC} dep
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>