aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-04-26 14:34:46 +0800
committermiwi <miwi@FreeBSD.org>2013-04-26 14:34:46 +0800
commit6116cb49937c7050209d07d0d4bcd455fea1c19c (patch)
treecf04ac3f92df40ea83155ff945439f90e11577ea /editors
parentf9ce991bfd55ed8987f870f7306fb38d5c8893ac (diff)
downloadfreebsd-ports-gnome-6116cb49937c7050209d07d0d4bcd455fea1c19c.tar.gz
freebsd-ports-gnome-6116cb49937c7050209d07d0d4bcd455fea1c19c.tar.zst
freebsd-ports-gnome-6116cb49937c7050209d07d0d4bcd455fea1c19c.zip
- Update to 35.0.0
PR: 177911 Submitted by: Ports Fury
Diffstat (limited to 'editors')
-rw-r--r--editors/tea/Makefile30
-rw-r--r--editors/tea/distinfo4
-rw-r--r--editors/tea/files/patch-document.cpp16
-rw-r--r--editors/tea/files/patch-rvln.cpp10
-rw-r--r--editors/tea/pkg-descr2
5 files changed, 50 insertions, 12 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 62bce5926df4..a9ea6795cf9a 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -2,35 +2,47 @@
# $FreeBSD$
PORTNAME= tea
-DISTVERSION= 34.0.1
+DISTVERSION= 35.0.0
CATEGORIES= editors
-MASTER_SITES= SF/${PORTNAME}-editor/${PORTNAME}-editor/${PORTVERSION}
+MASTER_SITES= http://semiletov.org/tea/dloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple and powerful Qt4-based text editor
LICENSE= GPLv3
+OPTIONS_RADIO= SPELL
+OPTIONS_RADIO_SPELL= ASPELL HUNSPELL
+OPTIONS_DEFAULT= ASPELL
+HUNSPELL_DESC= Spell cheecking support via Hunspell
+
USE_BZIP2= yes
-USE_QT4= qmake_build moc_build rcc_build gui xml
+USE_DOS2UNIX= rvln.*
+USE_QT4= gui moc_build qmake_build rcc_build
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/${PORTNAME}
-OPTIONS_DEFINE= ASPELL
-OPTIONS_DEFAULT= ASPELL
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
-QMAKEFLAGS= USE_ASPELL=true
+LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
+QMAKEFLAGS+= USE_ASPELL=true
+.else
+QMAKEFLAGS+= USE_ASPELL=false
+.endif
+
+.if ${PORT_OPTIONS:MHUNSPELL}
+LIB_DEPENDS+= hunspell-1.3:${PORTSDIR}/textproc/hunspell
+QMAKEFLAGS+= USE_HUNSPELL=true
.else
-QMAKEFLAGS= USE_ASPELL=false
+QMAKEFLAGS+= USE_HUNSPELL=false
.endif
post-patch:
- @${REINPLACE_CMD} -e '/aspell/s,/usr,${LOCALBASE},' ${WRKSRC}/src.pro
+ @${REINPLACE_CMD} -e \
+ 's|/usr/include|${LOCALBASE}/include|' ${WRKSRC}/src.pro
do-configure:
@cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS}
diff --git a/editors/tea/distinfo b/editors/tea/distinfo
index f8ee5ead9cf3..a7ee36677c5d 100644
--- a/editors/tea/distinfo
+++ b/editors/tea/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tea-34.0.1.tar.bz2) = 2de71096ebd01d7fd077a4a25fcfa9c7f59a7fc452996a669fee3b9bcadf07c5
-SIZE (tea-34.0.1.tar.bz2) = 314016
+SHA256 (tea-35.0.0.tar.bz2) = a2b7972937e1bd3fd01ff0194748aef326fe4f08ad5f2930e7c06d88e433b7fb
+SIZE (tea-35.0.0.tar.bz2) = 314921
diff --git a/editors/tea/files/patch-document.cpp b/editors/tea/files/patch-document.cpp
new file mode 100644
index 000000000000..6ecc5cfad458
--- /dev/null
+++ b/editors/tea/files/patch-document.cpp
@@ -0,0 +1,16 @@
+--- document.cpp.orig
++++ document.cpp
+@@ -206,11 +206,11 @@
+
+ qDebug() << "defined(Q_OS_WIN) || defined(Q_OS_OS2)";
+
+-#elif defined(Q_OS_LINUX)
++#elif defined(Q_OS_LINUX) || defined(Q_OS_UNIX)
+
+ eol = "\n";
+
+- qDebug() << "Q_OS_LINUX";
++ qDebug() << "defined(Q_OS_LINUX) || defined(Q_OS_UNIX)";
+
+
+ #elif defined(Q_OS_MAC)
diff --git a/editors/tea/files/patch-rvln.cpp b/editors/tea/files/patch-rvln.cpp
new file mode 100644
index 000000000000..4c3685785760
--- /dev/null
+++ b/editors/tea/files/patch-rvln.cpp
@@ -0,0 +1,10 @@
+--- rvln.cpp.orig
++++ rvln.cpp
+@@ -55,6 +55,7 @@
+ #include <QSettings>
+ #include <QLibraryInfo>
+ #include <QCryptographicHash>
++#include <QDebug>
+
+
+ #ifdef PRINTER_ENABLE
diff --git a/editors/tea/pkg-descr b/editors/tea/pkg-descr
index aaef0f5bfeb1..5445adca7444 100644
--- a/editors/tea/pkg-descr
+++ b/editors/tea/pkg-descr
@@ -19,4 +19,4 @@ hundreds of functions. Some of the features include:
- Built-in image viewer (PNG, JPEG, GIF, WBMP, BMP, SVG, TIFF, TGA,
etc.), converter, and resizer
-WWW: http://tea-editor.sourceforge.net/
+WWW: http://semiletov.org/tea/