aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-07 21:51:47 +0800
committerpawel <pawel@FreeBSD.org>2014-04-07 21:51:47 +0800
commit6a7aa5257db87cc645190ec3755b903d1721dd3d (patch)
treea2138cd0dd51359c4759e040f48712bccc9044d0 /editors
parentc5719e529a6e939eab7d6cd1623fa6da81ab2f87 (diff)
downloadfreebsd-ports-gnome-6a7aa5257db87cc645190ec3755b903d1721dd3d.tar.gz
freebsd-ports-gnome-6a7aa5257db87cc645190ec3755b903d1721dd3d.tar.zst
freebsd-ports-gnome-6a7aa5257db87cc645190ec3755b903d1721dd3d.zip
- Add staging support
- Remove leading article from COMMENT
Diffstat (limited to 'editors')
-rw-r--r--editors/tree-widget/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/editors/tree-widget/Makefile b/editors/tree-widget/Makefile
index 5843bfd15964..97ece75afc3b 100644
--- a/editors/tree-widget/Makefile
+++ b/editors/tree-widget/Makefile
@@ -11,31 +11,25 @@ MASTER_SITES= SF/emhacks/${PORTNAME}/${PORTVERSION} \
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A tree widget for Emacs
+COMMENT= Tree widget for Emacs
USE_EMACS= yes
-LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+LISPDIR= ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
NO_WRKSUBDIR= yes
THEMES_SUBDIR= default folder
-NO_STAGE= yes
do-build:
cd ${WRKSRC}; ${EMACS_NAME} -batch -no-site-file\
--eval="(add-to-list 'load-path \"${WRKSRC}\")"\
-f batch-byte-compile *.el
do-install:
- ${MKDIR} ${LISPDIR}
-.for i in *.el *.elc
- ${INSTALL_DATA} ${WRKSRC}/${i} ${LISPDIR}
-.endfor
- ${MKDIR} ${LISPDIR}/tree-widget-themes
-.for i in ${THEMES_SUBDIR}
- ${MKDIR} ${LISPDIR}/tree-widget-themes/${i}
- ${INSTALL_DATA} ${WRKSRC}/tree-widget-themes/${i}/*\
- ${LISPDIR}/tree-widget-themes/${i}
-.endfor
+ @${MKDIR} ${LISPDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.el *.elc ${LISPDIR})
+ @${MKDIR} ${LISPDIR}/tree-widget-themes
+ (cd ${WRKSRC}/tree-widget-themes && ${COPYTREE_SHARE} "${THEMES_SUBDIR}" \
+ ${LISPDIR}/tree-widget-themes)
.include <bsd.port.pre.mk>